Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 22 21:16
    jelson commented #454
  • Jun 22 08:23
    UweBonnes commented #454
  • Jun 22 08:17
    UweBonnes reopened #454
  • Jun 22 08:17
    UweBonnes commented #454
  • Jun 22 01:39
    jelson commented #454
  • Jun 19 16:36
    ofauchon commented #898
  • Jun 19 09:46
    UweBonnes commented #898
  • Jun 18 21:20
    UweBonnes commented #898
  • Jun 18 21:02
    ofauchon commented #898
  • Jun 18 17:03
    UweBonnes commented #832
  • Jun 18 17:03
    UweBonnes opened #898
  • Jun 18 10:13

    UweBonnes on master

    bmp_libusb: Check only for cmsi… Merge pull request #897 from Uw… (compare)

  • Jun 18 10:13
    UweBonnes closed #897
  • Jun 18 09:45
    UweBonnes synchronize #897
  • Jun 18 09:30
    UweBonnes opened #897
  • Jun 14 19:20
    justinmbrock closed #829
  • Jun 13 18:41
    UweBonnes commented #832
  • Jun 12 12:23
    ofauchon commented #832
  • Jun 12 12:16
    ofauchon commented #832
  • Jun 10 09:19
    UweBonnes commented #832
UweBonnes
@UweBonnes
Michael, before sending, take a fresh look at force bootloader entry. It is supposed to work, and I am 99.9 % sure is will work.
Michael N. Moran
@mnmoron
@UweBonnes I don't know what else I can do. Do have any suggestions? It seems to me that I have erased the entire BMP flash, but I could be wrong.
Piotr Esden-Tempski
@esden
Indeed, holding the button while plugging into the computer pretty much always works. Also try shorting the pads of the button, in case the button got crushed and broken due to use and storage.
Michael N. Moran
@mnmoron
@esden Thank you for the link.
Piotr Esden-Tempski
@esden
The bootloader does not allow writing into the bootloader section. I don't know how overwriting the bootloader would happen by accident to be honest.
UweBonnes
@UweBonnes
A close look with a magnifying glass might also be worth a try.
Piotr Esden-Tempski
@esden
@mnmoron please tell me how you found this chat here. So I can fix any link that you might have found. :)
Michael N. Moran
@mnmoron
@esden Google and GitHub (https://github.com/blacksphere/blackmagic). I am using an nRF52840 board from SparkFun for Bluetooth Mesh development. The firmware that came on the BMP does not seem to support the nRF52 completely, so I was attempting to load new firmware built from GitHub.
Piotr Esden-Tempski
@esden
@mnmoron humm... the link in the github repository has the correct link... I guess google still remembers old links for a very long time
if you used dfu-util and the built in bootloader to flash the firmware you can't overwrite the bootloader ...
you should still be able to "force" the bootloader if you hold the button on the BMP and plug it in to the usb port while it is pressed
the only other thing I can imagine is that the button itself is broken
UweBonnes
@UweBonnes
You can not neither erase the bootloader with stm32mem. Michaels original problem was that he loaded the elf file.
Piotr Esden-Tempski
@esden
so the application firmware is corrupt not the bootloader itself
You have to be able to force the bootloader then
the best way to make sure is to take tweezers, short the button pads together and plug in the USB... this should force the bootloader even if the button itself is broken
Michael N. Moran
@mnmoron
I'll give the tweezer trick a try later... now... I must eat. :-)
UweBonnes
@UweBonnes
Good luck and bye!
Michael N. Moran
@mnmoron
@esden The tweezer trick did not work.
chmousset
@chmousset
Hi everyone!
Has anyone managed to make a successful connection to a ZYNQ's CPU?
So far, I've only managed to get blackmagic to (unreliably) 'detect' the PL (FPGA) TAP but that's all...
Piotr Esden-Tempski
@esden
I think it is time for another announcement again. We are moved the chat from Gitter to Discord. Join us on Discord chat for all the fun and information about ongoing projects as well as future support of the BlackMagicProbe hardware and software. You can find the Discord link here: https://1bitsquared.com/pages/chat
@chmousset ^
chmousset
@chmousset
oops, I didn't see that. Will move on discord. Thanks @esden
Alexey Shvetsov
@alexxy
@UweBonnes hi. what do you think about swlink-f4 target i think it can merge f4discovery and hydrabus
Anatol Ulrich
@spookyvision

heyoo :)
I've successfully used a BMP attached to an STMF103 board, but I'm out of luck with STMF411 - the program gets flashed and starts, but gdb apparently has connection issues:

Attaching to program: /Users/ace/play/stm32/f411-leds-2/target/thumbv7em-none-eabihf/release/app, Remote target
0x080061fc in Reset ()
(gdb) load
Loading section .vector_table, size 0x198 lma 0x8000000
Loading section .text, size 0x6100 lma 0x8000198
Loading section .rodata, size 0x1770 lma 0x80062a0
Loading section .data, size 0x4 lma 0x8007a10
Start address 0x80061ca, load size 31244
Transfer rate: 37 KB/sec, 892 bytes/write.
(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /Users/ace/play/stm32/f411-leds-2/target/thumbv7em-none-eabihf/release/app
Running the default executable on the remote target failed; try "set remote exec-file"?

and

0x08006200 in Reset ()
(gdb) load
Loading section .vector_table, size 0x198 lma 0x8000000
Loading section .text, size 0x6100 lma 0x8000198
Loading section .rodata, size 0x1770 lma 0x80062a0
Loading section .data, size 0x4 lma 0x8007a10
Start address 0x80061ca, load size 31244
Transfer rate: 36 KB/sec, 892 bytes/write.
(gdb) s
Single stepping until exit from function Reset,
which has no line number information.
Could not read registers; remote failure reply 'EFF'
Anatol Ulrich
@spookyvision
I've found this issue - relevant? blacksphere/blackmagic#249
Anatol Ulrich
@spookyvision
ok, I should apparently just not use run or s. However c also causes problems: Program terminated with signal SIGLOST, Resource lost.
UweBonnes
@UweBonnes
Did you test the possible resolution I posted in that thread?
Anatol Ulrich
@spookyvision
@UweBonnes which is "try with your cortexm-branch"?
Please move over to discord, as Piotr worte last tim April 13
Anatol Ulrich
@spookyvision
thx! new to this chat, haven't consumed the entire backlog 🙃
Piotr Esden-Tempski
@esden
To keep that post "last thing in the chat, in hopes anyone coming in here sees it first"
I think it is time for another announcement again. We are moved the chat from Gitter to Discord. Join us on Discord chat for all the fun and information about ongoing projects as well as future support of the BlackMagicProbe hardware and software. You can find the Discord link here: https://1bitsquared.com/pages/chat
Maybe a graphical banner would be better. :)
XtracT
@XtracT
Hello! Has someone managed to get the serial gdb server to work through ser2net? The device serial communication I have managed to make it work via tcp/ip, but not the debug port.
Piotr Esden-Tempski
@esden
@XtracT please read the last message before your post.
We are moved the chat from Gitter to Discord. Join us on Discord chat for all the fun and information about ongoing projects as well as future support of the BlackMagicProbe hardware and software. You can find the Discord link here: https://1bitsquared.com/pages/chat
dmitry-pozhidaev
@dmitry-pozhidaev
hi . i try debug stm32l011 and board dont detected
dmitry-pozhidaev
@dmitry-pozhidaev
"apropos word" to search for commands related to "word".
(gdb) set debug remote 1
(gdb) target extended-remote /dev/cu.usbmodemC1CDB7C1
Remote debugging using /dev/cu.usbmodemC1CDB7C1
Sending packet: $qSupported:multiprocess+;swbreak+;hwbreak+;qRelocInsn+;fork-events+;vfork-events+;exec-events+;vContSupported+;QThreadEvents+;no-resumed+#df...Ack
Packet received: PacketSize=400;qXfer:memory-map:read+;qXfer:features:read+
Packet qSupported (supported-packets) is supported
Sending packet: $vMustReplyEmpty#3a...Ack
Packet received:
Sending packet: $!#21...Ack
Packet received: OK
Sending packet: $Hg0#df...Ack
Packet received:
Sending packet: $qXfer:features:read:target.xml:0,3fb#46...Ack
Packet received: E01
Sending packet: $qTStatus#49...Ack
Packet received:
Packet qTStatus (trace-status) is NOT supported
Sending packet: $?#3f...Ack
Packet received: W00
(gdb) mon swdp_scan
Sending packet: $qRcmd,737764705f7363616e#3c...Ack
Packet received: O54617267657420766f6c746167653a20414253454e54210a
Target voltage: ABSENT!
Packet received: O53572d4450207363616e206661696c6564210a
SW-DP scan failed!
Packet received: E
(gdb)
how make black box for code insert here?
UweBonnes
@UweBonnes
Why don't you care to read at least one posting above?
Double check your setup and connections. When running with BMP native, enable power "mon tpwr ena". Report back on discord.
Piotr Esden-Tempski
@esden
@dmitry-pozhidaev See the last message before your post. ;)
We have moved the chat from Gitter to Discord. Join us on Discord chat for all the fun and information about ongoing projects as well as future support of the BlackMagicProbe hardware and software. You can find the Discord link here: https://1bitsquared.com/pages/chat
chriskuku
@chriskuku

I compiled blackmagic under macOS make PROBE_HOSTED=hosted HOSTED_BMP_ONLY=1 today in order to get a hosted blackmagic connecting to an STLINK-V2 attached to my computer. Compilation went through this time after recent patches.

But I'm wondering why I don't get any native binary to run on my host (macOS). Or do I misunderstand sth.?

Could someone give me the Discord discussion forum link? Or whereelse do blackmagic discussions take place ?
chriskuku
@chriskuku
@chriskuku Sorry, forget about my post. I made a typo (PROBE_HOSTED instead of PROBE_HOST)
chriskuku
@chriskuku
Where can I find information about the innards of blackmagic? Especially, what is negotiated between gdb and the debugee (target) ?
UweBonnes
@UweBonnes
The link is about 10 lines above your post. "You can find the Discord link here: https://1bitsquared.com/pages/chat"