Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 04 13:42
    rafinhacp commented #189
  • Dec 04 02:32
    lychen83 opened #233
  • Nov 30 15:33
    AdamStuckert commented #189
  • Nov 29 23:12
    rafinhacp commented #189
  • Nov 29 23:12
    rafinhacp commented #189
  • Nov 12 09:42
    dpryan79 commented #216
  • Oct 30 14:13
    zolotarovgl opened #232
  • Oct 23 20:58
    macmanes commented #231
  • Oct 23 20:58
    rafaeltiveron edited #231
  • Oct 23 20:57
    rafaeltiveron opened #231
  • Sep 09 16:24
    tbg04 commented #229
  • Sep 06 09:15
    Shellfishgene closed #230
  • Sep 06 09:15
    Shellfishgene commented #230
  • Sep 05 13:20
    macmanes commented #230
  • Sep 05 13:18
    Shellfishgene commented #230
  • Sep 05 13:01
    macmanes commented #230
  • Sep 05 12:48
    Shellfishgene opened #230
  • Aug 31 14:21
    rafaeltiveron commented #187
  • Aug 31 14:05
    rafaeltiveron commented #187
  • Aug 07 20:01
    akcorut starred blahah/transrate
Abhijeet Shah
@abshah
@blahah @rob-p, bump!
Rik
@blahah
@abshah sorry I haven't been getting notifications from this channel for some reason
Yes you should be able to do that. It's not a perfect filter but it fits the "quick and dirty" requirement :)
Anton Kulaga
@antonkulaga
I have misterious "terminal_columns': undefined methodwinsize' for nil:NilClass " when I run transrate blahah/transrate#216
AsterChen
@AsterChen
Hi. I recently used transrate to check my transcriptome assemblies derived from Trinity and the assembly scores were incredibly low (around 0.02). I dont know whether I did something wrongly when I run the program or my assemblies are really bad. I once changed my read files manually from .fastqsanger to .fastq since transrate seems doesnt recognize .fastqsanger. Is that a problem?
svanscarfo
@svanscarfo

Hi,
I've installed transrate on my mac to assess the quality of different assemblies. Everything seem to work fine for the contig metrics (2sec for 38K contigs ranging from 200-15000bp). This effectively run either with example data or my own assemblies. However, when I tried to run the read mapping metric analysis (with example data or my assemblies), no (INFO) lines appear below my command line, Additionally Salmon PID seems to run in loop with really memory usage in TOP (99-100% USAGE / 532K memory) and the Global CPU usage is not more than 5% in the activiy monitor. I've tried to move the transrate folder in other locations with no success. Could you please help me on that.

Thanks.

Muskaann
@Muskaann
Hi All, I am getting a really low assembly score (0.13) for my seagrass transcriptome. I was wondering how many plant transcriptomes were assessed using TransRate and if we have information on scores from maybe the "model" plants for me to compare my scores to? I know that a score closest to 1 is the best but do we have something that is an ok score? Thanks.
Matt MacManes
@macmanes
hi @Muskaann, you can see the ORP protocol (https://www.biorxiv.org/content/early/2017/11/22/177253), and corresponding data (https://github.com/macmanes-lab/Oyster_River_Protocol/blob/master/manuscript/orp.csv) for several plant species. In the csv, the score columns show the scores for the different assemblers, and the opt columns are the optimal scores.
Muskaann
@Muskaann
@macmanes Thank you so much for the links. I will also try to use ORP protocol and see if it improves my assembly.
Matt MacManes
@macmanes
@Muskaann let me know if you have difficulties with the ORP.
PauloFlores
@PauloFlores
Hi blahah. I performed a mega RNA-Seq assembly (>800 samples, 16 billion of reads, mapped to my plant genome produced near 180,000 contigs) and now I'm trying to filter the results based on Transrate. I'm doing a few tests to understand the resources/running time required (mapping reads to the contigs and inspecting the alignments), and just testing with 10% of the reads apparently I'll need more than 1 week (32 threads) to get the results. "Calculating read diagnostics..." was the last message. Any advice how to increase the speed or how to run transrate with this amount of data?
Anton Kulaga
@antonkulaga
I hope you will manage to run it. I tried to run it many times on my data and failed
PauloFlores
@PauloFlores
Hi Anton. The size of the dataset maybe is not a problem, perhaps splitting the contigs in smaller datasets solves the situation. However, Salmon is not working (TPMs are zero) and I have no idea why...and finally - how to use the scores to filter the results??
Jochen Bick
@bimbam23
Hi, is there any limit to the size of the fastq files? I'm running two 70GB files versus a big assembly. Somehow it looks like the program got stuck. I can see any movements in the output folder. it looks like the snap-aligner ran into some trouble
Danielle DeLeo
@DeLeoDM_twitter
Hi- I am trying to assess the quality of a reference transcriptome assembly that was assembled with trinity using a sample.tsv file containing paths to replicate (n=5) read files (paired-end). I am hoping to get information about the assembly score with transrate, but am unsure of how to run the read metrics mode (--left --right) with multiple sample files. Is there a way to use this sample.tsv file or list multiple files?
Jochen Bick
@bimbam23
the error message is: [ERROR] 2018-03-12 16:47:36 : Snap failed
Welcome to SNAP version 1.0dev.96.
@DeLeoDM_twitter --left=<s> Left reads file(s) in FASTQ format, comma-separated
--right=<s> Right reads file(s) in FASTQ format, comma-separated
comma-separated should work
Grant Batzel
@grant_batzel_twitter
how long does transrate take to run? I have 90M reads in my forward file and 90 million reads in my reverse. I'm currently running transrate on a computer with 40 CPUs and 160G memory
TepoltC
@TepoltC
@svanscarfo, I think I'm having the same issue. On a Mac Pro, transrate's read mapping analysis doesn't appear to multithread even when I specify multiple threads in the command. Instead, it sits at the salmon stage, using a single thread and taking FOREVER (with no info printout). Did you figure out a solution? Does anyone else have any suggestions? Would love to use transrate but I think it's untenable on a single thread.
Grant Batzel
@grant_batzel_twitter
update: took me 90 minute to run transrate on my assembly
PauloFlores
@PauloFlores
--threads worked fine (linux) with me. Snap is slower than Salmon but 90 million reads shouldnt take very long - couple of hours?
Urwah Nawaz
@urwahnawaz_twitter
Hi all, I've generated a de novo assembly using Trinity and used TransRate to evaluate the accuracy. My transRate score turned out to be very low (0.03). I used other metrics as well (BUSCO, back mapping, ExN50), and so far they all look good. I wanted to know if TransRate would be good for my species (I'm sequencing a cephalopod and they are known to have a highly repetitive content). Any advice on this would be great :)
jereBrand
@Jeremias-Brand
Hi, all. I am running transrate on multiple assemblies simultaneously as part of a large snakemake pipeline. For this I limit threads for each run to a fraction of total cores used. Transrate seems to then only use the global limit. If I run 3 runs with 10 cpus assigned each then all 3 transrate runs will be executed at the same time but only using 10 cores. This is really slowing down the whole pipeline. Any suggestions on how to fix that?=
@blahah
Stuart Willis
@stuartwillis
@blahah is there a 'simple' reason why scores would be different between 1.0.1 (w/ salmon 0.4.2) and 1.0.3 (w/ salmon 0.6.0) for the same assembly? The fragments mapped etc. are much lower for 1.0.3 (e.g. 0.91 vs. 0.29). I tried to swap in the most recent salmon (0.9.?) to see what effect that had but transrate returned 'missing 0.6.0'. Any thoughts?
Rik
@blahah
@stuartwillis sorry for the slow reply. Yes - there's a bug in 1.0.3 - trust the scores from 1.0.1. I'm afraid I've been completely out of action for medical reasons now for going on 10 months. I have along backlog of work to catch up, and am not paid to work on this, but I will get around to releasing a new version with all bugs fixed
in the meantime I suggest following @macmanes procedures for using transrate - he has figured a nice way to include it in a workflow avoiding the pitfalls that have accumulated due to my absence
@macmanes do you have a link to your protocol? I'll add it to the welcome message for this channel
sdbaney
@sdbaney
Does transrate not read fastqsanger files? My downloaded trimmed files from galaxy are downloaded as fastqsanger but every time I try to run transrate with these files, it crashes, and gives me an error. When i run the --assembly with the raw read fastq formatted files, it runs fine. Do I need to somehow convert my trimmed files from fastqsanger to fastq?
Matt MacManes
@macmanes
I usa transrate at the end of the protocol to evaluate the assembly.
if you install the package, you could just use the version of transrate that is included.
tho... I do recommend you use all of the ORP. It has been shown to produce better assemblies that any one standalone assembler (of the ones tested - SPAdes, Shannon, Trinity).
Happy to answer questions about the package, help install, run, etc.
Sandra Victoria Gómez Gutiérrez
@sgomezgu_gitlab
Hi everybody! How are you. Scuse me. I would want to know if you have some solution for this problem. I get this error every time I try run transrate:
Dependencies are missing:
  • blastplus (2.2.[0-9])
    To install all missing dependencies, run:
    transrate --install-deps all
    If you only want the read-metrics dependencies:
    transrate --install-deps read
    Or if you only want the reference-metrics dependencies:
    transrate --install-deps ref
    and when I try to download dependencies I write --install-deps all to install reference module because I want to compare two assamblies. But I get this error:
[ERROR] 2018-07-26 11:26:56 : install-deps all is not valid. You must specify one of: ref.
Muhammad Arslan
@arsilan324_twitter
Hi. I am getting this error. Can someone help?
Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: tlsv1 alert protocol version (https://rubygems.org/latest_specs.4.8.gz)
lmfaber
@lmfaber
Hey everyone,
Since this thread seems to be a little bit more active than the github repository, I'll try my luck here.
I need to use Transrate in my current project (in a conda environment), but i couldn't find a working recipe anywhere.
I managed to create a working conda build (tested and working for me on two different machines). Everyone interested can get and test it from here: https://anaconda.org/lmfaber/transrate
There are currently version 1.0.3 and 1.0.1. If this is working as well for someone else, I would really appreaciate some feedback.
I could further provide the recipes if @blahah is interested?
Cheers
Rik
@blahah
thanks so much @lmfaber !
if you could publish them on github that would be great
and we can link to them if people need them
lmfaber
@lmfaber
@blahah I uploaded the recipes here: https://github.com/lmfaber/transrate_conda Feel free to use them as you need. Would be nice to see them on the bioconda channel sometime. Not the cleanest install, since I'm new to conda. There are many errors during the conda-build process, but however that doesn't affect the functionality. Cheers
Rik
@blahah
thanks very much @lmfaber
PersillaQ
@PersillaQ
Hi @blahah! I installed transrate with lmfaber's conda recipe (thanks!) without any error messages. It seems to work correctly. My analysis gives strange results insofar as I have high mapping rates with both bowtie2 and SNAP (i.e. >90%) but the transtransrate mapping stats are poor with <50% fragments aligned and 100% uncovered transcript. SNAP resports ~40% with a MAPQ>=10, and ~50% with a MAPQ<10. Could this be related (i.e. reads with MAPQ<10 are not counted as aligned?)? Thanks for helping!
Matthew A. Birk
@matthewabirk
@blahah @stuartwillis It looked like transrate v 1.0.4 was on the brink of coming out in April 2017 with the Salmon upgrade (0.4.0 → 0.8.2), but I can't find access to this version. Has this release been made? Are there any plans to release it? Thanks!
matemosaike
@matemosaike
Just wondering if Transrate works with Single-end RNA Seq reads?
Matt MacManes
@macmanes
no it does not
matemosaike
@matemosaike
Do you know any software that does similar analyses for Single-end Reads?
Yogesh Gupta
@bioinfonext_gitlab
I am trying to use Transrate to remove chimeric and low quality contigs from de novo assembly. What should be the cutoff to remove these artifacts from de novo assembly