Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 02 16:06
    sericomyxa starred blahah/transrate
  • Apr 15 12:51
    alermol starred blahah/transrate
  • Mar 23 22:42
    pmomadeira commented #241
  • Mar 23 22:41
    pmomadeira commented #241
  • Mar 23 19:54
    sericomyxa commented #241
  • Mar 23 19:54
    sericomyxa commented #241
  • Mar 01 19:06
    pmomadeira commented #241
  • Mar 01 17:16
  • Mar 01 16:21
  • Mar 01 14:22
    blahah commented #241
  • Mar 01 13:43
    pmomadeira commented #241
  • Mar 01 13:09
    pmomadeira commented #241
  • Feb 18 07:25
    Simon6089 starred blahah/transrate
  • Nov 27 2021 17:35
    Tina-L-Nguyen opened #245
  • Nov 10 2021 10:45
    timslittle closed #244
  • Nov 10 2021 10:45
    timslittle commented #244
  • Nov 09 2021 15:45
    timslittle opened #244
  • Nov 08 2021 16:27
    ndaluthge commented #240
  • Nov 08 2021 09:51
    dpgrape commented #240
  • Nov 08 2021 09:51
    dpgrape commented #240
Rik
@blahah
and we can link to them if people need them
lmfaber
@lmfaber
@blahah I uploaded the recipes here: https://github.com/lmfaber/transrate_conda Feel free to use them as you need. Would be nice to see them on the bioconda channel sometime. Not the cleanest install, since I'm new to conda. There are many errors during the conda-build process, but however that doesn't affect the functionality. Cheers
Rik
@blahah
thanks very much @lmfaber
PersillaQ
@PersillaQ
Hi @blahah! I installed transrate with lmfaber's conda recipe (thanks!) without any error messages. It seems to work correctly. My analysis gives strange results insofar as I have high mapping rates with both bowtie2 and SNAP (i.e. >90%) but the transtransrate mapping stats are poor with <50% fragments aligned and 100% uncovered transcript. SNAP resports ~40% with a MAPQ>=10, and ~50% with a MAPQ<10. Could this be related (i.e. reads with MAPQ<10 are not counted as aligned?)? Thanks for helping!
Matthew A. Birk
@matthewabirk
@blahah @stuartwillis It looked like transrate v 1.0.4 was on the brink of coming out in April 2017 with the Salmon upgrade (0.4.0 → 0.8.2), but I can't find access to this version. Has this release been made? Are there any plans to release it? Thanks!
matemosaike
@matemosaike
Just wondering if Transrate works with Single-end RNA Seq reads?
Matt MacManes
@macmanes
no it does not
matemosaike
@matemosaike
Do you know any software that does similar analyses for Single-end Reads?
Yogesh Gupta
@bioinfonext_gitlab
I am trying to use Transrate to remove chimeric and low quality contigs from de novo assembly. What should be the cutoff to remove these artifacts from de novo assembly
_fantasticDev_
@SnakeGeneral
Hello everyone!
I want to change a simple asm code to c++ code.
but I am facing problems...
please help me
transparency:
mov eax,00000000
in here transparency is address.
VanesaSGT
@VaneSGT
Hello all,
I'm beginner with this bioinformatic tools and I'm trying to install transrate. The installations seems to be OK, but when I try to run an analysis with the example dataset I get this error:
[ERROR] 2020-04-22 12:10:41 : ReadMetrics: could not find bam-read in path
it happen before with snap but error was solved when I have installed the snap-aligner dependency.
However my problem is that I cannot find a good recipe or channel to install bam-read
Im working on MacOS 10.14
I also tried to load the tar file, but honestly I don't know how to do this manual installation
I will appreciate if someone can help me
VS
Christine Florece
@cmflrc_gitlab
Hi. I am trying to install transrate via conda and it showed me this error:
PackagesNotFoundError: The following packages are not available from current channels:
  • transrate
  • ruby[version='>=2,>=2.6.5,<2.7.0a0']
VanesaSGT
@VaneSGT
you can download the tar file for your system and then keep the path before run the analysis
I have had the same problem. Seems conda only works for linux
VanesaSGT
@VaneSGT
Now I have another problem. I followed the instructions. I extracted the binaries etc.. Now transrate seems to run well but is not. I tested the run with an assembly that I already analyzed in transrate but in our ssh server (transrate works perfectly there). The results for the assembly metrics are good, but the read base metrics are totally different and very bad, means, 98% contigs good for the analysis done in the ssh server, and 15% contigs good with transrate installed in my mac. NO error messages!,
Anybody knows what happen?
Rik
@blahah
@VaneSGT hey, sorry for the issues you've been having. Transrate is quite out of date now, as I've been unable to maintain it for a few years
I saw you posted a github issue - if you can add all your problems there I can at least try to help you run it
VanesaSGT
@VaneSGT
Thanks Rik, I appreciate!
VanesaSGT
@VaneSGT
In future I will post all my problems there ;)
C
@mflc18_twitter
Hi all, I installed all the dependencies needed. However, it says that Salmon is not installed but upon checking on the bin folder of transrate, Salmon is there but as a link. Now, the problem persists every time I run a job.
Joshua Orvis
@jorvis
Same. Does yours error also when you just try to run salmon without arguments?
Abhijeet Shah
@abshah
Hi TransRate users, I too have encountered errors with Salmon (in recent versions of Salmon, the run flags have been changed), and I have managed to fix them. I can post a patch file in the next few days. I hope this can help other TransRate users.
Joshua Orvis
@jorvis
That's great!
Abhijeet Shah
@abshah
Hi TransRate Users, I have finally gotten around uploading my patch to github. I am not sure how well this might work on other systems. Please let me know if you encounter similar errors. I am sure we can figure them out. https://github.com/abshah/transrate
And thanks @jorvis for testing it out first !
Bikash Shrestha
@bshrestha0

I am getting following error while running TransRate,
Dependencies are missing:

  • salmon (0.6.0)
    You are running the packaged version of transrate
    This comes with the read-metrics dependencies pre-installed.

So, I git cloned the patch you have distributed above. I am getting following error while running command $ gem build transrate.gemspec

ERROR: While executing gem ... (Gem::InvalidSpecificationException)
duplicate dependency on bindeps (>= 1.2.1, ~> 1.2, development), (>= 1.2.1, ~> 1.2) use:
add_runtime_dependency 'bindeps', '>= 1.2.1, ~> 1.2', '>= 1.2.1, ~> 1.2'
/usr/lib64/ruby/2.1.0/rubygems/specification.rb:2608:in block in validate_dependencies' /usr/lib64/ruby/2.1.0/rubygems/specification.rb:2606:ineach'
/usr/lib64/ruby/2.1.0/rubygems/specification.rb:2606:in validate_dependencies' /usr/lib64/ruby/2.1.0/rubygems/specification.rb:2589:invalidate'
/usr/lib64/ruby/2.1.0/rubygems/package.rb:230:in build' /usr/lib64/ruby/2.1.0/rubygems/package.rb:114:inbuild'
/usr/lib64/ruby/2.1.0/rubygems/commands/build_command.rb:48:in execute' /usr/lib64/ruby/2.1.0/rubygems/command.rb:305:ininvoke_with_build_args'
/usr/lib64/ruby/2.1.0/rubygems/command_manager.rb:167:in process_args' /usr/lib64/ruby/2.1.0/rubygems/command_manager.rb:137:inrun'
/usr/lib64/ruby/2.1.0/rubygems/gem_runner.rb:54:in run' /usr/bin/gem:21:in<main>'

And if I try to run tranrate without building it, I get this error:

/usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- transrate (LoadError) from /usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:inrequire'
from /work/03125/bikash/phylogenomic/transrate/bin/transrate:2:in `<main>'

Any help/suggestions is greatly appreciated.

Thanks!

KDRichar
@KDRichar

Hi Transrate team,
I received the following error
Unmatched read IDs 'A00774R:152:GW2105151182nd:4:1104:17598:2534 00' and 'A00774R:152:GW2105151182nd:4:1102:9453:21308 00'. Use the -I option to ignore this.

However when I pass "-I_ to my command it says
Error: unknown argument '-I'.

Hans-v-V
@Hans-v-V
Hi Transrate team and user, I am new to transrate and would like to download the binary. But the link seems outdated (redirects to some Jfrog site). Is binary support discontinued?, is Ruby compilation the only way froward?
mokshadashah
@mokshadashah
Hi I installed transrate via "gem install transrate" command but it isn't installing the latest version and the link to download like mentioned above has been removed
To merge assemblies getting the zip undefined methoderror in version 1.0.1
so need the latest version
ariariari
@ariariari:matrix.org
[m]

Hi, I have tried to install transrate via conda using " conda install -c bioconda transrate" but i received the following error message:

UnsatisfiableError: The following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.31=0
  • transrate -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.31.

I am new to transcriptome assembly and I am not sure how I can fix this error. I wanted to download via the link provided on the transrate website but it seems to be no longer valid. I would like to know how to either rectify this error or other ways to download transrate other than using ruby. Thank you so much!

jorgeibarracaballero
@jorgeibarracaballero
Hello. I tried to download transrate today but I got a message saying that it is not longer available. Where or how can I get it? Thanks