Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
Repo info
  • Jul 02 17:47
    OrToR-KJM starred blahah/transrate
  • Jun 01 03:36
    huangkai0518 starred blahah/transrate
  • May 28 02:31
    raymond-u starred blahah/transrate
  • May 02 16:06
    sericomyxa starred blahah/transrate
  • Apr 15 12:51
    alermol starred blahah/transrate
  • Mar 23 22:42
    pmomadeira commented #241
  • Mar 23 22:41
    pmomadeira commented #241
  • Mar 23 19:54
    sericomyxa commented #241
  • Mar 23 19:54
    sericomyxa commented #241
  • Mar 01 19:06
    pmomadeira commented #241
  • Mar 01 17:16
  • Mar 01 16:21
  • Mar 01 14:22
    blahah commented #241
  • Mar 01 13:43
    pmomadeira commented #241
  • Mar 01 13:09
    pmomadeira commented #241
  • Feb 18 07:25
    Simon6089 starred blahah/transrate
  • Nov 27 2021 17:35
    Tina-L-Nguyen opened #245
  • Nov 10 2021 10:45
    timslittle closed #244
  • Nov 10 2021 10:45
    timslittle commented #244
  • Nov 09 2021 15:45
    timslittle opened #244
Christine Florece
Hi. I am trying to install transrate via conda and it showed me this error:
PackagesNotFoundError: The following packages are not available from current channels:
  • transrate
  • ruby[version='>=2,>=2.6.5,<2.7.0a0']
you can download the tar file for your system and then keep the path before run the analysis
I have had the same problem. Seems conda only works for linux
Now I have another problem. I followed the instructions. I extracted the binaries etc.. Now transrate seems to run well but is not. I tested the run with an assembly that I already analyzed in transrate but in our ssh server (transrate works perfectly there). The results for the assembly metrics are good, but the read base metrics are totally different and very bad, means, 98% contigs good for the analysis done in the ssh server, and 15% contigs good with transrate installed in my mac. NO error messages!,
Anybody knows what happen?
@VaneSGT hey, sorry for the issues you've been having. Transrate is quite out of date now, as I've been unable to maintain it for a few years
I saw you posted a github issue - if you can add all your problems there I can at least try to help you run it
Thanks Rik, I appreciate!
In future I will post all my problems there ;)
Hi all, I installed all the dependencies needed. However, it says that Salmon is not installed but upon checking on the bin folder of transrate, Salmon is there but as a link. Now, the problem persists every time I run a job.
Joshua Orvis
Same. Does yours error also when you just try to run salmon without arguments?
Abhijeet Shah
Hi TransRate users, I too have encountered errors with Salmon (in recent versions of Salmon, the run flags have been changed), and I have managed to fix them. I can post a patch file in the next few days. I hope this can help other TransRate users.
Joshua Orvis
That's great!
Abhijeet Shah
Hi TransRate Users, I have finally gotten around uploading my patch to github. I am not sure how well this might work on other systems. Please let me know if you encounter similar errors. I am sure we can figure them out. https://github.com/abshah/transrate
And thanks @jorvis for testing it out first !
Bikash Shrestha

I am getting following error while running TransRate,
Dependencies are missing:

  • salmon (0.6.0)
    You are running the packaged version of transrate
    This comes with the read-metrics dependencies pre-installed.

So, I git cloned the patch you have distributed above. I am getting following error while running command $ gem build transrate.gemspec

ERROR: While executing gem ... (Gem::InvalidSpecificationException)
duplicate dependency on bindeps (>= 1.2.1, ~> 1.2, development), (>= 1.2.1, ~> 1.2) use:
add_runtime_dependency 'bindeps', '>= 1.2.1, ~> 1.2', '>= 1.2.1, ~> 1.2'
/usr/lib64/ruby/2.1.0/rubygems/specification.rb:2608:in block in validate_dependencies' /usr/lib64/ruby/2.1.0/rubygems/specification.rb:2606:ineach'
/usr/lib64/ruby/2.1.0/rubygems/specification.rb:2606:in validate_dependencies' /usr/lib64/ruby/2.1.0/rubygems/specification.rb:2589:invalidate'
/usr/lib64/ruby/2.1.0/rubygems/package.rb:230:in build' /usr/lib64/ruby/2.1.0/rubygems/package.rb:114:inbuild'
/usr/lib64/ruby/2.1.0/rubygems/commands/build_command.rb:48:in execute' /usr/lib64/ruby/2.1.0/rubygems/command.rb:305:ininvoke_with_build_args'
/usr/lib64/ruby/2.1.0/rubygems/command_manager.rb:167:in process_args' /usr/lib64/ruby/2.1.0/rubygems/command_manager.rb:137:inrun'
/usr/lib64/ruby/2.1.0/rubygems/gem_runner.rb:54:in run' /usr/bin/gem:21:in<main>'

And if I try to run tranrate without building it, I get this error:

/usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- transrate (LoadError) from /usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:inrequire'
from /work/03125/bikash/phylogenomic/transrate/bin/transrate:2:in `<main>'

Any help/suggestions is greatly appreciated.



Hi Transrate team,
I received the following error
Unmatched read IDs 'A00774R:152:GW2105151182nd:4:1104:17598:2534 00' and 'A00774R:152:GW2105151182nd:4:1102:9453:21308 00'. Use the -I option to ignore this.

However when I pass "-I_ to my command it says
Error: unknown argument '-I'.

Hi Transrate team and user, I am new to transrate and would like to download the binary. But the link seems outdated (redirects to some Jfrog site). Is binary support discontinued?, is Ruby compilation the only way froward?
Hi I installed transrate via "gem install transrate" command but it isn't installing the latest version and the link to download like mentioned above has been removed
To merge assemblies getting the zip undefined methoderror in version 1.0.1
so need the latest version

Hi, I have tried to install transrate via conda using " conda install -c bioconda transrate" but i received the following error message:

UnsatisfiableError: The following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.31=0
  • transrate -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.31.

I am new to transcriptome assembly and I am not sure how I can fix this error. I wanted to download via the link provided on the transrate website but it seems to be no longer valid. I would like to know how to either rectify this error or other ways to download transrate other than using ruby. Thank you so much!

Hello. I tried to download transrate today but I got a message saying that it is not longer available. Where or how can I get it? Thanks