These are chat archives for boostorg/hana

14th
Apr 2017
Shreyans
@shreyans800755
Apr 14 2017 21:26

I have ruby installed on my system.
And ruby -v gives the following output:
ruby 2.2.6p396 (2016-11-15 revision 56800) [x86_64-linux-gnu]

But when I run cmake command to build hana, I'm getting following warning:
-- Could NOT find Ruby (missing: RUBY_INCLUDE_DIR RUBY_LIBRARY RUBY_CONFIG_INCLUDE_DIR) (found suitable version "2.2.0", minimum required is "2.1")
CMake Warning at benchmark/CMakeLists.txt:10 (message):
Ruby >= 2.1 was not found; the benchmarks will be unavailable.

I think it is able to find the proper ruby version, but still not considering 2.2.0 as later version compared to 2.1.

Louis Dionne
@ldionne
Apr 14 2017 21:27
Hmm. Can you file an issue on github please? I’ll look into it.
Shreyans
@shreyans800755
Apr 14 2017 21:27
Not sure whether this issue is due to hana or because of inappropriate setup on my system.
Sue
Sure
Louis Dionne
@ldionne
Apr 14 2017 21:27
Probably Hana / CMake is something doing wrong.
Shreyans
@shreyans800755
Apr 14 2017 21:34
@ldionne filed at boostorg/hana#337
Louis Dionne
@ldionne
Apr 14 2017 23:21
Thank you. Will have a look