These are chat archives for brunchboy/afterglow

9th
Feb 2018
Joen Tolgraven
@tolgraven
Feb 09 2018 14:52
So taken the launch of live10 and promised m4l efficiency improvements to dig into the max side of things. Got afterglow-max set up from snapshot and running in max8 without too much hassle, awesome! Got two issues right away tho. Afterglow can't connect to the push2 while the script active in ableton, nor will the script function if activated after afterglow has connected. I'm guessing due to the updates somehow but it's weird considering they're on separate ports, no?
Joen Tolgraven
@tolgraven
Feb 09 2018 16:25
And the other snafu is in .Cue where certain bangs (originating from eg using sel on incoming messages, as opposed to clicks) makes it throw, due to usage of the com.cycling74.max MaxObject Atom which can't be found. Both in max8/snapshot and max7/0.2.1 precompiled. Any clue why?
James Elliott
@brunchboy
Feb 09 2018 16:28
I’m not sure what you mean by separate ports, but I haven’t tried combining Max, afterglow, and Live at the same time, so there may be some contention. I haven’t seen that exception either, but I have Max 7.3.4. Cycling ’74 deprecated the Max/Java binding even before Ableton bought them, so perhaps you are starting to run into breakages?
Joen Tolgraven
@tolgraven
Feb 09 2018 18:01
Oh I mean like it's trying and failing to connect to the User port, the live script uses the Live port. Hmm yeah was thinking it was something about the new max version/binding or a paths issue but like I said I tested with max7 and your precompiled jar and had the same problem