These are chat archives for canjs/canjs

18th
Jan 2016
Andrei Balmus
@abalmush
Jan 18 2016 14:27
Huy guys, I updated my npm packages including can.js and now I’m getting the error in the console
Screen Shot 2016-01-18 at 4.20.48 PM.png
it comes from /*can@2.2.9#util/jquery/jquery*/
i cant revert my old node_modules folder as i added it to git ignore
Guido Smeets
@gsmeets
Jan 18 2016 15:09
That's jquery
Not canjs
Try jquery latest-1 ;)
Andrei Balmus
@abalmush
Jan 18 2016 15:41
thanks @gsmeets, i will check this right now
Guido Smeets
@gsmeets
Jan 18 2016 15:58
Technically that's canjs calling an undocumented jquery function that they're going to remove, but they'll postpone that till 3.0. But there is a jquery version out there now without that method
Andrei Balmus
@abalmush
Jan 18 2016 16:04
yes, exactly I downloaded old node_modules from our CI to my local environment ant everything looks good
can.js uses jquery 1.12.0 which is without that method
Screen Shot 2016-01-18 at 6.06.45 PM.png
Andrei Balmus
@abalmush
Jan 18 2016 16:12
I worry If I will have same issue on our production environment after next build :worried:
Guido Smeets
@gsmeets
Jan 18 2016 16:15
You can force it to jq1.11 probably, can't you?
Andrei Balmus
@abalmush
Jan 18 2016 16:29
I’m not sure how to make it correctly in my package json
I will take a look how to override it