These are chat archives for canjs/canjs

19th
Jan 2016
Andrei Balmus
@abalmush
Jan 19 2016 13:04

Hi guys I updated “can" from 2.2.9 to 2.3.10 and now when I run gulp I’m getting this error:

node_modules/can/dist/cjs/map/define/define.js Line 15: Illegal return statement
You may need an appropriate loader to handle this file type.
| require('../../compute/compute.js');
| if (can.define) {
|     return;
| }
| var define = can.define = {};
 @ ./~/can/dist/cjs/can.js 13:0-33

is it something that I can fix? i’m using webpack, please help.

Matthew Phillips
@matthewp
Jan 19 2016 17:15
@abalmush looks like a webpack issue: webpack/webpack#67
Andrei Balmus
@abalmush
Jan 19 2016 19:08
thank you @matthewp, I will try to update webpack maybe this fix my problem
Alex
@whitecolor
Jan 19 2016 22:12
@abalmush update it to stealJs)