These are chat archives for canjs/canjs

1st
Apr 2016
Mason Shin
@minsooshin
Apr 01 2016 16:25
Does anyone knows how to use eslint with steal-tools?
Parsing error: 'import' and 'export' may appear only with 'sourceType: module'
I am getting this error when I run the eslint validating
As I see, canjs and stealjs are using only jshint. Not using eslint, yet.
Morgan Heimbeck
@Xitstrategies
Apr 01 2016 16:31
I use eslint, I just use babel.
Mason Shin
@minsooshin
Apr 01 2016 16:31
hum… you mean you installed babel to your package.json?
I am using babel as transpiler of system
Morgan Heimbeck
@Xitstrategies
Apr 01 2016 16:32
yeah, I am also using it for my es6 to es5 in steal instead of traceur
Mason Shin
@minsooshin
Apr 01 2016 16:32
that’s what I also use in the app
“transpiler”: “babel”
top of it, I need to add “babel” as dependencies?
Morgan Heimbeck
@Xitstrategies
Apr 01 2016 16:33
are you using a .eslintrc file?
Mason Shin
@minsooshin
Apr 01 2016 16:34
yes
Morgan Heimbeck
@Xitstrategies
Apr 01 2016 16:34
parser should be set to babel-eslint, include that. npm install --save-dev babel-eslint
Mason Shin
@minsooshin
Apr 01 2016 16:34
oh...
let me try
Mason Shin
@minsooshin
Apr 01 2016 16:40
ah..this is not task runner module