These are chat archives for canjs/canjs

14th
Dec 2016
Thomas Sieverding
@Bajix
Dec 14 2016 00:00
Well that works too
That’s how it works ^
Or at least that would clarify
Kevin Phillips
@phillipskevin
Dec 14 2016 00:01
thanks
Thomas Sieverding
@Bajix
Dec 14 2016 00:11
@phillipskevin I don’t suppose you could do a release w/ canjs/steal-stache#11 & canjs/can-connect#210 merged?
Kevin Phillips
@phillipskevin
Dec 14 2016 00:11
individual releases of those? or a canjs/canjs release?
Thomas Sieverding
@Bajix
Dec 14 2016 00:11
Just those
They are forcing an older version of jQuery
Kevin Phillips
@phillipskevin
Dec 14 2016 00:12
yeah
sorry, yeah I know that’s the issue
let me see if I can get added to steal-stache
Thomas Sieverding
@Bajix
Dec 14 2016 00:12
Cool thanks
Kevin Phillips
@phillipskevin
Dec 14 2016 00:14
any reason to use ^3.1.1 || ^2.2.4 instead of 2.x - 3.x
Thomas Sieverding
@Bajix
Dec 14 2016 00:15
When I had tested it on steal-stache, 2.x - 3.x was installing 2.2.4, but perhaps that was from the circular reference with can-view-imports
There doesn’t seem to be any good reason to support older 3.x or 2.x
I was hoping that this syntax would be better for Travis CI
Kevin Phillips
@phillipskevin
Dec 14 2016 00:17
just that people might already have them as dependencies
Thomas Sieverding
@Bajix
Dec 14 2016 00:17
That wouldn’t matter
Kevin Phillips
@phillipskevin
Dec 14 2016 00:18
I don’t think I’ll be able to release them today
Thomas Sieverding
@Bajix
Dec 14 2016 00:19
Is that just because of the above?
What I mean to say is that it’s a non-issue with people already having them as dependencies as the existing projects would be semantically compatible anyway
Kevin Phillips
@phillipskevin
Dec 14 2016 00:23
yeah, I understand what you mean
just not sure if @justinbmeyer cares one way or the other
so I’d rather have him dismiss his review
also, it’s time for dinner
Thomas Sieverding
@Bajix
Dec 14 2016 00:25
I can just do 2.x - 3.x if that means we can release ASAP
Kevin Phillips
@phillipskevin
Dec 14 2016 00:27
ok, sure
Thomas Sieverding
@Bajix
Dec 14 2016 00:28
Done
Kevin Phillips
@phillipskevin
Dec 14 2016 00:33
Thomas Sieverding
@Bajix
Dec 14 2016 00:33
Sweeetness
Thank you sir! Now I can live in the world of real Promises :D
Kevin Phillips
@phillipskevin
Dec 14 2016 00:34
:thumbsup:
Thomas Sieverding
@Bajix
Dec 14 2016 01:22
@phillipskevin Could you release https://github.com/donejs/autorender/tree/can3 as 0.9.0-pre.2?
Thomas Sieverding
@Bajix
Dec 14 2016 01:43
@phillipskevin another dependency PR canjs/can-map-define#22
Kevin Phillips
@phillipskevin
Dec 14 2016 02:38
@Bajix can we just remove jquery from that one?
we did just enable greenkeeper also, so that should take care of the rest of the dependencies
just bumping to the latest versions
I’m slowly going through the 50+ PRs from greenkeeper
for autorender, the "got the appstate” test is failing for me
Gira Minus
@gKreator
Dec 14 2016 02:43
blob
Just took off steal-build-tools for testing and I see this... but the app still runs
Cleared cache
Thomas Sieverding
@Bajix
Dec 14 2016 02:44
@phillipskevin Greenkeeper doesn’t work for your jQuery use case - I think the wide range though might just mean it never includes jQuery in updates, so that’s moot
Kevin Phillips
@phillipskevin
Dec 14 2016 02:44
yeah, I meant for the non-jquery stuff
it won’t put in a PR if the latest is covered by the semver range
Thomas Sieverding
@Bajix
Dec 14 2016 02:45
I’ll take another look at done-autorender
Gira Minus
@gKreator
Dec 14 2016 02:46
Thanks, I'll check it out
Kevin Phillips
@phillipskevin
Dec 14 2016 02:47
@Bajix I can release a pre of autorender tomorrow if it gets fixed up
Thomas Sieverding
@Bajix
Dec 14 2016 02:47
What about doing a can-map-define release tonight?
Kevin Phillips
@phillipskevin
Dec 14 2016 02:48
does it need jQuery?
Thomas Sieverding
@Bajix
Dec 14 2016 02:48
It has jquery in it’s dependencies
Whether it needs it can wait
Gira Minus
@gKreator
Dec 14 2016 02:48
@phillipskevin Thnaks, that worked!
Thomas Sieverding
@Bajix
Dec 14 2016 02:49
done-autorender is going to load in the wrong jquery version until can-map-define is released
So at least if I put up a patch, it would be 3.x compat
Kevin Phillips
@phillipskevin
Dec 14 2016 02:53
why not just remove it?
Kevin Phillips
@phillipskevin
Dec 14 2016 02:59
@Bajix
Thomas Sieverding
@Bajix
Dec 14 2016 03:03
Yea sorry had stepped away
Sweeeeet!
Thank you sir
Gira Minus
@gKreator
Dec 14 2016 03:21
blob
blob
This worked with steal-tools, I am assuming this is bad lol
I am trying to pass a template to another component. I know I can pass it as a string, but I want for steal-tools to bundle it with the parent.
Gira Minus
@gKreator
Dec 14 2016 03:43
Found out it was my child component... I wansn't using the define { value: }
Thomas Sieverding
@Bajix
Dec 14 2016 04:17
@gKreator I think I found that error earlier. The tests pass in the browser, but the one fails when done from the cli - upon further inspection, I think this line is breaking StealJS
Gira Minus
@gKreator
Dec 14 2016 04:19
Nice, for me it was just my miss use of DefineMap
I just ran into a bug with <can-import>
<can-import from="scripts/components/datatable/">
<component-datatable {(options)}="datatable"></component-datatable>
</can-import>
I have to manually import the component somewhere... otherwise I get an error
Gira Minus
@gKreator
Dec 14 2016 04:24
import "scripts/components/datatable/";
GET /traceur.js 404 (Not Found)
It seems to only do this if can-import is nested
this error only shows up in steal-tools
Thomas Sieverding
@Bajix
Dec 14 2016 04:50
@phillipskevin I’ve got a fix for the done-autorender test
canjs/can-stache#127
It was breaking because of a bundle override on can-stache
Gira Minus
@gKreator
Dec 14 2016 04:51
What was breaking?
Thomas Sieverding
@Bajix
Dec 14 2016 04:54
can-stache had a path override that was breaking steal’s ability to load can-stache, but only during npm test
Gira Minus
@gKreator
Dec 14 2016 04:54
Ohh
Nice find!
Thomas Sieverding
@Bajix
Dec 14 2016 04:55
this was because done-autorender no longer has can as a dependency, and the path override in can-stache tries to map to can
Gira Minus
@gKreator
Dec 14 2016 04:55
Got any clue on my can-import issue?
:D
Thomas Sieverding
@Bajix
Dec 14 2016 04:55
Hmmm
Gira Minus
@gKreator
Dec 14 2016 04:56
Seems to be an issue with nested <can-import>
Thomas Sieverding
@Bajix
Dec 14 2016 04:56
Why’re you loading it from scripts?
I think your path setup isn’t right
Gira Minus
@gKreator
Dec 14 2016 04:57
the folder? Is all my js files and stache files in there
Thomas Sieverding
@Bajix
Dec 14 2016 04:57
I mean to say that you’re importing it from scripts, whereas the import statement shouldn’t need ‘scripts'
Gira Minus
@gKreator
Dec 14 2016 04:57
It only breaks when you use steal-tools to build
hmm
ohh this screenshot might explain it
Thomas Sieverding
@Bajix
Dec 14 2016 04:58
The paths configuration of your project wouldn’t make sense, not necessarily a comment on your file structure
Gira Minus
@gKreator
Dec 14 2016 04:59
blob
Thomas Sieverding
@Bajix
Dec 14 2016 04:59
Yea so then your package.json isn’t setup right
Gira Minus
@gKreator
Dec 14 2016 05:00
blob
Anything stick out?
Thomas Sieverding
@Bajix
Dec 14 2016 05:01
Yea, under system you should have "directories": { "lib": “public/scripts" },
Gira Minus
@gKreator
Dec 14 2016 05:01
package.json is in public/
so "scripts"
Thomas Sieverding
@Bajix
Dec 14 2016 05:01
Yea sure
Gira Minus
@gKreator
Dec 14 2016 05:02
Ok thx
Thomas Sieverding
@Bajix
Dec 14 2016 05:02
I have mine setup differently such that my package.json isn’t in my assets folder
I then do some more custom static serving
Such that my assets folder goes to /assets, node_modules to /node_modules, and package.json
W/ a redacted node_modules to protect private modules
Gira Minus
@gKreator
Dec 14 2016 05:04
Very interesting
I'd like to see this somehow
Thomas Sieverding
@Bajix
Dec 14 2016 05:05
app.use('/node_modules', function( req, res, next ) {
  var pathname = req.originalUrl;

  for (var i = 0; i < protectedDirs.length; i++) {
    if (~pathname.indexOf(protectedDirs[i])) {
      return next(new handler.NotAuthorizedError());
    }
  }

  next();
});

app.use('/css', express.static(path.join(__dirname, '../css')));
app.use('/dist', express.static(path.join(__dirname, '../dist')));
app.use('/assets', express.static(path.join(__dirname, '../assets')));
app.use('/package.json', express.static(path.join(__dirname, '../package.json')));
app.use('/node_modules', express.static(path.join(__dirname, '../node_modules')));
Gira Minus
@gKreator
Dec 14 2016 05:05
ohh I see
Thomas Sieverding
@Bajix
Dec 14 2016 05:05
I like to have the url /assets where I put everything using a modlet scheme; mixed assets within each modlet
Keeping those separate makes it easier to resolve the url patterns
The default setup has the unintended consequence of serving the app in liee of static assets whenever there’s a 404
I’ll probably follow up w/ this feedback w/ the DoneJS contrib or on github
Gira Minus
@gKreator
Dec 14 2016 05:08
Is the meeting online?
Thomas Sieverding
@Bajix
Dec 14 2016 05:09
They do a weekly hangouts
Gira Minus
@gKreator
Dec 14 2016 05:09
ENOENT: no such file or directory, open '/usr/share/nginx/drivetrain/public/undefined#main.js'
whenver I set the lib:
it just passes it as undefined
Thomas Sieverding
@Bajix
Dec 14 2016 05:09
You may have other issues
Considering all of your paths were already broken
Gira Minus
@gKreator
Dec 14 2016 05:10
lol :D
Thomas Sieverding
@Bajix
Dec 14 2016 05:10
You’d need to go through and update anything using improper path conventions
Basically require everything relatively
Gira Minus
@gKreator
Dec 14 2016 05:11
yeah that I already figured
blob
Anytime I set that and try to build...
blob
Thomas Sieverding
@Bajix
Dec 14 2016 05:13
I think it actually needs to be public/scripts
Gira Minus
@gKreator
Dec 14 2016 05:14
my build.js is in the /public/ folder
and it I tried that
and it seems like the pass is fine up until the /scripts
path*
actually this might be a misconfigured steal-tools build.js
Thomas Sieverding
@Bajix
Dec 14 2016 05:16
I think you need to do system.main=“{package.name}/main.js"
Gira Minus
@gKreator
Dec 14 2016 05:26
Where would I do that?
Thomas Sieverding
@Bajix
Dec 14 2016 05:28
What’s your package name?
Gira Minus
@gKreator
Dec 14 2016 05:29
{
"name": "drivetrain",
"main": "main",
"dependencies": {
"can": "^3.2.1",
"can-component": "^3.0.3",
"can-compute": "",
"can-connect": "^1.0.14",
"can-define": "^1.0.4",
"can-event": "
",
"can-route": "^3.0.5",
"can-set": "^1.0.2",
"can-stache": "^3.0.13",
"can-util": "*",
"flatpickr": "^2.2.4",
"jquery": "^3.1.1",
"jquery.scrollto": "^2.1.2",
"lightbox2": "^2.9.0",
"moment": "^2.17.1",
"parsleyjs": "^2.6.0",
"steal": "^0.16.43",
"steal-cache-bust": "^0.2.1",
"steal-stache": "^3.0.3",
"sweetalert2": "^6.2.0"
},
"devDependencies": {
"steal-tools": "^0.16.8"
},
"system": {
"npmAlgorithm": "flat",
"npmIgnore": [
"devDependencies"
],
"directories": {
"lib": "scripts"
}
}
}
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:29
wow
can you plz post files to external jsbin or other posting services
Thomas Sieverding
@Bajix
Dec 14 2016 05:30
The main property of your system object within package.json should be your main dependency, relative to your lib.directories folder, substituting your package.name for whatever lib.directories is
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:30
gists or else
Gira Minus
@gKreator
Dec 14 2016 05:30
kk
Thomas Sieverding
@Bajix
Dec 14 2016 05:31
So system.main should be “drivetrain/main.js"
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:31
when package.json is in / yes
if package.json is in drivetain also it would be only main.js
but listen to me i saw in your package json that you have a bad combo
of module versions
i think your mixing up a lot of stuff that will not 100% work
Thomas Sieverding
@Bajix
Dec 14 2016 05:33
What’s he using that won’t work?
Gira Minus
@gKreator
Dec 14 2016 05:33
yeah at this point i think my package.json is messed up beyond lol
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:33
right my frind now listen
Thomas Sieverding
@Bajix
Dec 14 2016 05:33
No it’s not?
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:33
we make it easy
you download donejs
do donejs add app
Thomas Sieverding
@Bajix
Dec 14 2016 05:33
DoneJS isn’t up to date right now
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:34
@Bajix it is
and his package.json isn't up to date too
so he will be more happy with the canjs 2.3 stack
as it will probally work as he expects it
and he can upgrade later
Thomas Sieverding
@Bajix
Dec 14 2016 05:34
donejs doesn’t have 3.0 yet
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:35
DoneJS has that
Gira Minus
@gKreator
Dec 14 2016 05:35
I already upgraded to CanJs 3
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:35
i simply don't published it
ah ok wait
i give you a donejs +canjs v3 json
you replace that with your
Gira Minus
@gKreator
Dec 14 2016 05:35
kk
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:35
need to search for a beta project give me some secunds
Gira Minus
@gKreator
Dec 14 2016 05:36
We are just trieing to fix a <can-import> bug...
sweet no problem
Thomas Sieverding
@Bajix
Dec 14 2016 05:36
Try out the system.main fix
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:37
Bai
in steal v1.0
the system object got renamed to steal
Thomas Sieverding
@Bajix
Dec 14 2016 05:37
Eh? that sounds terrible
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:37
and you need to use steal 1 not 0.16
No its not
simply read the migrating guid?
:D
Thomas Sieverding
@Bajix
Dec 14 2016 05:39
That’s not the issue
It decreases interoperability with SystemJS
Thomas Sieverding
@Bajix
Dec 14 2016 05:40
StealJS forked from SystemJS, but the two still have large simularities
As someone who authors works for both, this is kind of frustrating...
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:41
ohhh
sorry for that
but steal has simply probally other goals then accepting systemjs plugins or anything
Thomas Sieverding
@Bajix
Dec 14 2016 05:42
It’s a frivelous change to rename everything from system to steal and it’ll only make it that much harder to make portable works
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:42
example?
give realy usefull examples not only words always remember i don't know what your doing
Thomas Sieverding
@Bajix
Dec 14 2016 05:42
They they have same plugin interface, but different path resolution behaviors
Anything built for SystemJS can be made compatible for Steal and vice versa
Gira Minus
@gKreator
Dec 14 2016 05:43
when I run npm install steal --save, it gives me "steal": "^0.16.43",
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:43
ok little trick for you
npm install steal@rc steal-tools@rc --save
it gives you 1 right?
Gira Minus
@gKreator
Dec 14 2016 05:45
"steal-tools": "^1.0.0-rc2",
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:45
perfecto
Thomas Sieverding
@Bajix
Dec 14 2016 05:45
How does upgrading steal play into getting 3.0 compatible?
Gira Minus
@gKreator
Dec 14 2016 05:46
that might fix the can-import problem I am having when I use steal-tools?
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:46
not realy
you need to have the right versions
and need to use the right syntax overall
if you like and you got your repo public or you can give me access in private chat then i could upgrade it for you
i am skilled with that and will find fast what needs to be changed and it will also help me as i code functions for auto migration for the generator
Thomas Sieverding
@Bajix
Dec 14 2016 05:50
Can you send me a package.json with them?
Gira Minus
@gKreator
Dec 14 2016 05:52
Me?
Thomas Sieverding
@Bajix
Dec 14 2016 05:52
no @frank-dspeed
I guess it would be beneficial for everyone
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:54
ya let me look no problem
its around public in the git repos also
Thomas Sieverding
@Bajix
Dec 14 2016 05:55
I mean that’s probably just using the pre tags on donejs things
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:55
donejs/donejs#750
does that help you?
nope the pre tags don't work
:D
there is a donejs branch with canjs 3 and pre tags
Thomas Sieverding
@Bajix
Dec 14 2016 05:56
Sweet
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:56
that don't works
but this dependcys work
i use them in production
Thomas Sieverding
@Bajix
Dec 14 2016 05:56
That sounds liek the same issue that I saw in can-stache
Frank Lemanschik
@frank-dspeed
Dec 14 2016 05:57
maybe only remember to change system to steal
and to be compatible
maybe copy that also to system :D
little insider tip ;)
Thomas Sieverding
@Bajix
Dec 14 2016 05:58
k
Thanks mate
Frank Lemanschik
@frank-dspeed
Dec 14 2016 06:00
no problem your welcome
Per Ehnbom
@perehnbom
Dec 14 2016 08:39
It was nice to see a canjs post on http://www.echojs.com/latest/0 , that was long due :)
Mohamed Cherif Bouchelaghem
@cherifGsoul
Dec 14 2016 08:41
@perehnbom it needs up votes now :)
Per Ehnbom
@perehnbom
Dec 14 2016 08:41
I was the first
needs more
Mohamed Cherif Bouchelaghem
@cherifGsoul
Dec 14 2016 08:42
yes thank you
Per Ehnbom
@perehnbom
Dec 14 2016 09:10
The weekly newsletters I read are javascript weekly and WDRL, would be nice to get that canjs post in there as well
Mohamed Cherif Bouchelaghem
@cherifGsoul
Dec 14 2016 09:11
you can post it
Per Ehnbom
@perehnbom
Dec 14 2016 09:15
I guess @chasenlehara was the one posting at echojs, if he's not up for reaching out to the newsletters, Ill do it
Chasen Le Hara
@chasenlehara
Dec 14 2016 10:15
@perehnbom. I am trying to reach out to all of the newsletters that would be interested in us, so please let me know where I can reach out
Frank Lemanschik
@frank-dspeed
Dec 14 2016 10:16
that should be near any news letter :)
Chasen Le Hara
@chasenlehara
Dec 14 2016 10:17
Bitovi has recently placed me in the developer relations role but I’m still learning about how I can reach out to the community
Frank Lemanschik
@frank-dspeed
Dec 14 2016 10:17
ya you can only reach out to the community via the gitrepos :D
thats where all companys look at
if you want to attract new users do it like me i am writing at present german articels for canjs v3 release
for web magazins like t3n.de
its a big one in germany they have printed and online version
Chasen Le Hara
@chasenlehara
Dec 14 2016 10:19
Thank you @frank-dspeed! Let me know if I can help in communicating our message.
Frank Lemanschik
@frank-dspeed
Dec 14 2016 10:20
simply google for things like how to write for and name a big magazin in the targeted region most magazin accepts articels from outside
maybe we should write a how to Anounce v3 release guid
so that people know that should point to CanJS is dead long life CanJS
the change from framework to collection and that
we can fast produce variations from that for releases in magazins
in general i think guids are the best comunication with developers this days
most people google for guids
if you want that people do something give them a guid and they will follow
you could also enable githubs project feature :)
and use the scrum board to point out what is currently in work
Justin Meyer
@justinbmeyer
Dec 14 2016 17:14
we use zenhub b/c github's projects can span multiple orgs
Thomas Sieverding
@Bajix
Dec 14 2016 17:45
@justinbmeyer do you use Zenhub within Bitovi too? I’m feeling awfully meh about Jira
Justin Meyer
@justinbmeyer
Dec 14 2016 17:45
we use it just for OS work
if it could do burndowns for epics ... it would be about perfect imo
but we mostly use it b/c it can do epics across all 60 or so DoneJS, CanJS, StealJS, etc repos
and can do complexity estimates
so I can see that DoneJS 1.0 has 700 story points
Thomas Sieverding
@Bajix
Dec 14 2016 17:48
My team needs to establish a better process. I haven’t really ever been at a company that has done it right, and it’s been a major pain point
Is the DoneJS Zenhub private?
Matthew Phillips
@matthewp
Dec 14 2016 17:55
zenhub is slow though
it does a bunch of http requests in the client
Thomas Sieverding
@Bajix
Dec 14 2016 17:58
Sounds like they need done-ssr
Gira Minus
@gKreator
Dec 14 2016 17:58
lol
Matthew Phillips
@matthewp
Dec 14 2016 18:52
indeed!
Chasen Le Hara
@chasenlehara
Dec 14 2016 18:56

Justin’s going to host a YouTube live steam (in 5 minutes!) on how to use can-connect and can-set for real-time functionality.

https://www.youtube.com/watch?v=QYLP-dHc0iE

Chasen Le Hara
@chasenlehara
Dec 14 2016 19:05
…and we’re live!
Thomas Sieverding
@Bajix
Dec 14 2016 19:20
How would set Algebra accomplish the equivalent of db.todos.find({ $gt: { updatedAt: new Date(lastUpdatedTime) }})?
Also is it possible for a set Algebra function alone to be able to modify query params, or does it need a can-connect behavior mixin as well?
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:20
why do you copy the questions
you should focus on the life chat i think
Thomas Sieverding
@Bajix
Dec 14 2016 19:20
Wasn’t sure if he was seeing that chat feed
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:20
i see it
:D
Chasen Le Hara
@chasenlehara
Dec 14 2016 19:21
I’ll bring it up to @justinbmeyer. We’ll go through the questions here. :)
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:21
and why did someone writen then befor the livestream that he answers there
isn't that confusing :D
Thomas Sieverding
@Bajix
Dec 14 2016 19:32
@justinbmeyer how would you recommend query params articulate a greater than query?
I had sent an actual monogod command in the example, not how one would’ve built the API
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:34
@Bajix i would let you database do that :)
and build the api with feathersjs
are you familary with mongoose models?
Thomas Sieverding
@Bajix
Dec 14 2016 19:35
More than familiar I’d say
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:35
if you work with mongodb i would code the api with express and mongoose and learn feathers on side
then you simply call that api via canjs
and let the api return the right results
Justin Meyer
@justinbmeyer
Dec 14 2016 19:36
@Bajix I'd have the property on the "outside" of the set
{updatedAt: {gt: value}}`
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:36
for example when i store a new value i let it return sorted results + new value
Justin Meyer
@justinbmeyer
Dec 14 2016 19:36
instead of {gt: {updatedAt:{ value } }
Thomas Sieverding
@Bajix
Dec 14 2016 19:36
@frank-dspeed I’m not new to NodeJS ;)
Frank Lemanschik
@frank-dspeed
Dec 14 2016 19:36
why do you then sort client side?
is there any advantage?
Thomas Sieverding
@Bajix
Dec 14 2016 19:38
@justinbmeyer Yea you’re right.. I was being dyslexic
Justin Meyer
@justinbmeyer
Dec 14 2016 19:39
ah, ok
so that would make it a bit easier
create a forum post with the rules and I'll try to spec out how to do it
Thomas Sieverding
@Bajix
Dec 14 2016 19:39
kk
Does ref need any special treatment?
Matthew Phillips
@matthewp
Dec 14 2016 20:29
Hey everyone, we're looking for feedback on what DoneJS (CanJS, StealJS, whatever) training topics are wanted: http://forums.donejs.com/t/donejs-trainings/506
Thomas Sieverding
@Bajix
Dec 14 2016 23:23
@matthewp Is there anything holding up doing a release of autorender?