These are chat archives for canjs/canjs

15th
Jun 2018
Jeroen Cornelissen
@jeroencornelissen
Jun 15 2018 14:20
For the vscode users, I’ve made some snippets for can-stache:
https://marketplace.visualstudio.com/items?itemName=jeroencornelissen.can-stache-snippets
Gregg Roemhildt
@roemhildtg
Jun 15 2018 14:24
:+1: @jeroencornelissen
srikkanthsiki
@srikkanthsiki
Jun 15 2018 18:48
hi
if i use this isn code i get
element.querySelector(“h2”) is not a function
can someonehelp
srikkanthsiki
@srikkanthsiki
Jun 15 2018 18:57
thanks a lot team
i made it work
Chasen Le Hara
@chasenlehara
Jun 15 2018 20:11
Oh awesome @jeroencornelissen!
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:36
(node:64843) UnhandledPromiseRejectionWarning: Error: Could not load 'jquery@2.2.4#jquery'
Is this an npm module not saved in your package.json?
at file:/Project/Kosmos/trouper/trouper/node_modules/steal/ext/npm-extension.js:379:20
(node:64843) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 881)
this is issue with steal npm run live-reload
can some one help on this
Kevin Phillips
@phillipskevin
Jun 15 2018 21:40
does node_modules/jquery/jquery exist?
and do you have jquery in your package.json?
@srikkanthsiki
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:41
hi
/Project/Kosmos/trouper/trouper/node_modules/jquery/dist/jquery.js
node_modules/jquery/dist/jquery.js
should it been in jquery ?
should i move it from dist to jqeury folder
?
Kevin Phillips
@phillipskevin
Jun 15 2018 21:44
no
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:44
if i use 'npm install jquery@2.2.4 --save --save-dev'
it creates node module like this
image.png
Kevin Phillips
@phillipskevin
Jun 15 2018 21:45
yeah, that's fine
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:45
steal-tools live-reload
this is causing issue
Kevin Phillips
@phillipskevin
Jun 15 2018 21:46
what does this have to do with live-reload?
the error only happens when the page is reloaded by live-reload?
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:46
when i run live reload .. in the logs i get this errir
at file:/Project/Kosmos/trouper/trouper/node_modules/steal/ext/npm-extension.js:379:20
(node:72670) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 46)
(node:72670) UnhandledPromiseRejectionWarning: Error: Could not load 'jquery@2.2.4#jquery'
Is this an npm module not saved in your package.json?
at file:/Project/Kosmos/trouper/trouper/node_modules/steal/ext/npm-extension.js:379:20
(node:72670) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 48)
^C
Kevin Phillips
@phillipskevin
Jun 15 2018 21:47
is jquery in your package.json?
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:47
image.png
"can": {
"version": "2.3.33",
"resolved": "https://registry.npmjs.org/can/-/can-2.3.33.tgz",
"integrity": "sha1-Zx+HU+r34j38DEb8ASt2dKPppaY=",
"dev": true,
"requires": {
"can-simple-dom": "^0.3.0",
"jquery": ">=1.9.0 <1.12.0 || >=2.1.0 <2.3.0"
}
package-lock.json
"jquery": {
"version": "2.2.4",
"resolved": "https://registry.npmjs.org/jquery/-/jquery-2.2.4.tgz",
"integrity": "sha1-LInWiJterFIqfuoywUUhVZxsvwI="
},
Kevin Phillips
@phillipskevin
Jun 15 2018 21:51
I'm not sure
try asking in the steal room
srikkanthsiki
@srikkanthsiki
Jun 15 2018 21:52
sure thanks for support
srikkanthsiki
@srikkanthsiki
Jun 15 2018 22:00
stealjs/steal-tools#130