Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 16 20:07
    matthewp commented #5384
  • Oct 16 20:06
    matthewp labeled #5384
  • Oct 16 20:06
    matthewp opened #5384
  • Oct 16 19:53
    matthewp opened #5383
  • Oct 16 16:23
    phillipskevin closed #4841
  • Oct 15 21:43

    phillipskevin on master

    Update dist for release (compare)

  • Oct 15 21:43

    phillipskevin on v6.1.1

    Update dist for release 6.1.1 (compare)

  • Oct 15 21:34

    phillipskevin on can-observable-mixin-1.0.2

    (compare)

  • Oct 15 21:34

    phillipskevin on master

    fix(package): update can-observ… Merge branch 'master' into gree… Merge pull request #5382 from c… (compare)

  • Oct 15 21:34
    phillipskevin closed #5382
  • Oct 15 21:34

    phillipskevin on can-make-map-1.2.2

    (compare)

  • Oct 15 21:34

    phillipskevin on master

    fix(package): update can-make-m… Merge pull request #5380 from c… (compare)

  • Oct 15 21:34
    phillipskevin closed #5380
  • Oct 15 20:30
    phillipskevin synchronize #5382
  • Oct 15 20:30

    phillipskevin on can-observable-mixin-1.0.2

    fix(package): update can-observ… fix(package): update can-simple… Merge pull request #5372 from c… and 2 more (compare)

  • Oct 15 20:30
    phillipskevin opened #5382
  • Oct 15 20:28

    phillipskevin on can-simple-map-4.3.3

    (compare)

  • Oct 15 20:28

    phillipskevin on master

    fix(package): update can-simple… Merge pull request #5378 from c… (compare)

  • Oct 15 20:28
    phillipskevin closed #5378
  • Oct 15 20:26

    phillipskevin on can-observable-mixin-1.0.1

    (compare)

Gira Minus
@gKreator
whenver I set the lib:
it just passes it as undefined
Thomas Sieverding
@Bajix
You may have other issues
Considering all of your paths were already broken
Gira Minus
@gKreator
lol :D
Thomas Sieverding
@Bajix
You’d need to go through and update anything using improper path conventions
Basically require everything relatively
Gira Minus
@gKreator
yeah that I already figured
blob
Anytime I set that and try to build...
blob
Thomas Sieverding
@Bajix
I think it actually needs to be public/scripts
Gira Minus
@gKreator
my build.js is in the /public/ folder
and it I tried that
and it seems like the pass is fine up until the /scripts
path*
actually this might be a misconfigured steal-tools build.js
Thomas Sieverding
@Bajix
I think you need to do system.main=“{package.name}/main.js"
Gira Minus
@gKreator
Where would I do that?
Thomas Sieverding
@Bajix
What’s your package name?
Gira Minus
@gKreator
{
"name": "drivetrain",
"main": "main",
"dependencies": {
"can": "^3.2.1",
"can-component": "^3.0.3",
"can-compute": "",
"can-connect": "^1.0.14",
"can-define": "^1.0.4",
"can-event": "
",
"can-route": "^3.0.5",
"can-set": "^1.0.2",
"can-stache": "^3.0.13",
"can-util": "*",
"flatpickr": "^2.2.4",
"jquery": "^3.1.1",
"jquery.scrollto": "^2.1.2",
"lightbox2": "^2.9.0",
"moment": "^2.17.1",
"parsleyjs": "^2.6.0",
"steal": "^0.16.43",
"steal-cache-bust": "^0.2.1",
"steal-stache": "^3.0.3",
"sweetalert2": "^6.2.0"
},
"devDependencies": {
"steal-tools": "^0.16.8"
},
"system": {
"npmAlgorithm": "flat",
"npmIgnore": [
"devDependencies"
],
"directories": {
"lib": "scripts"
}
}
}
Frank Lemanschik
@frank-dspeed
wow
can you plz post files to external jsbin or other posting services
Thomas Sieverding
@Bajix
The main property of your system object within package.json should be your main dependency, relative to your lib.directories folder, substituting your package.name for whatever lib.directories is
Frank Lemanschik
@frank-dspeed
gists or else
Gira Minus
@gKreator
kk
Thomas Sieverding
@Bajix
So system.main should be “drivetrain/main.js"
Frank Lemanschik
@frank-dspeed
when package.json is in / yes
if package.json is in drivetain also it would be only main.js
but listen to me i saw in your package json that you have a bad combo
of module versions
i think your mixing up a lot of stuff that will not 100% work
Thomas Sieverding
@Bajix
What’s he using that won’t work?
Gira Minus
@gKreator
yeah at this point i think my package.json is messed up beyond lol
Frank Lemanschik
@frank-dspeed
right my frind now listen
Thomas Sieverding
@Bajix
No it’s not?
Frank Lemanschik
@frank-dspeed
we make it easy
you download donejs
do donejs add app
Thomas Sieverding
@Bajix
DoneJS isn’t up to date right now
Frank Lemanschik
@frank-dspeed
@Bajix it is
and his package.json isn't up to date too
so he will be more happy with the canjs 2.3 stack
as it will probally work as he expects it
and he can upgrade later
Thomas Sieverding
@Bajix
donejs doesn’t have 3.0 yet
Frank Lemanschik
@frank-dspeed
DoneJS has that
Gira Minus
@gKreator
I already upgraded to CanJs 3
Frank Lemanschik
@frank-dspeed
i simply don't published it
ah ok wait