Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 18 22:20
    greenkeeper[bot] labeled #5391
  • Oct 18 22:20
    greenkeeper[bot] opened #5391
  • Oct 18 22:20

    greenkeeper[bot] on can-observable-mixin-1.0.3

    fix(package): update can-observ… (compare)

  • Oct 18 19:08
    cherifGsoul labeled #5390
  • Oct 18 19:07
    cherifGsoul opened #5390
  • Oct 18 18:45
    greenkeeper[bot] labeled #5389
  • Oct 18 18:45
    greenkeeper[bot] opened #5389
  • Oct 18 18:45

    greenkeeper[bot] on can-observable-bindings-1.3.0

    fix(package): update can-observ… (compare)

  • Oct 18 18:29

    matthewp on master

    Update dist for release (compare)

  • Oct 18 18:29

    matthewp on v6.1.3

    Update dist for release 6.1.3 (compare)

  • Oct 18 17:59

    matthewp on can-observable-array-1.0.2

    (compare)

  • Oct 18 17:59

    matthewp on master

    fix(package): update can-observ… Merge pull request #5388 from c… (compare)

  • Oct 18 17:59
    matthewp closed #5388
  • Oct 18 16:46
    greenkeeper[bot] labeled #5388
  • Oct 18 16:46
    greenkeeper[bot] opened #5388
  • Oct 18 16:46

    greenkeeper[bot] on can-observable-array-1.0.2

    fix(package): update can-observ… (compare)

  • Oct 18 12:45
    greenkeeper[bot] labeled #5387
  • Oct 18 12:45
    greenkeeper[bot] opened #5387
  • Oct 18 12:45

    greenkeeper[bot] on can-stache-element-1.0.2

    fix(package): update can-stache… (compare)

  • Oct 18 09:49
    chasenlehara edited #5384
Frank Lemanschik
@frank-dspeed
we make it easy
you download donejs
do donejs add app
Thomas Sieverding
@Bajix
DoneJS isn’t up to date right now
Frank Lemanschik
@frank-dspeed
@Bajix it is
and his package.json isn't up to date too
so he will be more happy with the canjs 2.3 stack
as it will probally work as he expects it
and he can upgrade later
Thomas Sieverding
@Bajix
donejs doesn’t have 3.0 yet
Frank Lemanschik
@frank-dspeed
DoneJS has that
Gira Minus
@gKreator
I already upgraded to CanJs 3
Frank Lemanschik
@frank-dspeed
i simply don't published it
ah ok wait
i give you a donejs +canjs v3 json
you replace that with your
Gira Minus
@gKreator
kk
Frank Lemanschik
@frank-dspeed
need to search for a beta project give me some secunds
Gira Minus
@gKreator
We are just trieing to fix a <can-import> bug...
sweet no problem
Thomas Sieverding
@Bajix
Try out the system.main fix
Frank Lemanschik
@frank-dspeed
Bai
in steal v1.0
the system object got renamed to steal
Thomas Sieverding
@Bajix
Eh? that sounds terrible
Frank Lemanschik
@frank-dspeed
and you need to use steal 1 not 0.16
No its not
simply read the migrating guid?
:D
Thomas Sieverding
@Bajix
That’s not the issue
It decreases interoperability with SystemJS
Thomas Sieverding
@Bajix
StealJS forked from SystemJS, but the two still have large simularities
As someone who authors works for both, this is kind of frustrating...
Frank Lemanschik
@frank-dspeed
ohhh
sorry for that
but steal has simply probally other goals then accepting systemjs plugins or anything
Thomas Sieverding
@Bajix
It’s a frivelous change to rename everything from system to steal and it’ll only make it that much harder to make portable works
Frank Lemanschik
@frank-dspeed
example?
give realy usefull examples not only words always remember i don't know what your doing
Thomas Sieverding
@Bajix
They they have same plugin interface, but different path resolution behaviors
Anything built for SystemJS can be made compatible for Steal and vice versa
Gira Minus
@gKreator
when I run npm install steal --save, it gives me "steal": "^0.16.43",
Frank Lemanschik
@frank-dspeed
ok little trick for you
npm install steal@rc steal-tools@rc --save
it gives you 1 right?
Gira Minus
@gKreator
"steal-tools": "^1.0.0-rc2",
Frank Lemanschik
@frank-dspeed
perfecto
Thomas Sieverding
@Bajix
How does upgrading steal play into getting 3.0 compatible?
Gira Minus
@gKreator
that might fix the can-import problem I am having when I use steal-tools?