Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 17 18:44

    matthewp on setupguide

    (compare)

  • Sep 17 18:44

    matthewp on major

    Current static Update setting up canjs The setting up guide and 2 more (compare)

  • Sep 17 18:44
    matthewp closed #5292
  • Sep 17 18:06
    matthewp ready_for_review #5292
  • Sep 17 18:06
    matthewp synchronize #5292
  • Sep 17 18:06

    matthewp on setupguide

    Minor edits to make the setting… (compare)

  • Sep 17 17:30

    matthewp on major

    Update dist for release (compare)

  • Sep 17 17:30

    matthewp on v6.0.0-pre.15

    Update dist for release 6.0.0-pre.15 (compare)

  • Sep 17 17:04

    matthewp on major

    Upgrade to can-type 1.0.0-pre.8 Increase bundlesize for core T… Upgrade to can-stache@5.0.0-pre… and 1 more (compare)

  • Sep 17 17:04
    matthewp closed #5291
  • Sep 17 16:08

    chasenlehara on type8

    Upgrade to can-stache@5.0.0-pre… (compare)

  • Sep 17 16:08
    chasenlehara synchronize #5291
  • Sep 17 16:00
    cherifGsoul commented #5268
  • Sep 17 15:57

    cherifGsoul on update-theme-new-buttons

    pre 2 for theme (compare)

  • Sep 17 15:51
    cherifGsoul synchronize #5268
  • Sep 17 15:51

    cherifGsoul on jquery-add-event-migration-guide

    Some updates (compare)

  • Sep 17 15:33
    greenkeeper[bot] labeled #5293
  • Sep 17 15:32
    greenkeeper[bot] opened #5293
  • Sep 17 15:32

    greenkeeper[bot] on can-component-4.6.3

    fix(package): update can-compon… (compare)

  • Sep 17 15:00
    phillipskevin commented #5290
Chasen Le Hara
@chasenlehara
Ok, good
And just to double check, this line never gets called, right? https://github.com/canjs/can-route/blob/v3.3.2/can-route.js#L877
Piyush Sharma
@Piyush5767
it called only at beginning after page refresh but not when we call route.attr( { 'section': "merchandizing", 'page': 'customers','action':'create' });
Chasen Le Hara
@chasenlehara
That teardown function shouldn’t be called when the page loads. Can you put a breakpoint there and see what’s calling it?
Piyush Sharma
@Piyush5767
ok
no its not about teardown, i am talking about setup
Chasen Le Hara
@chasenlehara
Ok, so that teardown function is never called, right?
Piyush Sharma
@Piyush5767
there is no called made to teardown
no, not even after we call route.attr
Chasen Le Hara
@chasenlehara
Ok, good
After the route.attr call, do you see this function being called again? https://github.com/canjs/can-route/blob/v3.3.2/can-route.js#L958
Can you log canRoute.data.serialize() and see what it returns? It should be called before route.attr and after route.attr, so two logs.
Piyush Sharma
@Piyush5767
yes sure
ok it return {page: "customers", section: "merchandizing"} before route.attr where as it had not been called after route.attr
for starting it called twice... first one {} and second: {page: "customers", section: "merchandizing"}
but not after route.attr been called
Chasen Le Hara
@chasenlehara
Ok. The fact that it doesn’t get called after the route.attr is a problem… we’ve made some progress.
Instead of calling route.attr with an object, what happens if you replace that call with just route.attr('action', 'create')?
Piyush Sharma
@Piyush5767
let me try that
no it didn't call even i use route.attr('action', 'create')
where as page change but same url in browser still same
Chasen Le Hara
@chasenlehara
We figured it out; this was a DoneJS app with done-autorender, which automatically calls route.start()
Removed the call and it worked 🎉
Piyush Sharma
@Piyush5767
yep, thanks!
apsignifi
@apsignifi
can3->can4 : is there a way to simultaneously upgrade all npm libraries to a compatible version when moving to can4 from can3 ?
I have already tried 'donejs upgrade', and getting conflicts because of two versions of a package 'can-dom-data-state' - the error asks to check dependencies.
Ivo Pinheiro
@ivospinheiro
I have upgraded an application from can 3 to can 4 recently
My experience is that you can upgrade to the latest version of all dependencies, besides can-connect and can-set if I'm not wrong
can-jquery should be replaced by jquery or can-ajax
and can-util/dom usages should be avoided and replaced by the alternative library
Justin Meyer
@justinbmeyer
@apsignifi I will answer in 5 min
apsignifi
@apsignifi
@ivospinheiro : Thanks. will try latest.
@justinbmeyer : okk, thanks.
Justin Meyer
@justinbmeyer
@apsignifi I'm going to write up a forum post
apsignifi
@apsignifi
@justinbmeyer : Thanks.
question: I have multiple apps using different canjs versions ( 2.3, 3 & 4). is there a way to use a different donejs version for each (as needed).
for example, use donejs v0.9 with can2.3, donejs v1.x with can3.x && donejs2.x with can4.x
?
Justin Meyer
@justinbmeyer
when you say use donejs you mean its CLI?
apsignifi
@apsignifi
yes
Justin Meyer
@justinbmeyer
the donejs CLI is a mask already, so it should work
by mask, I mean that it calls to code in the local project and does very little on its own
apsignifi
@apsignifi
ok, let me try. Thanks.
Justin Meyer
@justinbmeyer
so having the latest donejs should be fine
so donejs add component should generate a different component code in each version
apsignifi
@apsignifi
okk. thanks.
not an automated process, but should be pretty straightforward
Gregg Roemhildt
@roemhildtg
Has anyone ever built a calendar component for canjs they'd be able to share?
Something that would let me pass dates and event names to it so that they'd appear on the calendar in a readable format
apsignifi
@apsignifi

@apsignifi https://forums.donejs.com/t/how-to-get-your-packages-right-for-example-upgrading-from-3-0-to-4-0/1013
not an automated process, but should be pretty straightforward

Thanks, will take a look.

apsignifi
@apsignifi

this package : can-dom-data-state , it seems a lot of packages for can4 are still using an older version 0.2.0 ,
this is the only one giving me an error:

You can't have two versions of can-dom-data-state, check your dependencies

Matthew Phillips
@matthewp
@chasenlehara is our resident can-dom-data / can-dom-data-state expert :)
apsignifi
@apsignifi
@matthewp : Thanks.
is there a way to force using only one version regardless of what's mentioned in dependencies ?
Kevin Phillips
@phillipskevin
if you're using something in can-util/dom it will load the wrong version