Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
gsarin1980
@gsarin1980
Hi team, can Hygieia work with other NOSQL databases like DynamoDB ?
1 reply
Jasmin Mehta
@jmcnn

Hi All, I am trying to install Hygieia Dashboard locally using docker-compose. Running into setting up Jenkins Build Collector. Appears it tries to look for mongo on localhost instead of host and port specified through environment variable. Has anyone run into this scenario? Would appreciate help.

Docker Log with default config generated through properties-builder.sh:

MONGODB_HOST: 172.21.0.2
MONGODB_PORT: 27017
....
....

2020-10-02 15:50:30,065 [localhost-startStop-1] INFO  c.c.dashboard.config.MongoConfig - Connecting to Mongo: Mongo{options=MongoClientOptions{description='null', applicationName='null', compressors='[]', readPreference=primary, writeConcern=WriteConcern{w=null, wTimeout=null ms, fsync=null, journal=null, retryWrites=false, readConcern=com.mongodb.ReadConcern@0, codecRegistry=org.bson.codecs.configuration.ProvidersCodecRegistry@b62ad2, serverSelector=null, clusterListeners=[], commandListeners=[], minConnectionsPerHost=0, maxConnectionsPerHost=100, threadsAllowedToBlockForConnectionMultiplier=5, serverSelectionTimeout=30000, maxWaitTime=120000, maxConnectionIdleTime=0, maxConnectionLifeTime=0, connectTimeout=10000, socketTimeout=0, socketKeepAlive=true, sslEnabled=false, sslInvalidHostNamesAllowed=false, sslContext=null, alwaysUseMBeans=false, heartbeatFrequency=10000, minHeartbeatFrequency=500, heartbeatConnectTimeout=20000, heartbeatSocketTimeout=20000, localThreshold=15, requiredReplicaSetName='null', dbDecoderFactory=com.mongodb.DefaultDBDecoder$1@15d02638, dbEncoderFactory=com.mongodb.DefaultDBEncoder$1@4cb45d77, socketFactory=null, cursorFinalizerEnabled=true, connectionPoolSettings=ConnectionPoolSettings{maxSize=100, minSize=0, maxWaitQueueSize=500, maxWaitTimeMS=120000, maxConnectionLifeTimeMS=0, maxConnectionIdleTimeMS=0, maintenanceInitialDelayMS=0, maintenanceFrequencyMS=60000, connectionPoolListeners=[]}, socketSettings=SocketSettings{connectTimeoutMS=10000, readTimeoutMS=0, keepAlive=true, receiveBufferSize=0, sendBufferSize=0}, serverSettings=ServerSettings{heartbeatFrequencyMS=10000, minHeartbeatFrequencyMS=500, serverListeners='[]', serverMonitorListeners='[]'}, heartbeatSocketSettings=SocketSettings{connectTimeoutMS=20000, readTimeoutMS=20000, keepAlive=true, receiveBufferSize=0, sendBufferSize=0}}}
2020-10-02 15:50:30,078 [cluster-ClusterId{value='5f774c4524e499001abd41d2', description='null'}-localhost:27017] INFO  org.mongodb.driver.cluster - Exception in monitor thread while connecting to server localhost:27017
3 replies
alihussainiF1
@alihussainiF1
@richardmendonca7 in my case I had noticed the name of the database name ( dashboarddb and not dashboardb) to cause the error and once the collector runs I had to first configure it in my widget view . Also in the config file . I kept it set to bitbucket cloud. The url for api was commented out but I kept the first url for git.host = www.bitbucket.org/<companyname>/repositories
Chaitanya Chowdary
@HaasyaDhanvika
Hi all, when im running my udeploy collector, the collector went fine and it only shows the deployments done by admin user and if i use other than admin token, then it shows the deployments done by second user, if i try to put all the user tokens in an array and try then it is not working. is there any solution on how to get data on udeploy collector with help of multi tokens in application.properties file.
2 replies
Andrew Ochsner
@aochsner
I'm finding w/ a simple team dashboard w/ a github repo & jenkins build, along w/ a simple Product dashboard taht has that team, no commits/info gets populated int eh commit or build stage... and looking at the pipeline collection, it doesn't have any stages. This is using the latest released veresions of UI/API/Github GraphQL/Jenkins collectors. I'm not using the webhook/plugin options at the moment. This used to work and struggling to figure out what broke. Eying the EventListeners?
image.png
image.png
Karan Attar
@KaranAttar_twitter
Hi All,
I am working to set team dashboard with Features widget using latest Hygieia UI (version : 1.0.0-SNAPSHOT) , API module (version : 3.3.2-SNAPSHOT) and hygieia-feature-jira-collector version ( version : 3.2.0-SN1APSHOT).
The hygieia-feature-jira-collector runs successfully and populate data in Teams, Scope and features table but in collector_items table. My application settings are configured to work in JiraBoard mode.
When I am trying to add Feature widget from UI, It is making an API (/collector/item/type/searchField/{collectorType})call to verify Team & project Name. In CollectorController class, the method collectorItemsByTypeAndSearchField
Tries to match Team & Project information from collector_items table. Which is empty in my case.
Can you please help me to understand what is wrong.
2 replies
amritasaha1
@amritasaha1
Where to run "echo -n username:password | base64" for jira collectior
Karan Attar
@KaranAttar_twitter
@amritasaha1 you can run this command in IDE terminal or cmd
amritasaha1
@amritasaha1
From any specififc location in cmd?
Like from /target ...?
If I run in cmd, I am getting below message - 'base64' is not recognized as an internal or external command,
operable program or batch file.
Karan Attar
@KaranAttar_twitter
@amritasaha1 you can try online https://www.base64decode.org/
@amritasaha1 Which widgets have you set up successfully for hygieia?
amritasaha1
@amritasaha1
Github, Sonar, Jenkin - so far
12 replies
Ragha Vema
@rvema
@KaranAttar_twitter what’s the issue you are facing, there is so much activity on gitter , it’s quite difficult to get the context. It would be nice if you ping me in person with context and details
4 replies
Ragha Vema
@rvema
The readme for sonar and GitHub are up to date, did you try following the instructions? For Jira I am not sure if I can help
3 replies
For GitHub use the graphql version
Ragha Vema
@rvema
Can you check with @aochsner ?
Chaitanya Chowdary
@HaasyaDhanvika
Hi All, im looking for LDAP Group configuration, is there any new release coming with LDAP Group configuration feature ?
3 replies
laxsin
@laxsin
image.png
Hi, I had set up Hygieia (with lot of collectors) already, locally in my Windows. My system went out of battery and when I started the api again, after running gulp serve, I am getting above error in API logs. Also in the UI, the API connectivity is marked as red.

image.png

2020-10-15 20:42:30,958 [main] INFO com.capitalone.dashboard.Application - Started Application in 28.276 seconds (JVM running for 30.036)
2020-10-15 20:43:56,059 [http-nio-8080-exec-1] INFO o.a.c.c.C.[Tomcat].[localhost].[/] - Initializing Spring FrameworkServlet 'dispatcherServlet'
2020-10-15 20:43:56,061 [http-nio-8080-exec-1] INFO o.s.web.servlet.DispatcherServlet - FrameworkServlet 'dispatcherServlet': initialization started
2020-10-15 20:43:56,143 [http-nio-8080-exec-1] INFO o.s.web.servlet.DispatcherServlet - FrameworkServlet 'dispatcherServlet': initialization completed in 77 ms
2020-10-15 20:43:56,342 [http-nio-8080-exec-1] INFO c.c.d.a.t.JwtAuthenticationFilter - requester=READ_ONLY, timeTaken=128, endPoint=/api/dashboard/pagesize, reqMethod=GET, status=404, clientIp=127.0.0.1
2020-10-15 20:44:09,157 [http-nio-8080-exec-3] INFO c.c.d.a.t.JwtAuthenticationFilter - requester=READ_ONLY, timeTaken=54, endPoint=/api/appinfo, reqMethod=GET, status=404, clientIp=127.0.0.1
2020-10-15 20:44:09,181 [http-nio-8080-exec-2] INFO c.c.d.a.t.JwtAuthenticationFilter - requester=READ_ONLY, timeTaken=78, endPoint=/api/authenticationProviders, reqMethod=GET, status=404, clientIp=127.0.0.1

WHAT COULD HAVE WENT WRONG! I did not change anything before and after my system restart in any properties files. This is my application.properties

dbname=dashboarddb
dbusername=dashboarduser
dbpassword=dbpassword
dbhost=localhost
dbport=27017
dbreplicaset=false

server.contextPath=/api
server.port=8080

logRequest=false
logSplunkRequest=false
corsEnabled=false
version.number=0.0.1
pageSize=10

I have already tried building the code again with latest code also. Still getting the same error. Please help urgently, I have cancelled demo because of this.

sathishselvakumar-ai
@sathishselvakumar-ai
Had trouble with hygieia bitbucket collector
its not pulling any data from bitbucket cloud
image.png
Kindly help here asap!!!
sathishselvakumar-ai
@sathishselvakumar-ai
Hi
p20in
@p20in
Does Hygieia Executive dashboard supports Angular version 8?
KarthikShridhar
@KarthikShridhar
Hello All, I'm looking for Azure Collector for deploy Widget. It will be very helpful.
Jasmin Mehta
@jmcnn
Hello All, Does anyone use MongoDB Atlas as backend for Hygieia or has found a tweak to make Hygieia work for Atlas? I am running into connecting to MongoDB using the URI that Atlas has provided.
Buvanesh Kumar
@linuxsbk4_gitlab
I am looking into starter kit: https://github.com/Hygieia/hygieia-starter-kit
There is no mention of where the DB is, I tried getting into the container, and executing mongo, but says command not found.
2 replies
Basically I am trying to restore DB from dbdump
Buvanesh Kumar
@linuxsbk4_gitlab
@rvema hello, can you look at the above question?
Anonymous-Sonar
@Anonymous-Sonar
Hi Team, even though if i have mentined the hygieia url in the jenkins global config, during the course of the jenkins build, the job build information is not being to hygieia dashboard. Error logs in the jenkins build console : Hygieia: Failed Publishing Build Start Data. Response Code: 500. Response Value= {timestamp:1604404050936,status:500,error:Internal Server Error,exception:org.springframework.security.web.firewall.RequestRejectedException,message:The request was rejected because the URL was not normalized.,path:/api//v2/build}
Can someone provide the sample template of hygieia url which must be defined in jenkins global config? i think my hygieia connection is not established in jenkins..
Gabe
@roygabriel
I was wondering if anyone had resolved the issue #2 on the VersionOne Collector. We're up and running but it's doing the same thing noted in the issue. It only shows Kanban results, when Scrum is selected it shows nothing. The only thing I did see was the applications.properites file that's located in the collector repo has more entries in it that are not noted in the collector documentation. Specifically "feature.sprintQuery/feature.memberQuery/feature.epicQuery/feature.sprintDays/feature.sprintEndPrior" are these depreciated being they are not in the actual docs and only the repo, or are they needed?
Ejaye
@EjnarAz
Hi can anyone help me I am not getting any commits in our gitlab collector
I have an error Failed to retrieve data, the repo or collector is most likey misconfigured
Ejaye
@EjnarAz
org.springframework.web.client.HttpClientErrorException: 404 Not Found
amritasaha1
@amritasaha1
Hi ...We are setting up Hygieia Dashboard on CentOS machine, after busing CORE, API, deploying API and Running "Gulp Serve" the dashboard is coming up , but we can not see "login fields" after c;licking on "Login" icon
it is saying some API Connectivity and X sign
amritasaha1
@amritasaha1
angular.js:12265 GET http://10.130.154.103:3000/api/dashboard/pagesize 502 (Bad Gateway) - getting this error
amritasaha1
@amritasaha1
Where ever it is trying to connect /api...it is getting 500 Bad Gateway
Ejaye
@EjnarAz

sorry if this is a stupid question but I am trying to connect to our company's gitlab. It is enterprise edition, private repo and needs VPN this is my property files can someone tell me if I am missing anything?

Tried reading through the docs I might be stupid but for encryption what is the core module that the documentation is talking about? is it the api? UI? Hygieia-core? Can someone please help?

cat > $PROP_FILE <<EOF
#Database Name
dbname=${HYGIEIA_API_ENV_SPRING_DATA_MONGODB_DATABASE:-dashboarddb}

#Database HostName - default is localhost
dbhost=${MONGODB_HOST:-10.1.1.1}

#Database Port - default is 27017
dbport=${MONGODB_PORT:-27017}

#Database Username - default is blank
dbusername=${HYGIEIA_API_ENV_SPRING_DATA_MONGODB_USERNAME:-dashboarduser}

#Database Password - default is blank
dbpassword=${HYGIEIA_API_ENV_SPRING_DATA_MONGODB_PASSWORD:-dbpassword}

#Collector schedule (required)
gitlab.cron=${GITLAB_CRON:-*/60 * * * * *}

#Gitlab host (optional, defaults to "gitlab.com")
gitlab.host=${GITLAB_HOST:-gitlab.company.com}

#Gitlab protocol (optional, defaults to "http")
gitlab.protocol=${GITLAB_PROTOCOL:-https}

#Gitlab port (optional, defaults to protocol default port)
gitlab.port=${GITLAB_PORT:-443}

#Gitlab path (optional, defaults to no path)
gitlab.path=${GITLAB_PATH:-}

#Gitlab API Token (required, access token can be retrieved through gitlab, collector will have the permissions of the user associated to the token)
gitlab.apiToken=${GITLAB_API_TOKEN:-"generated personal token from gitlab with all the scopes"}

#Maximum number of days to go back in time when fetching commits
gitlab.commitThresholdDays=${GITLAB_COMMIT_THRESHOLD_DAYS:-15}

#Gitlab Instance using self signed certificate
gitlab.selfSignedCertificate=${GITLAB_SELF_SIGNED_CERTIFICATE:-true}

#Gitlab API Version (optional, defaults to current version of 4)
gitlab.apiVersion=${GITLAB_API_VERSION:-4}

EOF

echo "

===========================================
Properties file created `date`:  $PROP_FILE
Note: passwords hidden
===========================================
`cat $PROP_FILE |egrep -vi password`
 "

exit 0
jacksod1
@jacksod1
Question about the SonarQube collector. Currently, whenever I restart the sonarqube collector the CodeAnalysis widget seems to lose its configuration.
image.png
I have to manually go through all of my projects and re-add the SonarQube Code Analysis job.