These are chat archives for cboursnell/transfuse

7th
Oct 2015
biojl
@egenomics
Oct 07 2015 09:11
we tried it, but we still get the same error
we tried installing it through gem isntall and compiling it
[root@cappra ~]# /usr/local/ruby-2.2.3/bin/gem install bundler
Fetching: bundler-1.10.6.gem (100%)
Successfully installed bundler-1.10.6
Parsing documentation for bundler-1.10.6
Installing ri documentation for bundler-1.10.6
Done installing documentation for bundler after 7 seconds
1 gem installed
[root@cappra ~]# /usr/local/ruby-2.2.3/bin/transfuse
/usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require': superclass mismatch for class Pathname (TypeError) from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/pathname.rb:12:in <top (required)>' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/yell-2.0.5/lib/yell/logger.rb:3:in<top (required)>'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/yell-2.0.5/lib/yell.rb:136:in <top (required)>' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transrate-1.0.1/lib/transrate.rb:3:in<top (required)>'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transfuse-0.4.4/lib/transfuse/transfuse.rb:11:in <module:Transfuse>' from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transfuse-0.4.4/lib/transfuse/transfuse.rb:7:in<top (required)>'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transfuse-0.4.4/lib/transfuse.rb:4:in <top (required)>' from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire'
from /usr/local/ruby-2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transfuse-0.4.4/bin/transfuse:4:in<top (required)>'
from /usr/local/ruby-2.2.3/bin/transfuse:23:in load' from /usr/local/ruby-2.2.3/bin/transfuse:23:in<main>'
if we look at the installed gem packages
bundle is there
Chris Boursnell
@cboursnell
Oct 07 2015 09:13
Hm... sorry.. It seemed to fix the problem in the VM...
biojl
@egenomics
Oct 07 2015 09:13

/usr/local/ruby-2.2.3/bin/gem list

LOCAL GEMS

bigdecimal (1.2.6)
bindeps (1.2.0)
bio (1.5.0)
bundler (1.10.6)
[...]

Chris Boursnell
@cboursnell
Oct 07 2015 09:23
ok i've made a scientific linux VM. going to try to reproduce your environment...
Chris Boursnell
@cboursnell
Oct 07 2015 10:32
Ok @willblev I've made some fixes to the gem. Could you uninstall 0.4.4 and install 0.4.6 with gem install transfuse -v '0.4.6'
or download and install from https://rubygems.org/downloads/transfuse-0.4.6.gem
Will
@willblev
Oct 07 2015 10:36
Thanks, will let you know how it goes
Will
@willblev
Oct 07 2015 16:51
Good news, everyone- It's alive!
Chris Boursnell
@cboursnell
Oct 07 2015 16:53
Great. Thanks for bearing with me :D
Will
@willblev
Oct 07 2015 16:54
Thanks for fielding the error so quickly! Apologies for the delayed and fragmented nature of our responses- we had to wait for our admin to test things out, and he's got a lot of other things on his plate
We'll let you know how we end up using transrate/transfuse :D
Chris Boursnell
@cboursnell
Oct 07 2015 16:59
Excellent thanks :)
Richard Smith-Unna
@blahah
Oct 07 2015 17:22
@willblev both tools are still actively developed, so if you encounter problems we'd love to hear about them
not just bugs/crashes - but any feedback about your experience would be valuable