These are chat archives for cboursnell/transfuse

13th
Oct 2015
Will
@willblev
Oct 13 2015 13:26
Hi again- sorry to bother you again, but when we said that it was 'working' before, we inadvertently lied. We were able to get the welcome message of transfuse, but when we actually tried to run it, we got the following error:
/soft/devel/ruby-2.2.3/lib/ruby/gems/2.2.0/gems/transrate-1.0.1/lib/transrate/snap.rb:17:in `initialize': could not find snap in the path (Transrate::SnapError)

This is strange, as we can see that the gem is installed:
/soft/devel/ruby-2.2.3/bin/gem list
LOCAL GEMS

addressable (2.3.8)
bigdecimal (1.2.7, 1.2.6)
bindeps (1.2.0)
bio (1.5.0)
colorize (0.7.7)
crb-blast (0.6.6, 0.6.5)
facade (1.0.7)
fix-trinity-output (1.0.0)
fixwhich (1.0.2)
io-console (0.4.3)
json (1.8.3, 1.8.1)
launchy (2.4.3)
minitest (5.8.1, 5.4.3)
pathname2 (1.7.4)
power_assert (0.2.4, 0.2.2)
psych (2.0.15, 2.0.8)
rack (1.6.4)
rack-protection (1.5.3)
rake (10.4.2)
rdoc (4.2.0)
rubygems-update (2.4.8)
sinatra (1.4.6)
snap (0.1.4)
test-unit (3.1.5, 3.0.8)
threach (0.2.0)
tilt (2.0.1)
transfuse (0.4.6)
transrate (1.0.1)
trollop (2.1.2)
yell (2.0.5)

Chris Boursnell
@cboursnell
Oct 13 2015 13:32
This means that the aligner snap isn't installed. I didn't know there was a ruby gem called snap as well :P
you need to run transrate --install-deps read
this will install snap which is needed for the transrate part of transfuse.
I mentioned this before in the other channel I think and then remembered I hadn't written that in the readme on the transfuse github page... it's there now, but probably wasn't when you looked before
You can also download snap from here:
https://github.com/Blahah/snap/releases/download/v1.0beta.18/snap_v1.0beta.18_linux.tar.gz
if the transrate automatic installation doesn't work
Will
@willblev
Oct 13 2015 13:36
Hmm. I wonder if our admin already tried that- I think I told him to do it for the previous version of transrate, but IDK if he remembers...
Chris Boursnell
@cboursnell
Oct 13 2015 13:36
Might have been a different version of snap that was required...
try
which snap-aligner
to see if you have it installed
Will
@willblev
Oct 13 2015 13:38
We have the older version (1.0). I'll have him run --install-deps all
FFS... should've checked that before asking! Sorry :)
Chris Boursnell
@cboursnell
Oct 13 2015 13:42
might be better to have him install from the .tar.gz archive i linked above? then he knows where it's going... i can't remember where transrate installs stuff if you have a admin version of ruby...
Will
@willblev
Oct 13 2015 14:04
I'll ask him to try both ways