These are chat archives for cboursnell/transfuse

27th
Jun 2016
monicabritton
@monicabritton
Jun 27 2016 19:45
Hi Folks! I'm having difficulty installing transfuse. I got transrate installed and ran successfully, also vsearch installed (at least vsearch --help works), but transfuse is proving difficult. I thought I finally got all the ruby gems installed, but transfuse --help produces:
Sorry, got disconnected, the error I'm getting is: /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': /home/mbritton/.gem/ruby/1.9.1/gems/transrate-1.0.1/lib/transrate/transrater.rb:23: syntax error, unexpected tLABEL (SyntaxError)
def initialize(assembly, reference, threads: 1)
Any suggestions on troubleshooting? Thanks in advance
Matt MacManes
@macmanes
Jun 27 2016 20:56
you need at Ruby 2.x
wget https://keybase.io/mpapis/key.asc
gpg --import key.asc
\curl -sSL https://get.rvm.io | bash -s stable —ruby
depending on what OS your on, this should install 2.x. It works for Ubuntu.
you may have to uninstall the other older Ruby version.