These are chat archives for ceylon/ceylon-ide-eclipse

11th
Feb 2016
Roland Tepp
@luolong
Feb 11 2016 08:44
I am building Eclipse plugin from source and it buils just fine, but if I try to install or update to the new version, I keep getting this error:
An error occurred while collecting items to be installed
session context was:(profile=_Users_rolandt_Ceylon_Eclipse.app_Contents_Eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,ceylon.bootstrap,1.2.1.v20160210-1242
No repository found containing: osgi.bundle,ceylon.collection,1.2.1.v20160210-1244
No repository found containing: osgi.bundle,ceylon.file,1.2.1.v20160210-1244
No repository found containing: osgi.bundle,ceylon.formatter,1.2.1.v20160210-1245
No repository found containing: osgi.bundle,ceylon.interop.java,1.2.1.v20160210-1244
No repository found containing: osgi.bundle,ceylon.language,1.2.1.v20160210-1242
No repository found containing: osgi.bundle,ceylon.runtime,1.2.1.v20160210-1243
No repository found containing: osgi.bundle,ceylon.tool.converter.java2ceylon,1.2.1.v20160210-1245
No repository found containing: osgi.bundle,com.redhat.ceylon.common,1.2.1.v20160210-1241
No repository found containing: osgi.bundle,com.redhat.ceylon.compiler.java,1.2.1.v20160210-1242
No repository found containing: osgi.bundle,com.redhat.ceylon.compiler.js,1.2.1.v20160210-1242
No repository found containing: osgi.bundle,com.redhat.ceylon.dist,1.2.1.v20160210-1243
No repository found containing: osgi.bundle,com.redhat.ceylon.dist.repo,1.2.1.v20160210-1243
No repository found containing: osgi.bundle,com.redhat.ceylon.eclipse.android.plugin,1.2.1.v20160210-1247-Final
No repository found containing: osgi.bundle,com.redhat.ceylon.eclipse.ui,1.2.1.v20160210-1247-Final
No repository found containing: osgi.bundle,com.redhat.ceylon.eclipse.ui.jdt.debug.fragment,1.2.1.v20160210-1247-Final
No repository found containing: osgi.bundle,com.redhat.ceylon.ide.common,1.2.1.v20160210-1246
No repository found containing: osgi.bundle,com.redhat.ceylon.model,1.2.1.v20160210-1241
No repository found containing: osgi.bundle,com.redhat.ceylon.module-resolver,1.2.1.v20160210-1241
No repository found containing: osgi.bundle,com.redhat.ceylon.test.eclipse.plugin,1.2.1.v20160210-1247-Final
No repository found containing: osgi.bundle,com.redhat.ceylon.typechecker,1.2.1.v20160210-1242
No repository found containing: osgi.bundle,org.jboss.jandex,2.0.0.Final
No repository found containing: osgi.bundle,org.jboss.logmanager,2.0.3.Final
No repository found containing: osgi.bundle,org.jboss.modules,1.4.4.Final
No repository found containing: org.eclipse.update.feature,ceylon.tool.converter.java2ceylon.feature,1.2.1.v20160210-1246
No repository found containing: org.eclipse.update.feature,com.redhat.ceylon.dist.feature,1.2.1.v20160210-1243
No repository found containing: org.eclipse.update.feature,com.redhat.ceylon.eclipse.android.feature,1.2.1.v20160210-1247-Final
No repository found containing: org.eclipse.update.feature,com.redhat.ceylon.eclipse.feature,1.2.1.v20160210-1247-Final
No repository found containing: org.eclipse.update.feature,com.redhat.ceylon.ide.common.feature,1.2.1.v20160210-1246
No repository found containing: osgi.bundle,com.redhat.ceylon.langtools.classfile,1.2.1.v20160210-1241
No repository found containing: osgi.bundle,com.redhat.ceylon.tool.provider,1.2.1.v20160210-1243
No repository found containing: osgi.bundle,net.lingala.zip4j,1.3.2
Does anyone have any idea what is wrong
Bastien Jansen
@bjansen
Feb 11 2016 08:45
are you also updating the other plugins? (dist, ceylon-ide-common, formatter etc)
Roland Tepp
@luolong
Feb 11 2016 08:45
errmm… maybe.. I don’t know...
David Festal
@davidfestal
Feb 11 2016 08:46
let me check here
Roland Tepp
@luolong
Feb 11 2016 08:46
I assume I have to have those repositories referenced somewhere?
David Festal
@davidfestal
Feb 11 2016 08:46
what do you do exactly to install them ?
Roland Tepp
@luolong
Feb 11 2016 08:47
well, after building with mvn clean install -fae
Bastien Jansen
@bjansen
Feb 11 2016 08:47
in the about dialog, click on "installation details", everything related to Ceylon should have the same version
David Festal
@davidfestal
Feb 11 2016 08:48
don't you build with ant clean-all dist sdk eclipse ?
in order to be sure to have everything up-to-date in the local repository ?
Roland Tepp
@luolong
Feb 11 2016 08:48
I just either install from the ${ceylon-ide-eclipse}/site/target/repository/ or (after having added that to list of repositories), just try to update

don't you build with ant clean-all dist sdk eclipse ?

I did that too

David Festal
@davidfestal
Feb 11 2016 08:49
what do you have in the ${ceylon-ide-eclipse}/site/target/repository/plugins ?
the content I mean ?
Roland Tepp
@luolong
Feb 11 2016 08:55
let me see
Bastien Jansen
@bjansen
Feb 11 2016 08:56
I just updated eclipse and everything looks fine
Roland Tepp
@luolong
Feb 11 2016 08:57
ceylon.bootstrap_1.2.1.v20160210-1242.jar
ceylon.collection_1.2.1.v20160210-1244.jar
ceylon.file_1.2.1.v20160210-1244.jar
ceylon.formatter_1.2.1.v20160210-1245.jar
ceylon.interop.java_1.2.1.v20160210-1244.jar
ceylon.language_1.2.1.v20160210-1242.jar
ceylon.runtime_1.2.1.v20160210-1243.jar
ceylon.tool.converter.java2ceylon_1.2.1.v20160210-1245.jar
com.github.lookfirst.sardine_5.1.0.jar
com.github.rjeschke.txtmark_0.13.0.jar
com.redhat.ceylon.common_1.2.1.v20160210-1241.jar
com.redhat.ceylon.compiler.java_1.2.1.v20160210-1242.jar
com.redhat.ceylon.compiler.js_1.2.1.v20160210-1242.jar
com.redhat.ceylon.dist.repo_1.2.1.v20160210-1243.jar
com.redhat.ceylon.dist_1.2.1.v20160210-1243.jar
com.redhat.ceylon.eclipse.android.plugin_1.2.1.v20160210-1247-Final.jar
com.redhat.ceylon.eclipse.ui.jdt.debug.fragment_1.2.1.v20160210-1247-Final.jar
com.redhat.ceylon.eclipse.ui_1.2.1.v20160210-1247-Final.jar
com.redhat.ceylon.ide.common_1.2.1.v20160210-1246.jar
com.redhat.ceylon.langtools.classfile_1.2.1.v20160210-1241.jar
com.redhat.ceylon.maven-support_2.0.0.jar
com.redhat.ceylon.model_1.2.1.v20160210-1241.jar
com.redhat.ceylon.module-resolver_1.2.1.v20160210-1241.jar
com.redhat.ceylon.test.eclipse.plugin_1.2.1.v20160210-1247-Final.jar
com.redhat.ceylon.tool.provider_1.2.1.v20160210-1243.jar
com.redhat.ceylon.typechecker_1.2.1.v20160210-1242.jar
net.lingala.zip4j_1.3.2.jar
net.minidev.json-smart_1.1.1.jar
org.antlr.antlr4-runtime-osgi_4.5.1.jar
org.antlr.antlr_2.7.7.jar
org.antlr.runtime_3.4.0.jar
org.antlr.stringtemplate_3.2.1.jar
org.apache.commons.codec_1.8.0.jar
org.apache.commons.logging_1.1.1.jar
org.apache.httpcomponents.httpclient_4.3.2.jar
org.apache.httpcomponents.httpcore_4.3.2.jar
org.jboss.jandex_2.0.0.Final.jar
org.jboss.logmanager_2.0.3.Final.jar
org.jboss.modules_1.4.4.Final.jar
org.jgrapht.core_0.9.1.jar
org.slf4j.api_1.6.1.jar
org.tautua.markdownpapers.core_1.2.7.jar
David Festal
@davidfestal
Feb 11 2016 08:57
did you do a reload on the local repository ?
Roland Tepp
@luolong
Feb 11 2016 08:58
khmm.. how?
David Festal
@davidfestal
Feb 11 2016 08:59
in list of update sites
Roland Tepp
@luolong
Feb 11 2016 09:00
ah yes, found it … did the reload, but it does not seem to help ..
I will try to do completely fresh install .. see how/if htat helps...
David Festal
@davidfestal
Feb 11 2016 09:01
and did you close the install/update dialog and reopen it ?
David Festal
@davidfestal
Feb 11 2016 09:09
This message was deleted
Roland Tepp
@luolong
Feb 11 2016 09:12
huh… fresh install on blank Eclipse Platform distribution worked
David Festal
@davidfestal
Feb 11 2016 09:15
OK, maybe you should have tried cleaning the p2 caches
you know starting eclipse with -clean, etc ...
Roland Tepp
@luolong
Feb 11 2016 09:16
yes, maybe I should have … Any way .. Eclipse feels sometimes like Windows used to — yoy really need to re-install it every once in a while
David Festal
@davidfestal
Feb 11 2016 09:16
yeah ...
Bastien Jansen
@bjansen
Feb 11 2016 10:26
it looks like the current master doesn't automatically import declarations in pasted code
and it worked fine a few days ago
David Festal
@davidfestal
Feb 11 2016 10:29
didn't change anything here
Bastien Jansen
@bjansen
Feb 11 2016 10:29
does it work on your side?
David Festal
@davidfestal
Feb 11 2016 10:29
don't know I have the 1.2.1 for the moment