These are chat archives for ceylon/ceylon-ide-eclipse

30th
May 2016
David Festal
@davidfestal
May 30 2016 07:53
Hi @bjansen. I'm working on it right now
Bastien Jansen
@bjansen
May 30 2016 07:53
ok
thanks
David Festal
@davidfestal
May 30 2016 08:30
That should be fixed now
@bjansen : Are you the one that triggered the CI build ?
or is it automatically triggered after each commit ?
Bastien Jansen
@bjansen
May 30 2016 08:32
yes
it was me
David Festal
@davidfestal
May 30 2016 08:32
Oh you were very fast
I was about to do it :-)
but too late !
Gavin King
@gavinking
May 30 2016 13:26
@davidfestal are you about?
David Festal
@davidfestal
May 30 2016 13:26
yes
Gavin King
@gavinking
May 30 2016 13:26
we need you
I’m waiting for an answer here: ceylon/ceylon-ide-eclipse#1727
David Festal
@davidfestal
May 30 2016 13:27
ah, yes.
I'll be more on eclipse now
Gavin King
@gavinking
May 30 2016 13:27
And I suspect this problem might be something to do with you
David Festal
@davidfestal
May 30 2016 13:27
since the hardest part on IntelliJ is behind for me it seems
and yes, I saw this problem on intelliJ this morning, and will try to have a look
Gavin King
@gavinking
May 30 2016 13:30
thanks
it’s really ruining my experience with the intellij plugin
David Festal
@davidfestal
May 30 2016 13:30
ah, sorry about that
I'll have a look in priority then
let me first answer you question
on 1727
Gavin King
@gavinking
May 30 2016 13:31
but with that 1727 issue, it looks like you already fixed it — don’t understand why it’s not closed
David Festal
@davidfestal
May 30 2016 13:31
I'm having a look at the GitHiub issue
Gavin King
@gavinking
May 30 2016 19:47
@davidfestal I can’t build the IDE
Bastien Jansen
@bjansen
May 30 2016 19:59
great, now I can't navigate to a package.ceylon by cmd-clicking on an imported package
nor can I navigate to a module descriptor
instead it shows references
Gavin King
@gavinking
May 30 2016 20:01
oh, oops
hehe
that’s easy to fix
once I can get the IDE building again
Bastien Jansen
@bjansen
May 30 2016 20:04
what's the error?
David Festal
@davidfestal
May 30 2016 20:06
@gavinking : do you have a stackTrace or log output ?
Gavin King
@gavinking
May 30 2016 20:06
try to build it
David Festal
@davidfestal
May 30 2016 20:07
of course, I can pull everything, but I have some current work pending
that's why I was first asking for more information :-)
Gavin King
@gavinking
May 30 2016 20:07
look, i can build it after commenting out that test
David Festal
@davidfestal
May 30 2016 20:08
which test ?
ModelAndPhasedUnitTests ?
Gavin King
@gavinking
May 30 2016 20:08
the broken one
that doesn’t seem right
i still find it pretty annoying that I can’t build the IDE at all because a test is broken
David Festal
@davidfestal
May 30 2016 20:08
I fixed one this morning and pushed
and the build succeeded on the continuous integration
Gavin King
@gavinking
May 30 2016 20:09
oh, wait
David Festal
@davidfestal
May 30 2016 20:09
@bjansen had triggered it
David Festal
@davidfestal
May 30 2016 20:17
@gavinking : Is it OK finally ?
Gavin King
@gavinking
May 30 2016 20:49
i think so