These are chat archives for ceylon/ceylon-ide-eclipse

13th
Jul 2016
the ZIP is invalid
and if I use it as a remote repo for Eclipse it fails
is that normal?
David Festal
@davidfestal
Jul 13 2016 14:25
I don't know, honestly.
Stéphane Épardaud
@FroMage
Jul 13 2016 14:25
do we have dev builds in other places?
for 1.2.3?
David Festal
@davidfestal
Jul 13 2016 14:26
Yes, I pushed a dev build on the official dev update site somedays ago
Stéphane Épardaud
@FroMage
Jul 13 2016 14:26
ok thanks
David Festal
@davidfestal
Jul 13 2016 14:26
for matej
(I mentioned it in my last answer)
Stéphane Épardaud
@FroMage
Jul 13 2016 14:28
An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Error closing the output stream for osgi.bundle,com.redhat.ceylon.dist.repo,1.2.3.v20160713-0026 on repository file:/home/stephane/no-backup/src/eclipse-neon/.
Error unzipping /tmp/com.redhat.ceylon.dist.repo_1.2.3.v20160713-00261337942777766618381.jar: Unexpected end of ZLIB input stream
actually same error as on the CI site
David Festal
@davidfestal
Jul 13 2016 14:29
strange
I didn't have that, and matej didn't have that as well when he updated
Stéphane Épardaud
@FroMage
Jul 13 2016 14:29
ok, so how do I resolve this?
I haven't been able to build the IDE lately
and I can't even download it?
David Festal
@davidfestal
Jul 13 2016 14:30
what was the problem to build it ?
I'll have a look
Stéphane Épardaud
@FroMage
Jul 13 2016 14:30
can't remember but last time I asked for help I got the same answer "strange"
and that was that
David Festal
@davidfestal
Jul 13 2016 14:30
really ?
it's with a new raw Neon install ?
Stéphane Épardaud
@FroMage
Jul 13 2016 14:31
yes
David Festal
@davidfestal
Jul 13 2016 14:31
let me try then
Stéphane Épardaud
@FroMage
Jul 13 2016 14:31
thanks
Bastien Jansen
@bjansen
Jul 13 2016 14:35
it updated just fine from CI, here
Neon too
David Festal
@davidfestal
Jul 13 2016 14:35
ah
Stéphane Épardaud
@FroMage
Jul 13 2016 14:36
pffff
tried again, didn't work
except I noticed that even though I selected the DEV site it fetched things from the CI site
David Festal
@davidfestal
Jul 13 2016 14:39
are you sure you disabled the alternate update sites ?
Stéphane Épardaud
@FroMage
Jul 13 2016 14:39
trying again now with the option to query all update sites for missing software unchecked
David Festal
@davidfestal
Jul 13 2016 14:39
to be sure you only use the checked ones ?
Stéphane Épardaud
@FroMage
Jul 13 2016 14:39
I didn't disable it, I just didn't select it, but apparently that's not enough
huge UI fail
OK this time the download worked
damnit
it's stuck at "Committing the provisioning operation" :(
David Festal
@davidfestal
Jul 13 2016 14:43
you have to wait for a while
Stéphane Épardaud
@FroMage
Jul 13 2016 14:43
more than a minute already
wow unstuck
David Festal
@davidfestal
Jul 13 2016 14:43
sometimes it takes quite much time but finally does it
Stéphane Épardaud
@FroMage
Jul 13 2016 14:43
I wonder what this does
that takes so long
David Festal
@davidfestal
Jul 13 2016 14:44
I don't know where it comes from, not sure at all it is Ceylon-related
Bastien Jansen
@bjansen
Jul 13 2016 14:44
yeah it's always taking ages
Stéphane Épardaud
@FroMage
Jul 13 2016 14:45
"provisioning" is a bit like the flux capacitor
well, it "restarted" but that also took like 3 minutes
WTF does it do all this time?
Mars was never that slow
Bastien Jansen
@bjansen
Jul 13 2016 14:48
the first restart on neon took me a while too after I installed Ceylon IDE
but after that it came back to normal
David Festal
@davidfestal
Jul 13 2016 14:49
please open an issue if not already done
just to keep track of it
Stéphane Épardaud
@FroMage
Jul 13 2016 14:49
honestly I doubt this is due to our IDE