These are chat archives for ceylon/ceylon-ide-eclipse

22nd
May 2017
Stéphane Épardaud
@FroMage
May 22 2017 14:46
@davidfestal does the Eclipse IDE support Java files that depend on Ceylon files in the same module?
David Festal
@davidfestal
May 22 2017 14:46
well, partly only
Stéphane Épardaud
@FroMage
May 22 2017 14:49
because I'm seeing errors
in a java file that can't see the ceylon file right next to it
so asking if this is normal
David Festal
@davidfestal
May 22 2017 14:49
it might be normal yes
Stéphane Épardaud
@FroMage
May 22 2017 14:50
ah, ok
Stéphane Épardaud
@FroMage
May 22 2017 15:13
very very unfortunate
John Vasileff
@jvasileff
May 22 2017 16:46
Are there also errors in Ceylon files? IIRC, 1) errors appear in Java files that depend on Ceylon declarations, 2) Ceylon sources are compiled, 3) Java sources are re-compiled, making the errors disappear
I don't recall if (3) happened for me when there are errors in (2)