These are chat archives for chandu0101/scalajs-react-components

14th
Dec 2016
jhegedus42
@jhegedus42
Dec 14 2016 16:59
is it possible to update material-ui to latest version ?
i'd be happy to update the wrapper for latest material-ui
its a little bit out of date
@chandu0101 would it make sense if you would put the generating code to github ?
jhegedus42
@jhegedus42
Dec 14 2016 17:20
@oyvindberg do you perhaps know where can I find the generating code ?
@trepidacious ^ think i found it
Armin Keyvanloo
@arminio
Dec 14 2016 20:11
Hi, just trying to get started with scalajs-react-components but I am a little bit lost as how to include/provide the material-ui javascript. The demo which seems to be using webpack is not working. Can I just do a npm install material-ui instead?
By 'demo is not working' I mean: running npm start I get errors such as:
ERROR in ./~/css-loader!./~/highlight.js/styles/github.css Module build failed: ReferenceError: Promise is not defined
Chandra Sekhar Kode
@chandu0101
Dec 14 2016 22:11
if you want to use mui in your app , yeah npm install material-ui is fine. and you need following config in your web pack index file.
window.mui          = require("material-ui");
window.mui.Styles   = require("material-ui/styles");
window.mui.SvgIcons = require('material-ui/svg-icons/index');
Armin Keyvanloo
@arminio
Dec 14 2016 22:19
@chandu0101 I have tried that but it didn't work for me. fails on npm start
ERROR in ./~/react-tap-event-plugin/src/injectTapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/EventPluginHub' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/injectTapEventPlugin.js 23:2-37

ERROR in ./~/react-tap-event-plugin/src/TapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/EventConstants' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/TapEventPlugin.js 22:21-56

ERROR in ./~/react-tap-event-plugin/src/TapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/EventPluginUtils' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/TapEventPlugin.js 23:23-60

ERROR in ./~/react-tap-event-plugin/src/TapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/EventPropagators' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/TapEventPlugin.js 24:23-60

ERROR in ./~/react-tap-event-plugin/src/TapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/SyntheticUIEvent' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/TapEventPlugin.js 25:23-60

ERROR in ./~/react-tap-event-plugin/src/TapEventPlugin.js
Module not found: Error: Cannot resolve module 'react/lib/ViewportMetrics' in /development/projects/scala/scalajs-react-components/demo/node_modules/react-tap-event-plugin/src
 @ ./~/react-tap-event-plugin/src/TapEventPlugin.js 27:22-58
webpack: bundle is now VALID.
Chandra Sekhar Kode
@chandu0101
Dec 14 2016 22:20
use yarn
@jhegedus42 there is an ongoing PR for mui 0.16 : chandu0101/scalajs-react-components#77
Armin Keyvanloo
@arminio
Dec 14 2016 22:36
what the what is yarn?
Chandra Sekhar Kode
@chandu0101
Dec 14 2016 22:38
Armin Keyvanloo
@arminio
Dec 14 2016 22:40
oh no, I forgot how quickly things become obsolete in js land