These are chat archives for chandu0101/scalajs-react-components

1st
May 2017
Roberto Leibman
@rleibman
May 01 2017 17:29
Hey, hi! I just "upgraded" com.github.japgolly.scalajs-react to 1.0.0
Everything's broke... :(
Is anybody working on it? if so... eta? if not... can I help?
@chandu0101 ? @oyvindberg ?
Roberto Leibman
@rleibman
May 01 2017 17:51
I applied the automated script at curl -s https://raw.githubusercontent.com/japgolly/scalajs-react/master/doc/changelog/1.0.0-migrate.sh | bash and managed to reduce it to 735 compiler errors.
Chandra Sekhar Kode
@chandu0101
May 01 2017 20:45
@rleibman @oyvindberg is the maintiner now :smile:
Roberto Leibman
@rleibman
May 01 2017 21:00
oy! :)
Roberto Leibman
@rleibman
May 01 2017 22:38
I'm down to 161 compiler errors... a good portion of them are:
[error] ~/workspace/git_forks/scalajs-react-components/core/src/main/scala/chandu0101/scalajs/react/components/materialui/MuiStepper.scala:36: type mismatch; [error] found : japgolly.scalajs.react.vdom.VdomNode [error] required: scala.scalajs.js.Any [error] val props = JSMacro[MuiStepper](this) [error] ^