Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Tim McBride
    @deviousgeek
    Hey guys! When compton is enabled, typing into text fields / boxes / the address bar of chrome / chromium is really slow!
    I know there's an issue with popups / context menus in chrome, but that can be avoided thankfully
    a13ph
    @a13ph
    chrome://gpu might help
    Tim McBride
    @deviousgeek
    this issue is a killer though.
    yeah? for logs?
    a13ph
    @a13ph
    for checking status of gpu acceleration etc
    Tim McBride
    @deviousgeek
    it seems to be a mix of both
    a13ph
    @a13ph
    chrome://flags if for trying to get things working
    a13ph
    @a13ph
    i was mostly referring to status. but be its guest
    i'm sorry, i'm just pointing you out to some directions. I myself dropped using compton/compositors, too much setting up without too much effect, sadly. Will probably return to them when I have time to fiddle
    Tim McBride
    @deviousgeek
    Interesting, it seems to only be slow when it's the only window on the screen
    a13ph
    @a13ph
    of course. it's compositor.
    I think you need to get canvas acceleration, but who knows. i have issues even with whole acceleration enabled
    look at compton wiki on github too
    good luck
    Tim McBride
    @deviousgeek
    cheers
    I forced all of them on, did not seem to make a diff.
    Tim McBride
    @deviousgeek
    heh. :)
    nodecraic
    @webworkio
    hey, if anyone has any remote remote , designer, DevOps or Sysadmin jobs they can post them at http://webwork.io
    arisian
    @arisian
    Hi guys, just found compton the other day, and after a bit of fiddling got frustrated that I couldn't set per-wintype values of "active-opacity" and "inactive-opacity". So, I grabbed the latest git code, and hacked it so that I could :smile:
    Anyone who wants to use it is welcome to do so; if the maintainers want to merge it into the main branch, so much the better. I'm not sure if it adheres to all the idioms and style choices of the rest of the codebase, so feel free to modify it further. I went through as little of the original code as possible while getting my feature working, and once it worked, I was happy and I stopped. Therefore, it's also possible it's not the "best" way of doing things, it was just the way that seemed to require the least amount of changes to the existing code.
    arisian
    @arisian
    To use it, just add active/inactive-opacity to a type setting in your config file, e.g.: "wintypes: { dock = { active-opacity = 1.0; inactive-opacity = 0.5; focus = false; }; }"
    In my (admittedly fairly limited) testing, it's seemed to work with no problems; it's always possible (likely, even) that more users trying more things will find a way to break it, but it's not tremendously complicated, so hopefully it won't bork things up for anyone too badly.
    Sudeepto
    @Sudeepto

    Hello guys. I am using Compton on Arch Linux with XFCE . I am having trouble understanding the different variables used in compton.

    I wanted to remove the double glass like shadows from all the GTK apps . So I followed this issue page #189 .

    I added '_NET_WM_OPAQUE_REGION@:c' to my shadow-exclude array. This helped me remove the borders from the GTK apps . And it also made the Whisker menu flat with the panel. Earlier , the Whisker Menu was on top of the panel . Screenshot of Whisker menu with the problem. But now the fading effects are GONE. Also when I scroll a webpage, I get some ripple effect in the middle of the screen. I think it is screen tearing . Sorry I am very new to settings these things up.

    I am also giving you the link of my compton.conf file. Please tell me what should I do change correct things up.

    Link to the compton.conf file

    I have an Integrated Graphics card from Intel . Intel HD 2500 .

    Michael Smith
    @androvix
    hello
    Hubcapp
    @Hubcapp
    Is there any way to rotate windows with compton?
    Oh wait, this is a completely dead chatroom. never mind. Last message 6 months ago
    Stefan Ivic
    @stefanivic
    Hello everyone, quick question. How do i enable blur on compton ?
    Diki Ananta
    @dikiaap
    New version please
    Amos Bird
    @amosbird
    hi
    where can I find the compton's rcfile?
    Amos Bird
    @amosbird
    um, what is the best way to differenciate active and inactive windows ? I find that opacity is not good for my usual need
    Amos Bird
    @amosbird
    Hmm, I just cannot disable the transparency of urxvt when running compton. Anyone knows what might be the problem?
    gothmog123
    @gothmog123
    Is there any chance compton development will resume?
    matisla
    @matisla
    Hey, i'm trying to install compton on Fedora 26, so i need to compile it from the sources. For that, I cloned the repo on my computer, cd compton, but when I launch de compilation with make command, I get this error :
    make: pcre-config: Command not found
    Package x11 was not found in the pkg-config search path.
    Perhaps you should add the directory containing x11.pc' to the PKG_CONFIG_PATH environment variable Package 'x11', required by 'virtual:world', not found Package 'xcomposite', required by 'virtual:world', not found Package 'xfixes', required by 'virtual:world', not found Package 'xdamage', required by 'virtual:world', not found Package 'xrender', required by 'virtual:world', not found Package 'xext', required by 'virtual:world', not found Package 'xrandr', required by 'virtual:world', not found Package 'xinerama', required by 'virtual:world', not found Package 'libconfig', required by 'virtual:world', not found Package 'dbus-1', required by 'virtual:world', not found make: pcre-config: Command not found Package libdrm was not found in the pkg-config search path. Perhaps you should add the directory containinglibdrm.pc'
    to the PKG_CONFIG_PATH environment variable
    Package 'libdrm', required by 'virtual:world', not found
    Package x11 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `x11.pc'
    to the PKG_CONFIG_PATH environment variable
    Package 'x11', required by 'virtual:world', not found
    Package 'xcomposite', required by 'virtual:world', not found
    Package 'xfixes', required by 'virtual:world', not found
    Package 'xdamage', required by 'virtual:world', not found
    Package 'xrender', required by 'virtual:world', not found
    Package 'xext', required by 'virtual:world', not found
    Package 'xrandr', required by 'virtual:world', not found
    Package 'xinerama', required by 'virtual:world', not found
    Package 'libconfig', required by 'virtual:world', not found
    Package 'dbus-1', required by 'virtual:world', not found
    cc -std=c99 -DCONFIG_XINERAMA -DCONFIG_LIBCONFIG -DCONFIG_LIBCONFIG_LEGACY -DCONFIG_REGEX_PCRE -DCONFIG_REGEX_PCRE_JIT -DCONFIG_VSYNC_DRM -DCONFIG_VSYNC_OPENGL -DCONFIG_VSYNC_OPENGL_GLSL -DCONFIG_VSYNC_OPENGL_FBO -DCONFIG_VSYNC_OPENGL_VBO -DCONFIG_DBUS -DCONFIG_XSYNC -DCONFIG_C2 -DCOMPTON_VERSION="\"git-v0.1_beta2-87-g316eac0-2017-04-30\"" -DNDEBUG -O2 -D_FORTIFY_SOURCE=2 -Wall -c src/compton.c
    In file included from src/compton.h:10:0,
    from src/compton.c:11:
    src/common.h:96:10: erreur fatale: X11/Xlib.h : No such file or directory

    include <X11/Xlib.h>

          ^~~~~~~~~~~~
    could someone help me pls ?
    Kris Leech
    @krisleech
    Anyone had an issue with glx backend after upgrading to Ubuntu 18.04?
    yshui
    @yshui
    @krisleech what is the issue?
    M
    @michaelraba
    how do i use glx instead of xrender on arch i3-wm?
    M
    @michaelraba
    Ok, i just specified it in the .conf file
    yshui
    @yshui
    You got it.
    Morgan
    @morganhein
    Howdy! I'm trying to override the opacity for firefox when it is inactive. Something like 'opacity-rule', but for inactive windows instead.
    Marcin Mrugacz
    @Migacz85
    hello
    I enabled kawase-blur using this line: git clone https://aur.archlinux.org/compton-tryone-git.git Overall it look fantastic, - but the main issue with it is performance hit - maybe somebody know about some better - more cpu efficient way to turn kawase blur ?
    ProgrammerPlays
    @ProgrammerPlays
    Hey, I'm unable to clone the repo. Git says the repo just doesn't exist. Specifically, I'm using tyrone144/compton. What should I do?
    PiBu
    @pibuxd
    XD