These are chat archives for chocolatey/ChocolateyGUI

17th
Jan 2017
Manfred Wallner
@mwallner
Jan 17 2017 06:50
hey @RichiCoder1 - what's left on the 0.15 roadmap?
Richard Simpson
@RichiCoder1
Jan 17 2017 09:05
Basically ^. It's a slightly longer list than it appears, and at least some of it is just infrastructure.
Manfred Wallner
@mwallner
Jan 17 2017 11:51
uh ^^ sorry for the dump question :D
Rob Reynolds
@ferventcoder
Jan 17 2017 22:59
@RichiCoder1 any change to get back to 4.5 or is 4.5.2 a hard dependency?
Richard Simpson
@RichiCoder1
Jan 17 2017 23:00
It is for CefSharp and (I believe) at least one other dependency we take.
Rob Reynolds
@ferventcoder
Jan 17 2017 23:00
also chocolatey/ChocolateyGUI#376
Does CefSharp require 4.5.2 or did they just select something higher than 4.0 and land there?
I guess is what i meant
Richard Simpson
@RichiCoder1
Jan 17 2017 23:01
They explicitly require it. There was some very specific reason I forget.
Rob Reynolds
@ferventcoder
Jan 17 2017 23:01
fair enough
Richard Simpson
@RichiCoder1
Jan 17 2017 23:03
I admit, I'm curious why it matters? I understand enterprise enviroments can be strict and finiky about these things, but 4.5.2 is a drop in update over 4.5 and available everywhere 4.5 is?
Rob Reynolds
@ferventcoder
Jan 17 2017 23:03
vagrant reload
setting up a demo environment, I can install everything I need except for chocolatey gui
it requires installing 4.5.2, and then rebooting
then I can install it
the MSI does not recognize that I installed 4.5.2 unless a reboot happens. Not sure why that is
Richard Simpson
@RichiCoder1
Jan 17 2017 23:05
Because microsoft is stupid. I don't think it fully reinstalls until a reboot. Is there not a more up-to-date vagrant image you can base off of? .Net 4.5.2 has been out for over a year ;P
Rob Reynolds
@ferventcoder
Jan 17 2017 23:06
I mean there's that ;)