Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 23 14:51
    gep13 labeled #695
  • Aug 23 14:51
    gep13 milestoned #695
  • Aug 23 14:51
    gep13 assigned #695
  • Aug 23 14:51
    gep13 opened #695
  • Aug 22 13:22
    Sukender opened #694
  • Aug 21 06:41
    gep13 closed #693
  • Aug 21 06:41
    gep13 commented #693
  • Aug 21 06:40
    gep13 milestoned #693
  • Aug 21 06:40
    gep13 labeled #693
  • Aug 21 06:40

    gep13 on develop

    (GH-693) Clarify usage requirem… (compare)

  • Aug 21 06:39

    gep13 on develop

    (maint) Remove mention of ZenHu… (compare)

  • Aug 21 04:00
    Lemmingh opened #693
  • Aug 09 14:39
    cybercatgurrl commented #617
  • Aug 01 08:39
    pascalberger commented #692
  • Aug 01 07:56
    gep13 commented #692
  • Aug 01 07:34

    mwallner on develop

    (build) Disable documentation o… (compare)

  • Aug 01 07:34
    mwallner closed #692
  • Aug 01 07:33

    mwallner on develop

    (doc) Fix typo (#691) (compare)

  • Aug 01 07:33
    mwallner closed #691
  • Jul 31 05:46
    AdmiringWorm commented #637
Hitesh
@TechMinder
I will send the screenshot shortly.
Richard Simpson
@RichiCoder1
:+1:. And the log file too if you can. Should be under %UserProfile%/AppData/Local/ChocolateyGui/Logs or something like that
@RichiCoder1 I don't see any log files generated under user's Appdata folder.
Richard Simpson
@RichiCoder1
Hmm. That def looks like a choco issue. @ferventcoder Does choco have first-start code?
Hitesh
@TechMinder
@RichiCoder1 It should prompt for administrator permission if it requires an administrator rights.
Richard Simpson
@RichiCoder1
The thing is, that call shouldn't. The fact that it does it bizzare.
Hitesh
@TechMinder
@RichiCoder1 @ferventcoder here is the example https://msdn.microsoft.com/en-us/library/bb756929.aspx
Richard Simpson
@RichiCoder1
@TechMinder Haha, you definitely don't need to tell me about proper evelation procedures. We have a whole subprocess just to deal with admin elevation issues ;P
Hitesh
@TechMinder
@RichiCoder1 :) I know you are guys know already, but I shared to clear my problem about the permission.
Rob Reynolds
@ferventcoder
@RichiCoder1 @TechMinder "Access to the path 'C:\Program Files (x86)\ChocolateyGUI\redirects\choco.exe' is denied" looks like a choco issue?
@TechMinder in PowerShell, what does the following return? $env:ChocolateyInstall
Hitesh
@TechMinder
@ferventcoder let me run this command
Rob Reynolds
@ferventcoder
@RichiCoder1 so choco will extract resources on first run, but they are already likely to exist at C:\ProgramData\chocolatey
if it is attempting to extract them elsewhere, you are using a debug-built version of chocolatey lib or that environment variable is not available
Hitesh
@TechMinder

here is my script in batch file ```
SET installerPath=\<network-location>\Packages

CD %UserProfile%\My Documents

SET chocoDir=choco
IF not exist %chocoDir% (mkdir %chocoDir%)

CD %chocoDir%

COPY "\<NetworkPath>\choco\choco.exe"

choco.exe install Chocolatey

choco.exe install chocolateygui --source https://www.myget.org/F/chocolateygui/ --pre --force

choco.exe source add -n internalApps -s %installerPath%
```

It installs both chocolatey and then chocolateygui.
@ferventcoder I checked at user's machine and above batch didn't add environment variable. so '$env:ChocolateyInstall' returns nothing.
$env:ChocolateyInstall
Rob Reynolds
@ferventcoder
the batch may not have it available yet
if you ran that by cmd.exe, you should call echo %ChocolateyInstall%
Hitesh
@TechMinder
@ferventcoder I ran that command in windows powershell.
Rob Reynolds
@ferventcoder
so shells don't update until closed and reopened (for environment variables)
and sometimes explorer won't catch updates either
Hitesh
@TechMinder
@ferventcoder got it!
Rob Reynolds
@ferventcoder
if explorer hasn't noticed, you will need to reboot the machine for it to take effect
but an install of choco will set that variable
you will see it if you head into system properties and look at the variables
or into the registry where those are kept
Hitesh
@TechMinder
@ferventcoder I installed chocolateygui in separate cmd.exe(Administrator). And i got the same Autofac exception on first run. If I run ChocolateyGui as administrator then it works fine.
Rob Reynolds
@ferventcoder
it's creating files it should not
it won't do that if that environment variable is recognized
Hitesh
@TechMinder
@ferventcoder yep! that's the issue. I don't know why it won't create environment variable even if I run the batch as administrator. Do you think it's not right approach to install chocolatey?
@ferventcoder I forgot to mention, the batch file is on shared location.
Rob Reynolds
@ferventcoder
install choco as an admin
that's fine
the problem is likely elsewhere
If you see this only happen on a handful of systems
it's explorer.exe not recognizing the updated values
Hitesh
@TechMinder
it's happening on every machine where I am installing using batch file.
Rob Reynolds
@ferventcoder
you can try this from cmd.exe to trigger it: setx trigger 1, then close and reopen everything
take a look at how choco handles updating environment variables for clues to what may be going on - https://github.com/chocolatey/choco/blob/2f588e755e33e4476f5170494c097932a23e1554/src/chocolatey.resources/helpers/functions/Set-EnvironmentVariable.ps1
Hitesh
@TechMinder
@ferventcoder thanks Rob, let me try this.
Rob Reynolds
@ferventcoder
you can try killing and restarting explorer.exe (it's a bit hacktastic as compared to a reboot, but... (shrugs))
that will ensure all environment settings and changes get loaded
start with setx
Hitesh
@TechMinder
Thanks Rob, I will try the options you provided.
thanks for your help. I will let you know if it gets solved..
Rob Reynolds
@ferventcoder
Also, follow this -chocolatey/choco#1297
Hitesh
@TechMinder
@ferventcoder as per your suggestion, I am setting up envionrment variable ChocolateyInstall through command after installing Chocolatey as an admin. It works now.