Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 13 06:49
    lucknaumann commented #685
  • Sep 13 06:09
    gep13 commented #685
  • Sep 12 23:48
    lucknaumann commented #685
  • Sep 12 11:28
    AdmiringWorm commented #685
  • Sep 11 01:43
    lucknaumann commented #685
  • Sep 11 01:43
    lucknaumann commented #685
  • Sep 10 07:01
    punker76 commented #685
  • Sep 10 06:58
    punker76 assigned #685
  • Sep 10 02:59
    lucknaumann commented #685
  • Sep 10 02:39
    lucknaumann commented #685
  • Sep 01 15:46
    gep13 closed #696
  • Sep 01 15:46
    gep13 labeled #696
  • Sep 01 15:21
    AdmiringWorm commented #696
  • Sep 01 14:35
    superbonaci opened #696
  • Aug 27 09:39
    mwallner labeled #694
  • Aug 27 09:39
    mwallner labeled #694
  • Aug 23 14:51
    gep13 labeled #695
  • Aug 23 14:51
    gep13 milestoned #695
  • Aug 23 14:51
    gep13 assigned #695
  • Aug 23 14:51
    gep13 opened #695
Hitesh
@TechMinder
I am talking about without downloading chocolatey nupkg file.
Richard Simpson
@RichiCoder1
@TechMinder Choco.exe is not standalone. Or at least not completely. It initializes a fair amount of context and settings that must be present for it to work properly.
If you poke inside the nupkg (It's just a zip), you'll notice there's install scripts and tools and helpers and more.
Hitesh
@TechMinder
Thanks @RichiCoder1 , now I got the answer. I will follow the steps defined on the page.
Richard Simpson
@RichiCoder1
:+1: Good luck! If you have anymore questions, feel free to ask (though preferably in chocolatey/choco ;P)
Hitesh
@TechMinder
okay, my goal was to run ChocolateyGUI . so I posted all the questions here. :smile:
Richard Simpson
@RichiCoder1
Absolutely, if you run into Gui specific issues post here.
Hitesh
@TechMinder
Thanks @ferventcoder @RichiCoder1 for help and answering questions.
@RichiCoder1 do we have plan to make choco standalone? It worked for me with extra command to setup environment variable.
Richard Simpson
@RichiCoder1
@TechMinder That's a @ferventcoder question. My understanding is no, but that could change.
Rob Reynolds
@ferventcoder
@TechMinder choco is not required to be downloaded, but you do need the chocolateyInstall.ps1 (and other PowerShell scripts in the package) to get it installed properly
@TechMinder if you do it outside of that as standalone (it could work), but we won't consider that a supported scenario. So when new things would be added, you would be broken and that would be in your purview to find and fix. We prefer you do things in a supported manner. HTH
Hitesh
@TechMinder
@ferventcoder I see choco in nupkg. Anyways, thanks for your help. I have already replaced my script with recommended one.
Hitesh
@TechMinder
@ferventcoder just ignore my last question. I got the answer. I must have this package to get choco. then I can run command.
Rob Reynolds
@ferventcoder
perfect. Was just providing insight for both you and anyone that happens across the convo. :D
EntranceJew
@EntranceJew
latest version from chocolatey (0.13.2) gives me this crash on startup while getting package list https://hastebin.com/isufeximoz.css
Richard Simpson
@RichiCoder1
@EntranceJew I'll echo the comments in the other thread. Try pre-release :)
Details how are on the github page readme.
EntranceJew
@EntranceJew
that one launches no problem :thumbsup:
Richard Simpson
@RichiCoder1
Glad to hear :). Let us know if you run into any further issues!
Rob Reynolds
@ferventcoder
@RichiCoder1 so looking over chocolatey/ChocolateyGUI#438 - it looks good, have you verified it all?
Richard Simpson
@RichiCoder1
@ferventcoder Yup. Gonna tweak two things and merge it
Richard Simpson
@RichiCoder1
@gep13 Random: As of the latest commit, we're not longer having to special case dupFinder. We pass inspection and dup with defaults :)
Hitesh
@TechMinder
@ferventcoder @RichiCoder1 on one of the windows 10 machine, chocolateyGUI throws exception related to .net and wcf pipe.
I am sharing screenshots and chocolatey logs here https://github.com/TechMinder/Shared/blob/master/ChocolateyGUI%20-%20Exception.zip
Richard Simpson
@RichiCoder1
Weird. Will look into it
Hitesh
@TechMinder
Thanks @RichiCoder1
Richard Simpson
@RichiCoder1
@TechMinder Think I found the issue. Verifying and then pushing.
Hitesh
@TechMinder
Thanks @RichiCoder1 , does this fix require re-installation of ChocolateyGUI?
Richard Simpson
@RichiCoder1
It will indeed require updating to the most recent version (of pre-release). I'll have that pushed in about 20 minutes.
Rob Reynolds
@ferventcoder
@RichiCoder1++
The chocolatiest bot this side of the Mississippi
@choco-bot
richicoder1 is on the rise! (Karma: 8)
Hitesh
@TechMinder
@RichiCoder1 were you able to push the fix?
Richard Simpson
@RichiCoder1
@TechMinder It should have rolled out, yes
Richard Simpson
@RichiCoder1
I still want to do some exploration to make sure it's a solid dependency to take, but I'm thinking about pulling on XamlCSS (https://github.com/warappa/XamlCSS). Thought's @gep13? Channel people?
Xaml's styling is super painful and arguably the area that's bogged me down the most improving Gui
Gary Ewan Park
@gep13
@RichiCoder1 totally agree that XAML styling is painful
not played with that package though, so can't speak to how good/bad it is
anything would be better that out of the box experience :D
Richard Simpson
@RichiCoder1
Haha, right? I'm going to pull it down and use it to fix a few style issues around GUI just to see if I like it. If it works, and works well, I think I'll pull it it.
AmmyUI looks cool and looks like it might solve the same problem, but it's way to big of change, to big of a dependency, and to young and unsopported for me to be comfortable.
Gary Ewan Park
@gep13
sounds like we are on the same page :+1:
Manfred Wallner
@mwallner
hey folks, I'm having a hard time building ChocolateyGUI on the current develop branch - it seems the nuget package config for ChocolateyGUI.Shared isn't complete...
Richard Simpson
@RichiCoder1
D:
I'll look into it. Shouldn't be an issue :\
kimcdow
@kimcdow
Anyone know who the package maintainer is for Kodi, one is not listed on the choco gui
Kim J. Nordmo
@AdmiringWorm
@kimcdow that would be dtgm, his repository is here: https://github.com/dtgm/chocolatey-packages
kimcdow
@kimcdow
@AdmiringWorm Thank you
Kim J. Nordmo
@AdmiringWorm
@kimcdow you're welcome
Joshua
@linuxUsr118
Any suggestion, from anyhow, about clearing Chocolatey's library of (now) uninstalled programmes?
Gary Ewan Park
@gep13
@linuxUsr118 there is nothing OOTB in the OSS edition's that will do this for you. The package sync feature in the licensed version: https://chocolatey.org/pricing may have part of what you are looking for.