Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 13 06:49
    lucknaumann commented #685
  • Sep 13 06:09
    gep13 commented #685
  • Sep 12 23:48
    lucknaumann commented #685
  • Sep 12 11:28
    AdmiringWorm commented #685
  • Sep 11 01:43
    lucknaumann commented #685
  • Sep 11 01:43
    lucknaumann commented #685
  • Sep 10 07:01
    punker76 commented #685
  • Sep 10 06:58
    punker76 assigned #685
  • Sep 10 02:59
    lucknaumann commented #685
  • Sep 10 02:39
    lucknaumann commented #685
  • Sep 01 15:46
    gep13 closed #696
  • Sep 01 15:46
    gep13 labeled #696
  • Sep 01 15:21
    AdmiringWorm commented #696
  • Sep 01 14:35
    superbonaci opened #696
  • Aug 27 09:39
    mwallner labeled #694
  • Aug 27 09:39
    mwallner labeled #694
  • Aug 23 14:51
    gep13 labeled #695
  • Aug 23 14:51
    gep13 milestoned #695
  • Aug 23 14:51
    gep13 assigned #695
  • Aug 23 14:51
    gep13 opened #695
Rob Reynolds
@ferventcoder
Logs are not helpful
when I take the latest code in develop and try to run it with non-admin
Rob Reynolds
@ferventcoder
@RichiCoder1 can I get a warm and fuzzy about the above?
Manfred Wallner
@mwallner
hey @ferventcoder , @RichiCoder1 - I've been running into a interesting problem with the GUI lately: I've created a couple of "big meta-packages" at work defining certain "usage-groups" like "main-product-dev", "product-docu" etc, that have dependencies on lots of other packages. - some of them take relatively long to install (like vs2015 ^^) - to overcome a potential timeout (some of my coworkers are in remote locations with sub-optimal internet access) I'm setting the commandExecutionTimeoutSeconds during the install of those large packages. - this works, when running from CLI, but not from the GUI
uh, maybe I can provide a short form of the text above x_x
"The GUI doesn't adapt to config changes made in a chocolatey install script" -> probably a good title for a Issue ? :D
Rob Reynolds
@ferventcoder
:+1: (without reboot)
Also consider 0, infinite timeout
Rob Reynolds
@ferventcoder
@RichiCoder1 @gep13 @mwallner any updates into what may be causing the issue with self-service hookup?
Manfred Wallner
@mwallner
Not yet, will try to look into at the weekend
Gary Ewan Park
@gep13
image.png
@/all ^^
just pushed a version of ChocolateyGUI that once again contains the full version number
this functionality was removed when we switched from psake to Cake
have put this back in play again
Rob Reynolds
@ferventcoder
Awesome!
Chad Abizeid
@chad-abizeid
Hey folks. Just found out about Chocolatey. Pretty neat. Any decent web gui? I found Chocolately GUI but it's clumsy and not really user friendly. Something like Ninite where I can pick a bunch of apps and install with one shot.
Rob Reynolds
@ferventcoder
Chad - there are at least two sites that have that kind of experience out there, no idea whether they are being maintained or not. The GUI you installed, if the interface was not blue we agree with you. The new version is still in prerelease but head to the github page for this room and you will see that
Rob Reynolds
@ferventcoder
@chad-abizeid ^^
Rob Reynolds
@ferventcoder
GUI losing settings when it goes between process and subprocess, something is wacky
EntranceJew
@EntranceJew

I have some usability concerns (using ChocolateyGUI 0.13.2.0)
The base issue stems from having a few problem packages that I like installing from chocolatey but do not want to update at every opportunity.
this means:

  • i can't use "update all", that's a given
  • i can't ctrl+click to select all the packages i want, minus the ones i wish to exclude -- right clicking with multiple selected appears to only impact the clicked package chocolatey/ChocolateyGUI#424
  • i can't right-click a package and select to ignore its updates / move it to a separate view/list
  • i can't get around this bug chocolatey/ChocolateyGUI#462

from the GUI, this looks like:

  1. click "Show Only Packages with Updates"
  2. right-clicking a single package
  3. clicking "Update"
  4. untick "Show Only Packages with Updates"
  5. click "Refresh Packages"
  6. retick "Show Only Packages with Updates"
  7. repeat from 1, for N packages (sometimes up to 13!)
Gary Ewan Park
@gep13
@EntranceJew can I get you to try out the latest version of the ChocolateyGUI application? You can install this from the instructions on the project home page
we should use that as the basis for discussion, as quite a lot of things have changed
EntranceJew
@EntranceJew
@gep13 i ran cuninst chocolateygui and then choco install chocolateygui --source https://www.myget.org/F/chocolateygui/ --pre and now when i launch it and select "Show Only Packages with Updates" it does not blank the screen. additionally i do not have any more packages to update, according to the old version. this happens in both elevated/non-elevated.
or maybe it had to finish the background process.
EntranceJew
@EntranceJew
on the prerelease I tried adding the source i mentioned previously to keep it up to date so i don't gotta have one or the other (or be asked to install the prerelease again) and i got a hard crash https://hastebin.com/bozoyujigo.log
and now it crashes on launch and flashes a dialog box i can't capture the contents of
https://i.imgur.com/ ffdT2Sq.gif
Richard Simpson
@RichiCoder1
@gep13 Belated wooo (for git details in version)
Gary Ewan Park
@gep13
@RichiCoder1 :+1:
Are you now feeling better?
Richard Simpson
@RichiCoder1
Much! I'm now making up at work for having been sick most the month, but otherwise good haha
Gary Ewan Park
@gep13
@RichiCoder1 glad to hear you are feeling better. Let me know when you are more caught up, and we can arrange a chat.
Richard Simpson
@RichiCoder1
@gep13 Absolutely
Gary Ewan Park
@gep13
:+1:
Manfred Wallner
@mwallner
looking at #466 ! :-)
image.png
Manfred Wallner
@mwallner
whoops, just got a hard crash while clicking on a not-resolvable feed in the GUI
image.png
@ferventcoder - I think this is related to #465/ #466 ?
The chocolatiest bot this side of the Mississippi
@choco-bot
Issue 465: Installdir argument not working chocolatey/choco#465
Manfred Wallner
@mwallner
nvm all good, just set my VS to "paranoid" xD
I need to reimplement it but don't see how it was set
Gary Ewan Park
@gep13
I "think" I am right in saying that that is using this:
So not your standard container registration
but rather, a mechanism to instantiate it, as/when required
Richard Simpson
@RichiCoder1
Yup!