Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 29 2015 13:57
    ferventcoder commented on 4af5e76
  • Jun 29 2015 13:48
    ferventcoder commented on 4af5e76
  • Jun 29 2015 13:34
    ferventcoder commented on f9ecefa
  • Apr 08 2015 05:36

    Jaykul on ListCommand

    (compare)

  • Apr 08 2015 05:36

    Jaykul on InstallCommand

    (GH-132) Make InstallCommand a… (maint) Line wrapping. (compare)

  • Apr 08 2015 05:10
    Jaykul commented on 5742f16
  • Apr 08 2015 05:09
    Jaykul commented on 5742f16
  • Apr 08 2015 05:07

    Jaykul on InstallCommand

    (maint) Line wrapping. (compare)

  • Apr 08 2015 04:36
    ferventcoder commented on 5742f16
  • Apr 08 2015 04:28
    Jaykul commented on 5742f16
  • Apr 08 2015 03:13
    ferventcoder commented on 5742f16
  • Apr 08 2015 03:13
    ferventcoder commented on 5742f16
  • Apr 07 2015 16:15
    ferventcoder commented on 83ef921
  • Apr 07 2015 15:06
    Jaykul commented on 83ef921
  • Apr 07 2015 14:46
    ferventcoder commented on 83ef921
  • Apr 07 2015 14:45
    ferventcoder commented on 83ef921
  • Apr 06 2015 16:32

    Jaykul on master

    Add Install and Uninstall Refac… (compare)

  • Apr 05 2015 06:33

    Jaykul on InstallCommand

    (GH-132) Make InstallCommand a… (compare)

  • Apr 05 2015 06:27

    Jaykul on 0.9.9.3

    (compare)

  • Apr 05 2015 06:27

    Jaykul on InstallCommand

    (GH-132) Make InstallCommand a… (compare)

Darwin
@DarwinJS
I take PR's on my packages ;)
Gary Ewan Park
@gep13
could be, I have never been on the site before, so way just stumbling through the site, looks for pricing and then I saw the one I linked to
Darwin
@DarwinJS
LOL! - direct me to the comment and I'll take a look.
Gary Ewan Park
@gep13
hmm, I think it was on here, two secs...
Darwin
@DarwinJS
I can't keep up with the volume here - sorry.
Gary Ewan Park
@gep13
@DarwinJS no, sorry, can't find it. It was basically a suggestion to change the shim that you create in the .Net Version Checker away from dotnet. With the upcomgin release of the dotnet cli, there will be a conflict for people who have both installed
Darwin
@DarwinJS
@jdemate - to be very clear - it is ONLY Windows 7 and Server 2008 R2 that must install WMF 4 before going to 5. New versions of Windows can apply WMF 5 directly.
@gep13 - so you are suggesting I rename the default name of the EXE? Makes sense.
Gary Ewan Park
@gep13
@DarwinJS oh, sorry, I thought you were creating a shim. I didn't realise that this was the actual name of the exe
that makes things harder
the ideal would be to have the author rename the exe name, but not sure how likely that would be to happen
Darwin
@DarwinJS
@jdemate - are you supporting servers that are in part of a Continuous Delivery pipeline (constant code being deployed to them?) - or Traditional Ops - servers in an internal company infrastructure?
It would be just a rename
Probably needs a GUI shim too - realized another of my packages does
Gary Ewan Park
@gep13
:+1:
maxellnormalbias
@maxellnormalbias
hey uh, I just downloaded windows 10 into a VM and i wanted to install chromium and synergy on my system and have them auto update
but when i type "install-package -name chromium"
it just runs and doesn't output anything
and there's nothing in %appdata% or program files
Rob Reynolds
@ferventcoder
howdy - you are using a prototype and not an official provider. We suggest you stick to an official provider like choco.exe or ChocolateyGUI until we announce the official provider in the newsletter
Official client like choco.exe
maxellnormalbias
@maxellnormalbias
oh.
i'll install choco then.
excited for when an official provider comes out tho! :)
dragon788
@dragon788
@maxellnormalbias you might also check out Boxstarter.org, it uses Chocolatey but adds a bit more sugar
Derek Schauland
@webjunkie_twitter
I'm trying to figure out how to get a constant installation of a chocolatey package using the PowerShell method install-package ... Is it possible to get these to live in c:\program files\ rather than a seemingly random temp folder? thx
dragon788
@dragon788
you can pass a specific folder to install a package to per package
the actual installs happen to C:\ProgramData for the most part because this requires Administrator permissions and prevents any tampering with the programs
Derek Schauland
@webjunkie_twitter
When I run the script with -verbose it lists the installing directory as c:\users\user\appdata\local\temp\randomnumber but the randomnumber dir doesn't exist in \temp when I go chasing it
Also running get-package sysinternals indicates it is not installed
dragon788
@dragon788
I believe that the choco provider is currently in beta, it has been recommended to just use regular Chocolatey while they sort out some of the issues with OneGet/PowerShellGet
does install-package report any errors when installing?
also, do you have PsGet or any other providers enabled?
Derek Schauland
@webjunkie_twitter
The chocolatey package source is available but it doesn't appear under package providers... although I do not recall if it had before
no errors with install-package
Rob Reynolds
@ferventcoder
@webjunkie_twitter definitely want to wait for the official provider if you want to use Chocolatey in any capacity. We have a newsletter you can subscribe to and await for the official OneGet provider
for now, we definitely suggest you stick with either choco.exe or ChocolateyGUI for the best support and fixes, including any security issues that have been handled since the preview for the OneGet provider was released
Derek Schauland
@webjunkie_twitter
Cool Ill give that a shot
thanks
Vinay26k
@Vinay26k
There's a problem in installing chocolatey in Win 10 , I've tried all the installation methods mentioned in the https://chocoalatey.org page, the installation error is Exception calling "DownloadString" with "1" argument(s): "The remote server returned an error: (403) Forbidden."
At line:1 char:1
iex ((New-Object System.Net.WebClient).DownloadString('https://chocol ...
~~~~~
CategoryInfo : NotSpecified: (:) [], MethodInvocationException
FullyQualifiedErrorId : WebException
David McElroy
@dmce
Hi, is there any word on this becoming an official provider?
Rob Reynolds
@ferventcoder
Still on the plan. Priorities were shifted a bit though
dragon788
@dragon788
@Vinay26k are you doing this from an elevated prompt and using the option to set the -ExecutionPolicy Bypass ?
also assuming you got help since this channel has so little activity and the other are pretty hopping :)
Blake
@bswerdlen

Hi everyone, I have an issue with the Chocolatey OneGet provider and I'm hoping you can point me in the right direction. Whenever I try to register a package source or download a package which requires a user name and password, I get a 401 back when using this provider. The NuGet server I am using is hosted in Artifactory where I also have a NuGet and PowerShellGet repo setup. The NuGet and PowerShellGet repo's are also password protected and work just fine, but anytime I try to use the chocolatey provider, even for the same functioning repo's, I get the 401. I have even tested connecting to my Chocolatey repo and telling OneGet to use the NuGet or PowerShellGet providers, and the repo configures its self without issue and packages can be searched and downloaded (of course they don't execute properly since the choco engine is never kicked off when I set them up in this manner).

Any assistance or advice you could provide to help me work around this would be greatly appreciated.
My apologies if there is already an active issue around this, I couldn't find it

Rob Reynolds
@ferventcoder
@bswerdlen don't use it yet
Blake
@bswerdlen
thx
George.IO
@Geogboe
Hi guys, I've been utilizing Chocolatey a lot and a OneGet provider would really work well in my env so I'd like to help out with the project. I'm a bit rusty on C# though, is there any way I can still assist or a good getting started point you all could point me to as in, specific features or issues I can tackle?
George.IO
@Geogboe
Just wanted to document an interesing situation I had when building from source using Win10, VS17 Community, and Windows ADK pre-installed if anyone else has this. Line 222 seems to be an extra unnecessary #endregion which doesn't pair with anything. Commented it out. Also, the Path HKCU:\Software\PackageManagement\Tools\MT.EXE for my system was pointing towards arm64 not x64...and the build script looks at the reg key to find the path to the compiler...or library..or something. So that definitely didn't work. Possibly because I had done some Xamarine stuff before. So I had to change that and then the build succeeded.