Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 13 2017 14:04
    zippy1981 closed #287
  • Oct 13 2017 14:04
    zippy1981 closed #274
  • Aug 28 2017 20:41
    ferventcoder labeled #728
  • Aug 28 2017 20:41
    ferventcoder closed #728
  • Aug 28 2017 20:41
    ferventcoder commented #728
  • Aug 28 2017 15:07
    laxselocke opened #728
  • Aug 27 2017 20:15
    ferventcoder commented #140
  • Aug 27 2017 18:23
    acgetchell commented #140
  • Aug 27 2017 18:21
    acgetchell commented #140
  • Aug 27 2017 14:00
    ferventcoder commented #140
  • Aug 27 2017 13:56
    ferventcoder commented #140
  • Aug 27 2017 13:54
    ferventcoder commented #140
  • Aug 27 2017 13:54
    ferventcoder commented #140
  • Aug 27 2017 13:54
    ferventcoder commented #140
  • Aug 26 2017 20:59
    acgetchell commented #140
  • Aug 26 2017 20:59
    acgetchell commented #140
  • Aug 26 2017 20:49
    acgetchell commented #140
  • Aug 26 2017 20:48
    acgetchell commented #140
  • Jun 13 2017 21:32
    alexchandel commented #272
  • Jun 03 2017 21:24
    ferventcoder closed #727
Mubarak Harran Alketbi
@MHketbi
I don't remember i keep hitting the chat thing on the main site
To be honest, i would suggest total migration
Drop the google forum, drop gitter
Make a proper forum
Mubarak Harran Alketbi
@MHketbi
With proper sections
Last time gitter was updates on iOs is 2 years ago
Rob Reynolds
@ferventcoder
Slack?
Mohsin Yasin
@mohsinis
@ferventcoder I am having an issue with the Dropbox installation. Installation is failing [please check logs]
`2019-02-19 16:01:11,521 11752 [ERROR] - ERROR: Running ["C:\Users\artifactInstaller\AppData\Local\Temp\chocolatey\dropbox\67.3.79-beta\Dropbox 67.3.79 Offline Installer.exe" /s ] was not successful. Exit code was '-2147219198'. See log for possible error messages'
RB
@RedBaron2
@mohsinis most of the time that error code means you need to reboot
Miodrag Milić
@majkinetor
Whats wrong with this verification: https://chocolatey.org/packages/checkpoint/5.82.00
Locally works fine and gist also looks fine
Jekotia
@Jekotia
@majkinetor fileenterror.htm is failing to meet the expected checksum according to an error near the end.
Jekotia
@Jekotia
I'm trying to build an internal package for an application (IronCAD 2019) which has its own Service Pack installers released. I'm trying to figure out how to turn the main application + service packs into chocolatey packages, and I'd appreciate input on if my approach is a good one.
The primary package would be the metapackage ironcad2019 which installs nothing but declares ironcad2019-sp2 as a dependency. ironcad2019-sp2 would install the service pack, but also declare ironcad2019-sp1 as a dependency. ironcad2019-sp1 would install the service pack, but also declare ironcad2019.install as a dependency. ironcad2019.install would install the software. This would have the effect of 'choco install ironcad2019' installing ironcad2019.install, ironcad2019-sp1, and ironcad2019-sp2 in that exact order, correct?
(with the ability to add service packs to the top of the stack to maintain this behaviour with updates & new installs)
Gary Ewan Park
@gep13
@Jekotia before answering your question, I think it is worthwhile pointing out that this isn't the main Gitter channel that we use for folks asking questions. You can find that here:
Not sure how you found this channel, but if you got here from some documentation, can you let me know, as we will need to get that updated.
Regarding your question...
Jekotia
@Jekotia
Ah, my apologies!
Gary Ewan Park
@gep13
Your approach seems like a valid one to me.
Absolutely no need to apologise, just wanted to let you know.
Jekotia
@Jekotia
Thanks for the feedback :)
Miodrag Milić
@majkinetor
@Jekotia Your approach will be hard to maintain if any of the package in the hierarchy is embedded as currently they might fail on push, then entire upper hiearrchy that depend on it will fall verification. This is due to the long ongoing bug on the gallery. If you don't have embedded packages then it will work OK.
Gary Ewan Park
@gep13
@majkinetor it was originally mentioned that...
I'm trying to build an internal package for an application (IronCAD 2019)
Miodrag Milić
@majkinetor
yeah, 'internal' not being specified
Gary Ewan Park
@gep13
As such, I don't think that issue will have any bearing here
Miodrag Milić
@majkinetor
what exactly means
and what kind of server uses
gallery available on prem among alternatives ?
if so, the same bug
Gary Ewan Park
@gep13
Using an internal version of the Chocolatey Gallery is certainly not recommended. All our documentation points to the usage of something like Nexus, ProGet, or Artifactory.
Miodrag Milić
@majkinetor
why did this guy got this error

I get this error when I try to upgrade DBeaver.

dbeaver not upgraded. An error occurred during installation:
Already referencing a newer version of 'chocolatey-core.extension'.


I have the following versions of chocolotay cli installed.

chocolatey 0.10.15
chocolatey-core.extension 1.3.5.1

dbeaver depends on chocolatey-core 1.1
Gary Ewan Park
@gep13
@majkinetor probably best to ask this question in the chocolatey/choco gitter room. There are more folks in that chat room. This one is really in archive mode
Miodrag Milić
@majkinetor
dependency is not exact
ah, ok, thx
but since you are here ?
do u know
I don't recall I have ever seen this err
Gary Ewan Park
@gep13
Short answer is, off the top of the my head, I am not sure. Would need to dig into it, and I am just away to sign off for the night.
Miodrag Milić
@majkinetor
ok
villamas
@villamas

Hey, guys, I'm using chocolatey with a private nuget feed from Azure DevOps

I'm able to install packages from powershell with the command
choco install - $name --version=$version -s="$FeedURL" -u="$FeedUserName" -p="$FeedPAT" --params="$packageParams" however
I'm getting an error using nuget chocolatey.lib v0.10.15 (C#)

Message "Cannot read keys when either application does not have a console or when console input has been redirected from a file. Try Console.Read."

is there a way to specify the -p and -u arguments using chocolatey.lib?
where can I find the source code chocolatey.lib ?

Rob Reynolds
@ferventcoder
https://github.com/chocolatey/choco is the source code for lib/exe
And yes, you can pass the params for those items. You will likely need to see how choco does it and then set those same items
If you have any additional comments or questions, reference the link to this conversation, but let's move it to chocolatey/choco room. Thanks!
Gary Ewan Park
@gep13

@/all We have enabled a bot in this room which will automatically delete any messages that are not from the Gitter Chocolatey Moderation Team.

We would encourage everyone to use the new Chocolatey Community Chat on Discord at https://ch0.co/community and https://ch0.co/community-support if you have any questions.