Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Karmendra Suthar
    @karmendra
    you are trying to install api-gaurd v0.1 on laravel 5 or above, I believe, thus the error. if you are using Larvel 5+ in your compoer use version 2.0+ of apigaurd "chrisbjr/api-guard": "~2.0",
    Kiran
    @devkiran
    thank you Karmendra, that worked.
    Kiran
    @devkiran
    Can i customize the error response sent by the api-guard ?
    Stephan Galea
    @fairmutex
    hi all
    Lukas
    @LukvonStrom
    Hey, as asked here before will a lumen version be available ? At the moment I'm building some APIs and it would be great to use the api-guard with lumen
    David D.
    @ddimaria
    Hi, I just upgraded to L5.2 and pulled the latest apiguard from dev-master. I'm getting this error: Class apiguard does not exist. Anyone else getting this?
    Sergei Lemnev
    @enotys
    @ddimaria +1 dev-master NOT worked with L5.2 and "stable" 3.0.3 not worked :(
    Sergei Lemnev
    @enotys
    For 3.0.3 I add field protected $apiMethods = []; in all controllers extended ApiGuardController and now all working with laravel 5.2
    devravi
    @devravi

    Hello there,
    My application is build with laravel 5.0.33,
    I did 'composer require chrisbjr/api-guard' and it install with dependencies,

    When I add 'Chrisbjr\ApiGuard\Providers\ApiGuardServiceProvider::class,' to service provider it throws below exception,

    unknown service provider Chrisbjr\ApiGuard\Providers\ApiGuardServiceProvider::class.

    Astrit Zeqiri
    @astritzeqiri

    When i make a request to my contoller:
    i get this:

    Argument 1 passed to Chrisbjr\ApiGuard\ApiGuardAuth::__construct() must be an instance of Chrisbjr\ApiGuard\Contracts\Providers\Auth, null given, called in E:\xampp\xampp\htdocs\2016\api\vendor\chrisbjr\api-guard\src\Providers\ApiGuardServiceProvider.php on line 49 and defined

    P.S. I am using laravel 5.2
    untitled-1

    alt
    Robert Mennell
    @skatcat31
    This message was deleted
    Unr3al011
    @unr3al011_twitter
    hello
    Petyo Tsonev
    @petyots
    Hello :) You can use petyots/api-guard repo it supports Laravel 5.3.x
    Keannu Zeigfeld
    @ManifoldParadox
    Hello, How do you make a request with the api key?
    The documentation says curl --header "X-Authorization: 2ed9d72e5596800bf805ca1c735e446df72019ef" http://localhost:8000/api/v1/books
    but i want to access it like locahost/api/{api_key}/books
    Petyo Tsonev
    @petyots
    Then make a middleware
    or group the routes with this segment
    Chris Bautista
    @chrisbjr
    Hi all - v4.0.0 has been tagged - this is a complete rewrite and will only work with Laravel 5.3 and 5.4. Thanks
    Ghost
    @ghost~586ad513d73408ce4f40bfcc
    Hi there
    the readme tells about an api_logs table, but i cant find it anywhere in the code / also not in other branches
    also i was wondering how you can submit multiple object in the same request. validator does not seem to like it when i submit more then 1
    Ghost
    @ghost~586ad513d73408ce4f40bfcc
    @chrisbjr still active here?
    Muhammad Junaid Nasir
    @junaidnasir
    ^^ I don't think so. it was incompatible with laravel 5.5, I have submitted a PR. but to continue with my project I will be pushing it to packigst
    ahmedeltokhy
    @ahmedeltokhy
    hello all
    i installed the the package but when i trying to migrate it tells that nothing to migrate
    i did all the steps even the publish, it is on laravel 5.4
    ratatatKE
    @ratatatKE

    Are the generated API keys unique? Is there likely to be a situation where users share the same API key?

    I am just from running the database migration and have noticed that there is no unique constraint for the field api_key in api_keys table. Can anyone clarify