Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Apr 08 16:45
    tmcgee closed #984
  • Apr 08 16:44
    tmcgee milestoned #984
  • Apr 08 16:44
    tmcgee labeled #984
  • Apr 06 21:03
    snyk-bot opened #984
  • Mar 31 12:58
    tmcgee commented #983
  • Mar 31 01:17
    duckblaster edited #983
  • Mar 31 01:16
    duckblaster edited #983
  • Mar 31 01:16
    duckblaster edited #983
  • Mar 31 01:16
    duckblaster edited #983
  • Mar 31 01:15
    duckblaster opened #983
  • Mar 30 21:04
    snyk-bot opened #982
  • Mar 24 19:24
    tmcgee commented #981
  • Mar 24 18:42
    azinsharaf opened #981
  • Mar 18 16:34
    adrianrb commented #980
  • Mar 18 16:34
    adrianrb closed #980
  • Mar 18 13:25
    adrianrb opened #980
  • Mar 18 13:21
    adrianrb edited #979
  • Mar 18 13:20
    adrianrb opened #979
  • Mar 18 12:59
    adrianrb closed #977
  • Mar 18 12:59
    adrianrb commented #977
Tim McGee
@tmcgee

@KhaledMona That method of using `'locale' in dojoConfig used to be supported by WAB but perhaps it isn't any longer in more recent versions of WAB. It seems to ignore it.

The default for WAB is to use the web browser's locale/language. When I change the language for my browser, the WAB widgets respond appropriately using the appropriate locale.

And most of the support for Web AppBuilder is in the Esri community forums: https://community.esri.com/community/gis/web-gis/web-appbuilder

KhaledMona
@KhaledMona
Ok, How to change my cmv wab from right to left ??
Tim McGee
@tmcgee
@KhaledMona This is how it used to be set with old versions of WAB: https://github.com/cmv/cmv-wab-widgets/blob/master/config/wabapp-config.js#L6 That should still work though I haven't tested it in several years. It is possible they may have changed their approach in newer versions of WAB.
ivo silvestre
@ivomts
Does anyone know how to disable the legend of a custom basemap when printing? Most the time the printing task fails. Tks in advance
KhaledMona
@KhaledMona
@tmcgee
In WAB ,
When i change the browser language the titles of left list don't changed , How to solve this problem ??
and The ( 'isRTL': true ) is don't work , are there another way ??
and the support channel don't work
Tim McGee
@tmcgee

@KhaledMona The titles in the left sidebar are yours to edit as you like. They are not associated with WAB in any way. The cmv-app demo provides an example of how to handle multiple languages.

isRTL in WAB is not well documented so unfortunately I don't have any more detail to provide.

Not sure what you mean by "the support channel don't work". The Esri community that I linked to is active and available.

Tim McGee
@tmcgee
@ivomts RE: "Most the time the printing task fails" suggests you need to troubleshoot the Print Service. I find the best way to do that is using the REST API. For layers on the map (basemap or otherwise), often the failure of the Print Service is due to the ArcGIS Server not being able to access the specific layer due to a timeout or network issue. The response from the Print Service usually identifies the error. Here is an old article that is still relevant for troubleshooting the Service.
KhaledMona
@KhaledMona
@tmcgee
Thank you , Finally I need the wab documentation , please ??
Tim McGee
@tmcgee
@KhaledMona This is the entry point for the English version of the WAB documentation: https://doc.arcgis.com/en/web-appbuilder/index.html
KhaledMona
@KhaledMona
@tmcgee Thank you
Tim McGee
@tmcgee
@KhaledMona :thumbsup: I hope it helps you out.
Denverino
@Denverino
Hi everyone. I need to example of config imageParameters. Especially i need to know how to set imageSR and bboxSR parameters in query string. Thank you.
KhaledMona
@KhaledMona
coordinates: {
                include: true,
                id: 'coordinates',
                type: 'ui',
                placeAt: '.cmv-ui-map .cmv-ui-bottom-left',
                path: 'jimu/BaseWidgetPanel',
                options: {
                    widgetManager: true,
                    config: {
                        widgets: [
                            {
                                id: 'WABCoordinate',
                                uri: 'wabwidgets/Coordinate/Widget'
                            }
                        ]
                    }
                }
            },
Where I found the documentation about options ??
eyad
@eyad0599
Hi friends, I want to run wab without turning on the internet, can I please help?
Tim McGee
@tmcgee
@eyad If you use Esri's Web AppBuilder by itself, you will need access Arcgis on-line or an instance of portal. You can use WAB widgets with CMV without an internet connection though libraries like the ArcGIS JavaScript API, Font Awesome, etc, and any map layers would need to be served locally - definitely possible but perhaps more limited in functionality.
@Denverino You can use the buildImageParameters function as a starting point.
kjohnsonGIS
@kjohnsonGIS
Hi @tmcgee I'm using cmv 2 beta 2 release and want to upgrade the esri js api from 3.21 to the latest 3.33. I'm trying to get rid of BUG-000116101. on the api change besides updating my index.html page, any cmv edits i need to make? do you know of any gotchas with doing this? I am testing it right now and everything seems fine so far. Thanks
Tim McGee
@tmcgee
@kjohnsonGIS I am not aware of any changes required in CMV specific to supporting versions 3.22 or higher. I expect it to just work.
kjohnsonGIS
@kjohnsonGIS
ok great, thanks @tmcgee
gisfinder
@gisfinder
@tmcgee I'ms trying the editor widget, try to edit in one featurelayer, in the console I see the network request is with proxy:"http://localhost:63342/cmv-app-develop/viewer/proxy/proxy.ashx?http://myserver1:8090/arcgis/rest/services/wh/testattach/FeatureServer/0/applyEdits". I did not use proxy. The network result is "404" . Try to edit another layer in another server , the network request did not with proxy. The widget can work. I can not identify what's the problem it is.
eyad
@eyad0599
I run cmv wab without portal and without internet, but Basemap Gallery does not work. Why?
Tim McGee
@tmcgee
@eyad0599 By default, the Esri Baseemap Gallery widget uses basemaps hosted by Esri at ArcGIS.com. You can use the basemaps configuration property to provide an array of your own internal basemaps. You will also need to set the showArcGISBasemaps configuration propert to false so it does not attempt to add the ArcGIS basemaps.
csikora
@csikora

Hello (after a long time)! Is there any way to have the identify widget work with a FeatureServer (such as through ArcGIS Online)?

It does not work on single features either in my app (https://maps.psc.wi.gov/apps/WisconsinBroadbandMap/) or the demo app. However, I noticed in the demo app, that the identify widget seems to work on the clustered points in Northwest Arizona. How is this working? Can it be replicated?

Tim McGee
@tmcgee
@csikora There are no feature layers within your app so I could not test what you are describing there. From my testing, identifying features in a feature layer does work in the demo app - both for clustered and non-clustered features. Esri has cleared out the data in the Restaurant layer (they do that on occasion) so clustering is not as effective in the demo but it does work. There is also the San Francisco 311 Incidents layer in the demo that you can turn on. Lots of features over the city of San Francisco that can be identified.
csikora
@csikora

@tmcgee You are correct. I was only meaning to send the "public" app yesterday. This one has the feature layer in it: https://maps.psc.wi.gov/apps/WisconsinBroadbandMap20200914/

At the moment, mine isn't working, and the demo only seemed to work when I clicked on a clustered point.

ahwinz
@ahwinz
ESRI has disabled the geocoder used in cmv in favor of their search/worldwide geocoder. How can i implement this into cmv?
Tim McGee
@tmcgee
@ahwinz CMV switched to the new Esri Search widget when the deprecation of the Geocoder was announced over 3 years ago. Look at the viewer.js file in the cmv-app repo for the current configuration parameters.
ahwinz
@ahwinz
@tmcgee thanks.
duckblaster
@duckblaster
Maybe a future update to Universe will manage to fix the ShitHappens bug, but I'm not holding my breath waiting :P
Tim McGee
@tmcgee
@duckblaster PRs for the ShitHappensInTheUniverse bug will be gladly accepted! 😉
Hope all is well with you!
duckblaster
@duckblaster
yeah, all well, meant to put that in a different channel, but it still applies in general
Tim McGee
@tmcgee
It definitely applies!
César Augusto
@carrbrpoa
Hello! Have you ever tried to geometry Search a view published as a service with CMV?
tigerwoulds
@tigerwoulds
Hello! New here - I have an issue with the Layer Control widget showing duplicate layers from a map service. The map service has 5 layers (confirmed by viewing the rest service in ArcGIS Online) but in my CMV web map the last layer is showing twice. Has anyone seen this before or have any ideas?
Tim McGee
@tmcgee
@tigerwoulds That is not something I have seen before. Can you share the operationalLayers section from the configuration file for the app?
tigerwoulds
@tigerwoulds
@tmcgee I actually found the issue. The service was using grouped symbology. For example, 2 unique values were grouped in ArcMap and symbolized as one color. This particular service was being published to an old version of ArcGIS Server 10.2.1 and the server didn't like that. Ungrouping the symbology fixed the issue.
Denverino
@Denverino
Hello! Something wrong with my proxy. I use it for arcgisonline and one else resource to view in cmv in intranet. So 2-3 weeks ago this resources broken in my cmv, but they work fine on my server. So in f12 i saw 500 error. "SSL/TLS". I changed with google help proxy.ashx one row "ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;" on next: "ServicePointManager.ServerCertificateValidationCallback =delegate{return true}". But it work only few hours and after broke again so i need change this rows back for work.
Can anybody explain me what i need to do?(
Tim McGee
@tmcgee
@Denverino I don't have a specific answer to your question as I do not use the resource proxy with ArcGIS Online. You can ask specific questions about Esri's resource proxy over on GitHub. Also note that the resource proxy is in the process of being deprecated (Esri/resource-proxy#556) by Esri. The changes noted there may offer a few recommendations that are possibly applicable to your situation.
Denverino
@Denverino
@tmcgee thank you very much for answer!
Denverino
@Denverino
There is a new CP-Inspection root certificate using by arcgisonline web services from 22.01.2021 to 22.01.2031. May be this is the reason of my proxy troubles? @tmcgee what do you think?( I updated esri proxy to 1.1.2 version, but nothing, i had the same 500 errors sometimes
Denverino
@Denverino
I have one more question in cmv. Sorry(. I configured query link for layer. This layer have a connection with some arcgis table in my project. So, search widget work fine, but don't work 'zoom to'((
QueryParameter type 'spatial'
msamwill
@msamwill
Hello Tim, quite some time ago you stated to @yogeshsharma505 The current version of CMV hosted on GitHub works with version 3.x of the ArcGIS Javascript API. That version of the API does not support 3-D. I have a version of CMV that works with version 4.x, including 3-D. However, that version is not available on GitHub. I've stopped guessing when I might release that version beyond a few of my existing customers who supported that effort. Working with the current CMV and supporting my customers has kept me very busy these past few years. Any chance I can get a copy of the 4.x version?
Glenn
@RiverGlen
Hi @tmcgee, how would one go about citing the CMV say, in a peer reviewed journal? Do you have a citation formatted that one could use to cite?
adeelahmed30
@adeelahmed30
Hi, i am new to cmv my question is there any cmv version which can be use for cesiumjs 3d api. i am looking for cmv cesium version can anybody help me in this regard
Tim McGee
@tmcgee

I am catching up after having been offline for a few weeks to attend to some family matters.

@msamwill Recently there was been quite a bit of renewed interest in CMV with support for 4.x. One of my clients has finally (FINALLY!) committed to support this effort to complete the integration with 4.x. That is underway with an expected completion hopefully within a month or so. Once complete, I will post the code on GitHub - it might start as a small beta test before opening completely to the public.

@RiverGlen That sounds very interesting. Please let us know if/when that gets published. There have been a few articles and presentations over the years that have cited CMV. There hasn't been a standardized citation other than reference to the GitHub source code repo at https://github.com/cmv/cmv-app.

@adeelahmed30 I have always thought that integration with cesium would be a very interesting addition to the CMV project. Unfortunately, I don't know of any work that has been done on that integration.

adeelahmed30
@adeelahmed30
@tmcgee thanks for your reply i am now a days looking to customize cmv viewer for cesium but no luck in this regard till now hopefully we be able to do if you have any input which can guide me plz share with me