These are chat archives for coala/coala-bears

14th
Mar 2018
John Vandenberg
@jayvdb
Mar 14 2018 04:24
read the logs on appveyor, look for lines which suggest there is an error
Viresh Gupta
@virresh
Mar 14 2018 04:26
Uh
Thanks @jayvdb
But the logs suggest that govetbear failed
I don't think I messed with that file :worried:
John Vandenberg
@jayvdb
Mar 14 2018 04:29
the CI for our bears quite often fails when something changes in a dependency
and we need to understand the problem quickly, fix it, so other work can resume
first thing to check, is whether there is a new version of govet
Viresh Gupta
@virresh
Mar 14 2018 04:30
Ah
Thanks for the pointers :smile:
Ankit Joshi
@MacBox7
Mar 14 2018 05:12
I think this is ready to merge coala/coala-bears#2334 @Makman2 @jayvdb
John Vandenberg
@jayvdb
Mar 14 2018 05:27
need to rebase it @MacBox7
Ankit Joshi
@MacBox7
Mar 14 2018 05:28
Well, I had already rebased it before, to include Circle CI patch.
Ankit Joshi
@MacBox7
Mar 14 2018 05:40
@nvzard do you know why?
Nitanshu
@nvzard
Mar 14 2018 05:44
there might have been a new release
Ankit Joshi
@MacBox7
Mar 14 2018 05:44
What should I do?
John Vandenberg
@jayvdb
Mar 14 2018 05:59
help find the problem and solve it ;-)
Shrikrishna Singh
@sks444
Mar 14 2018 06:05
@jayvdb , can you please take a look at the community channel? :smile:
Ankit Joshi
@MacBox7
Mar 14 2018 06:05
something must have happened with recent commits, nothing wrong with my code. Local machine is skipping GoVotBearTest. Let me check what the problem is.
John Vandenberg
@jayvdb
Mar 14 2018 06:08
you probably dont have go / go vet installed
@sks444 im off to sleep; will peek over there in a few hours
Shrikrishna Singh
@sks444
Mar 14 2018 06:10
Alright; thanks!
Nitanshu
@nvzard
Mar 14 2018 06:47
@MacBox7 but windows built was master branch is passing o.O ?
never mind, it was built 3 days ago
Ankit Joshi
@MacBox7
Mar 14 2018 06:48
Yes, that's what I don't understand. My built is passing on CircleCI and Travis. Issue is with appveyor.
Is go installed in appveyor? Is it meant to be skipped?
Nitanshu
@nvzard
Mar 14 2018 06:50
maybe? I don't have any idea about its dependencies
Ankit Joshi
@MacBox7
Mar 14 2018 06:51
The bear is returning a result for a good file. The local bear 'GoVetBear' yields a result although it shouldn't
Ankit Joshi
@MacBox7
Mar 14 2018 07:25
Unable to recreate the error on my local machine.
Nitanshu
@nvzard
Mar 14 2018 07:27

On a windows machine?

Unable to recreate the error on my local machine.

Ankit Joshi
@MacBox7
Mar 14 2018 07:28
Nah, trying on ubuntu. I know appveyor runs on windows. Don't quite understand what the issue is.
Nitanshu
@nvzard
Mar 14 2018 07:29
you need to test on windows env since only appveyor is failing
Ankit Joshi
@MacBox7
Mar 14 2018 07:29
Is there an online platform to test appveyor build scripts?
Nitanshu
@nvzard
Mar 14 2018 07:32
no idea
John Vandenberg
@jayvdb
Mar 14 2018 07:59
appveyor is an online platform to test appveyor build scripts

Is go installed in appveyor? Is it meant to be skipped?

read the log to find your answers.

Ankit Joshi
@MacBox7
Mar 14 2018 08:03
Logs state that bear is returning result on valid go file. Which shouldn't be a case. I tried it on my local machine and test is passing all right.
Viresh Gupta
@virresh
Mar 14 2018 08:18
@MacBox7 , Try running tests after creating a similar environment as appveyor (in a VM probably).
Nitanshu
@nvzard
Mar 14 2018 08:29
or you can connect to the build using RDP
Ankit Joshi
@MacBox7
Mar 14 2018 11:35
Broken appveyor on master branch fixed, PR needs review coala/coala-bears#2338 @jayvdb @makman2
Ankit Joshi
@MacBox7
Mar 14 2018 16:30
@jayvdb explained the issue coala/coala-bears#2337
John Vandenberg
@jayvdb
Mar 14 2018 16:54
@MacBox7 , you havent explained why the tests passed yesterday (and have worked for months or even years), but are failing now.
Ankit Joshi
@MacBox7
Mar 14 2018 16:55
I wasn't able to figure out that part. I saw few past commits, but there were no modifications in GoVet.
John Vandenberg
@jayvdb
Mar 14 2018 16:56
complicated by the fact that go doesnt do versioning
Ankit Joshi
@MacBox7
Mar 14 2018 16:57
Even why it is working on linux and not on windows, seems a bit weird.
Manan Kalra
@manankalra
Mar 14 2018 17:38
a new go version was released last month
Ankit Joshi
@MacBox7
Mar 14 2018 17:43
The build was working fine 3 days back :smile:
Harsh Kumar Bhartiya
@harshhx17
Mar 14 2018 18:27
@jayvdb Can you please assign this issue to me coala/coala-bears#2006
I need to solve it anyways to be able to upgrade to circleci 2.0 build