These are chat archives for coala/coala-bears

19th
Jul 2018
Rahul Jha
@RJ722
Jul 19 2018 00:32
@MorTD seems like it.
cc @sils
Guangyuan (Charlie) Yang
@yzgyyang
Jul 19 2018 03:05
@MorTD does that solve your problem?
Mor Elmaliach
@MorTD
Jul 19 2018 04:17
No sadly it hasn't, still an issue. I tried manually installing python3-lxml package afterwards, says it's installed already. And still failing to install with the requirements files.
John Vandenberg
@jayvdb
Jul 19 2018 04:33
@satwikkansal @ishanSrt could you review https://gitlab.com/coala/mobans/merge_requests/44
Satwik Kansal
@satwikkansal
Jul 19 2018 06:01
Reviewed
Mor Elmaliach
@MorTD
Jul 19 2018 15:10
Hi guys
I'm still having issues with the lxml installation.. I'm really frustrated because I don't understand what's cuasing this. I installed it manually and it just uninstalls it and tries to install using the pip function from here: https://api.coala.io/en/latest/Developers/Newcomers_Guide.html and it keeps on failing
John Vandenberg
@jayvdb
Jul 19 2018 15:17
lxml is a nightmare. easy fix ... remove it from requirements.txt ;-)
Mor Elmaliach
@MorTD
Jul 19 2018 15:17
oh.
John Vandenberg
@jayvdb
Jul 19 2018 15:17
even better fix .. find out which bear was using it ... and fix the code so it doesnt use lxml ;-)
Mor Elmaliach
@MorTD
Jul 19 2018 15:22

Well I just kept on checking why is that... I finally found a solution:
sudo apt-get install zlib1g-dev

jU

just ran this and it installed ok now