These are chat archives for coala/coala-bears

2nd
Nov 2018
abhay gupta
@abhaygupta97
Nov 02 2018 16:11
when running pip3 install coala-bears, i am getting following error:
Collecting guess-language-spirit~=0.5.2 (from coala-bears)
Could not find a version that satisfies the requirement guess-language-spirit~=0.5.2 (from coala-bears) (from versions: )
No matching distribution found for guess-language-spirit~=0.5.2 (from coala-bears)
How can i solve this error?
John Vandenberg
@jayvdb
Nov 02 2018 16:12
hmm .. what OS are you using ?
abhay gupta
@abhaygupta97
Nov 02 2018 16:13
ubuntu 16.04
John Vandenberg
@jayvdb
Nov 02 2018 16:13
can you do pip3 --version pls
abhay gupta
@abhaygupta97
Nov 02 2018 16:14
pip3 --version gives this: pip 18.1 from /home/abhay/Projects/exp/coala-exp/venv/lib/python3.6/site-packages/pip (python 3.6)
John Vandenberg
@jayvdb
Nov 02 2018 16:15
hmmm ... ^ looks good ... that is strange then ...
abhay gupta
@abhaygupta97
Nov 02 2018 16:18
pip3 install guess-language-spirit gives the same error. I think there is something wrong with this package
John Vandenberg
@jayvdb
Nov 02 2018 17:03
we install it all the time in CI .. but sometimes our CI uses a cached version and we dont notice breakages straight away
Abhinav Kaushlya
@abhishalya
Nov 02 2018 17:42
@abhaygupta97 I tried installing bears using pip. I didn't face any issues
Try using virtualenv