These are chat archives for coala/coala-bears

9th
Dec 2018
Naveen T
@naveentvelu
Dec 09 2018 04:27
Need some help. I am facing some errors while running the pip3 install -r requirements.txt. Error log can be found here https://pastebin.com/di5scNqM
In ignore.txt language check and lxml is listed.
Naveen T
@naveentvelu
Dec 09 2018 04:47
For now, I removed both from bear-requirements.txt. Is there anyother way?
Sladyn
@sladyn98
Dec 09 2018 04:47
sudo apt-get install python-dev try this
Naveen T
@naveentvelu
Dec 09 2018 04:48
It's been already installed.
Sladyn
@sladyn98
Dec 09 2018 04:49
Which python version
Naveen T
@naveentvelu
Dec 09 2018 04:50
python3
For some reason both the errors which I got is included in the ignore.txt file.
Sladyn
@sladyn98
Dec 09 2018 04:52
sudo apt-get install libxml2-dev libxslt1-dev
@sladyn98 It still throws some errors. libxml2-dev : Depends: libicu-dev but it is not going to be installed
Sladyn
@sladyn98
Dec 09 2018 04:59
sudo apt-get install build-essential autoconf libtool pkg-config python-opengl python-imaging python-pyrex python-pyside.qtopengl idle-python2.7 qt4-dev-tools qt4-designer libqtgui4 libqtcore4 libqt4-xml libqt4-test libqt4-script libqt4-network libqt4-dbus python-qt4 python-qt4-gl libgle3 python-dev libssl-dev
try this
Naveen T
@naveentvelu
Dec 09 2018 05:04
I get this error E: Package 'python-imaging' has no installation candidate
Sladyn
@sladyn98
Dec 09 2018 05:09
Try googling this error and then work up backwards
Naveen T
@naveentvelu
Dec 09 2018 05:22
Sure @sladyn98