These are chat archives for coala/coala-bears

18th
Dec 2018
Shivank
@shivank1234
Dec 18 2018 06:24
Does anybody know that the reason why the files of coala-bears package uploaded on the Python Package Index does not match withthe existing coala-bears repo.....?
Naveen Naidu
@Naveenaidu
Dec 18 2018 06:29

@shivank1234 The package uploaded on Python Package Index is outdated. They do not match the files present in the currently working repository. I'm not entirely sure about the reason for this. But I am sure this is not intentional and it is only because the maintainers are busy with other work.

If you want to enjoy the new changes that happen in the repository. You can just fork the repository and easy install it. You can easy install it by using pip install -e .

I presume Maintainers would update the package when they get some free time :)
Shivank
@shivank1234
Dec 18 2018 06:38
Thanks @Naveenaidu Do you know the way to make some changes in the Python Package Index itself,I had an issue related to it?
Naveen Naidu
@Naveenaidu
Dec 18 2018 06:39
I'm not sure about it. IIRC only maintainers have write access to the Python Packages. You would have to talk to @jayvdb if you have some issues related to it :D
Shivank
@shivank1234
Dec 18 2018 06:43
Thanks for the info... :-)
Akhelesh
@Akhelesh
Dec 18 2018 08:54
Can someone please help me with the build issue for this PR coala/coala-bears#2828 I have been at it for hours but unable to figure out why it's failing. I just added the support for pylint's latest version
Abhinav Kaushlya
@abhishalya
Dec 18 2018 13:34
@li-boxuan Even though that, the appveyvor should pass I think, right?
Akhelesh
@Akhelesh
Dec 18 2018 14:03
@abhishalya @li-boxuan Yeah it's the AppVeyor build that's bothering me
Boxuan Li
@li-boxuan
Dec 18 2018 15:03
Okay. @Akhelesh The error is here C:\Python34\lib\site-packages\coalib\testing\LocalBearTestHelper.py:228: in check_invalidity. You need to run pylint locally to verify that. Maybe pylint's behavior has changed.
Akhelesh
@Akhelesh
Dec 18 2018 17:23
@li-boxuan yeah I tried running them locally but though I have coala installed while I run the test it gives the ModuleNotFoundError saying that could not import coalalib...I haven't figured out this part too yet....I am following the documentation too but unable to find out why am I getting these errors