Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 10:31
    codecov[bot] commented #3266
  • 10:27
    codecov[bot] commented #3266
  • 10:26
    codecov[bot] commented #3266
  • 10:25
    tpw56j synchronize #3266
  • 10:00
    agraul commented on 17aa1c4
  • 09:56

    meaksh on main-fix-some-issues-with-tests

    Include grubx86.efi as valid fo… Prevent issues in case request.… Fix tests to use real symlink a… and 2 more (compare)

  • 09:43
    codecov[bot] commented #3266
  • 09:38
    codecov[bot] commented #3266
  • 09:36
    codecov[bot] commented #3266
  • 09:36
    tpw56j synchronize #3266
  • 09:28
    agraul commented on 17aa1c4
  • 07:53
    ckotte commented #3287
  • 07:46
    SchoolGuy commented #3287
  • 07:44
    SchoolGuy commented #3287
  • 07:44
    ckotte commented #3287
  • 07:44
    SchoolGuy commented #3287
  • 07:44
    ckotte commented #3287
  • 07:40
    ckotte commented #3287
  • 06:49
  • Dec 01 17:31
    tondrejk starred cobbler/cobbler
consus
@consus:matrix.org
[m]
Depends on your case
If you don't have any dynamic configuration (like serving something other than Grub or pxelinux or ipxe) then why not
9d0cd7d2
@9d0cd7d2:matrix.org
[m]
hi all, I'm back, I've running cobbler for the last days testing some of their features, and for the moment is working well
One point is that I'm trying to enable serial console on grub over nodes
but I cannot found any field to enable it
Should I configure it on kernel_parameters? my doubts is because searching on /var/lib/cobbler/grub_config/grub/grub.cfg
I found this:
# Serial console
#-------------------------------------------------------------------------------
if [ $serial_console == true -a "$grub_platform" != "efi" ]; then
  # Do not fiddle with console on EFI, this should already be set
  serial --speed=$serial_baud --unit=$serial_line --word=8 --parity=no --stop=1
  terminal_input --append serial
  terminal_output --append serial
  if [ $serial_console == true ]; then
    # This is used in sourced submenus later
    set k_console="console=ttyS${serial_line},${serial_baud}"
  fi

else
  terminal_input console
  terminal_output console
fi
but not sure how to pass the parameter $serial_console
thanks in advance if somebody could give me one tip again!
consus
@consus:matrix.org
[m]
Hmmm
I bet it's autoinstall parameter
I'll check that out
Ah, no
You should fix the template and change serial_confole to true
wait, no
        # store variables for templating
        if system:
            if system.serial_device or system.serial_baud_rate:
                if system.serial_device:
                    serial_device = system.serial_device
                else:
                    serial_device = 0
                if system.serial_baud_rate:
                    serial_baud_rate = system.serial_baud_rate.value
                else:
                    serial_baud_rate = 115200

                if format == "pxe":
                    buffer += "serial %d %d\n" % (serial_device, serial_baud_rate)
                elif format == "grub":
                    buffer += "set serial_console=true\nset serial_baud={baud}\nset serial_line={device}\n" \
                        .format(baud=serial_baud_rate, device=serial_device)
cobbler system edit --name foobar --serial-device 0
Something like this
Or
cobbler system edit --name foobar --serial-baud-rate 115200
consus
@consus:matrix.org
[m]
baud rate shall be used according to your hardware of course
9d0cd7d2
@9d0cd7d2:matrix.org
[m]
I see
thanks again consus
consus
@consus:matrix.org
[m]
My pleasure
consus
@consus:matrix.org
[m]
Aaand we have a bug
serial_baud_rate is 0 if not set
egotthold
@egotthold:matrix.org
[m]
consus let's put it in an issue. I know how to fix it.
consus
@consus:matrix.org
[m]
Inheritance, right?
I made a test
^_^
egotthold
@egotthold:matrix.org
[m]
Thanks 😅
consus
@consus:matrix.org
[m]
Ehm
Shall the serial console be enabled by default?
egotthold
@egotthold:matrix.org
[m]
consus: Nah. Not all devices offer it and thus it should be enabled explicitly in my eyes.
consus
@consus:matrix.org
[m]
Okay another bug
But I believe is has the same root cause
Just need to mention this in the test description
andrewm659
@andrewm659
So i'm getting closer to having debian pxedboot from cobbler, however now the installation is looking for an ISO. I read that someone else put a few entries in the /var/lib/tftpboot/pxelinux.cfg/default along the lines of "set isofile="location://to/iso/file" and then putting another reference on another line. However i'mnot sure where to put these entries in cobbler. Could anyone assist?
egotthold
@egotthold:matrix.org
[m]
There should be a template for that file in case you want to always have them. So just edit the template and they magically appear.
Templates should be at /var/lib/cobbler/templates if I am not mixing things up again.
consus
@consus:matrix.org
[m]
I have a suggestion to move all this to /etc/cobbler/autoinstall since templates is a very, VERY overloaded term
andrewm659
@andrewm659
@egotthold:matrix.org ok i'll check that out. thx!
consus
@consus:matrix.org
[m]
Also moving dhcp.template and other service stuff to /etc/cobbler/integrations won't hurt
andrewm659
@andrewm659
i'm not seeing the file for tftpboot/pxelinux.cfg/default in the templates folder....
consus
@consus:matrix.org
[m]
See /etc/cobbler/boot_loaders_conf
It's pxe menu
AFAIR
pxe_menu.template
pxe_submenu.template
consus
@consus:matrix.org
[m]