These are chat archives for codexa/firetext

16th
Jun 2015
Daniel Huigens
@twiss
Jun 16 2015 12:23
Sorry. No idea, do you think usage statistics have meaningfully changed since https://groups.google.com/forum/#!msg/mozilla.dev.gaia/Htx5ixSPlVI/g9yCRaOwRUYJ ?
We could ask on the forums.
And what are the issues we have on 1.1?
Joshua Smith
@joshua-s
Jun 16 2015 13:49
Some CSP issue with module loading
1 sec
Joshua Smith
@joshua-s
Jun 16 2015 14:10
Here's the adb logcat log
Daniel Huigens
@twiss
Jun 16 2015 19:08
Looks like you would need a Promise polyfill
Daniel Huigens
@twiss
Jun 16 2015 19:16
This message was deleted
Joshua Smith
@joshua-s
Jun 16 2015 20:08
Hmm, do you know of a good one?
Also, what about the csp error?
Or is the promise issue what causes it?
Daniel Huigens
@twiss
Jun 16 2015 20:22
From a cursory look at github I would use this one: https://github.com/jakearchibald/es6-promise/. Functionally they should all be perfectly fine.
I don't know where the csp error is coming from
Joshua Smith
@joshua-s
Jun 16 2015 20:33
That fixed the promise error, but not the csp error
Daniel Huigens
@twiss
Jun 16 2015 20:34
Does the csp error actually mean the app doesn't work?
Joshua Smith
@joshua-s
Jun 16 2015 20:34
Yeah. It just loads a blank white screen
I think the csp error is from module loading
Is there a place where the app loads scripts/styles inline?
I'm poking around
Daniel Huigens
@twiss
Jun 16 2015 20:36
I think it comes from "unsafe-inline" in the default CSP, since we don't specify one: https://developer.mozilla.org/en-US/Apps/Build/Building_apps_for_Firefox_OS/CSP#Default_Policies
You could probably specify one without it, but I don't know if the app actually works without it
The only things that are additionally not allowed without it are <style> and style=""
Does an actual device give you this error? It's pretty weird, you'd expect the default csp to actually work
Joshua Smith
@joshua-s
Jun 16 2015 20:41
Yes, that's where I get the error.
We are subject to the packaged app csp: http://developer.mozilla.org/apps/csp
We cannot loosen it
default-src *; script-src 'self'; object-src 'none'; style-src 'self' 'unsafe-inline'
Daniel Huigens
@twiss
Jun 16 2015 20:47
If you remove 'unsafe-inline' you're actually tightening it
Joshua Smith
@joshua-s
Jun 16 2015 20:48
And that would fix the error?
Daniel Huigens
@twiss
Jun 16 2015 20:49
I think so
Joshua Smith
@joshua-s
Jun 16 2015 20:57
I removed it and nothing changed
The default csp is being forced
Daniel Huigens
@twiss
Jun 16 2015 21:06
Right, that's reasonable. Sounds like a bug to me, can I see a new log.txt?
Joshua Smith
@joshua-s
Jun 16 2015 21:06
sure
With or without the csp change (not that it makes a difference)
Daniel Huigens
@twiss
Jun 16 2015 21:08
Doesn't matter then
Joshua Smith
@joshua-s
Jun 16 2015 21:14
Daniel Huigens
@twiss
Jun 16 2015 21:15
TypeError: translationElement is undefined