These are chat archives for collectiveaccess/support

24th
Mar 2016
mrjayviper
@mrjayviper
Mar 24 2016 00:00
I meant as is
thanks again!
mrjayviper
@mrjayviper
Mar 24 2016 00:13
seems with my preferences and creating a new UI for quick add, it needs to be configured individually? thanks again
Stefan
@stefankeidel
Mar 24 2016 00:54
I bet there's a way to set a default in user_pref_defs.conf but I'd have to look at the code to figure that out. People could still override that default in their preferences, obviously
I haven't actually tried this but my quess is that something like this should work:
quickadd_ca_places_editor_ui = {
  default = your_ui_code
},
that's for places, obviously ...
mrjayviper
@mrjayviper
Mar 24 2016 01:27
-thumbs up-
just another question (sorry!)
if I cannot find an element in the metadata element list, I suppose this is something we cannot modify?
mrjayviper
@mrjayviper
Mar 24 2016 01:37
I'm looking for "registration type" which according to the UI is "Objects Source". But I cannot see an element with similar name
mrjayviper
@mrjayviper
Mar 24 2016 02:15
another question related to above. there is a metadata element called "Object titles". I cannot find it in the metadata element list but it shows up in the UI. By default, it appears on "Object info" section with the label "Title". I copied it to the "Acquisition" section but the label shows up as "Preferred labels". I went to the UI entry in Acquisition to change "Alternate label to place on the bundle" to "my own label" but it still shows up as "Preferred labels".
  1. is this how it should work? i.e. cannot change intrinsic elements even labels?
  1. or perhaps I'm doing it wrong. and in this case, can you please help? thanks again
just a update to my question above. I changed the "alternate label" on "Objects title" inside "Object info" section and the label was changed to "Preferred labels" instead of the actual text I entered. seems like a bug?
mrjayviper
@mrjayviper
Mar 24 2016 03:40
another update. I've removed my changes related to "alternate label" on both "Object info" and "Acquisition" sections and it seems the label is permanently stuck to "preferred labels" now. I've cleared cached and have logged out and logged back in but nothing has changed.
mrjayviper
@mrjayviper
Mar 24 2016 04:24
another update :P I have a list that --appears-- in the metadata element lists (unlike the other 2 above). when I changed the "alternate label" in the UI, nothing happened. Changing primary label on the element properties works though. So I guess my question is: Am I understanding "Alternate label" wrongly? thank you very much for your patience
according to the wiki, alternate labels should override the whatever label is entered in the element property
Stefan
@stefankeidel
Mar 24 2016 11:58
These fields are what we call intrinsics. They're hardcoded and always there. You can change a few properties on UI level but that's about it. You don't have to use them though
As for labels not changing properly -- is your UI locale different than your cataloguing locale by any chance?
alexanderkroh
@alexanderkroh
Mar 24 2016 18:48
@pinkfishies Thanks for the suggestion. Clearing the cache didn't change anything and I've been using the default media_display.conf settings. The solution was to change the value of "representationViewerPrimaryOnly" under objects in detail.conf from 0 to 1. I'm not sure that this was the intended behavior of this setting, but it solves my problem for now.
alexanderkroh
@alexanderkroh
Mar 24 2016 19:22
I spoke too soon, it solves the problem of getting the video to display correctly, but then non-primary representations aren't viewable even though they show up in the carousel.
CollectiveAccess
@collectiveaccess
Mar 24 2016 19:22
Hi Alex
Is this in reference to a problem posted on the forum?
alexanderkroh
@alexanderkroh
Mar 24 2016 19:23
Hi, I didn't see it posted on the forum but haven't looked today
So I think the answer is no
oh sorry, misread your question. No, this hasn't been posted to the forums
CollectiveAccess
@collectiveaccess
Mar 24 2016 19:27
alright I'll look for it in the chat
alexanderkroh
@alexanderkroh
Mar 24 2016 19:27
march 22, 15:28 was my original question