These are chat archives for collectiveaccess/support

5th
Apr 2016
mrjayviper
@mrjayviper
Apr 05 2016 00:20
@stefankeidel Apologies for the late reply. I was away yesterday. It's the "object title" element (intrinsic I suppose since it's not in the metadata element list). can you please explain how to "line up" my locales? Is there an easy way to do this without going through each UI/metadata element? thanks again
mrjayviper
@mrjayviper
Apr 05 2016 00:25
@stefankeidel and it does make sense why it's displaying "Preferred Names". I just understand why it's happening.
Can you please tell me where to find the locale for a UI element? I know there's global one called CA_DEFAULT_LOCALE in setup.php but I've never seen it on a UI element.
mrjayviper
@mrjayviper
Apr 05 2016 02:37
hi again. another question please! :) Elements/containers often have "+" sign to indicate the possibility of adding more. Can I disable this feature? or perhaps just hide "+" sign so I can't add more? thanks again
CollectiveAccess
@collectiveaccess
Apr 05 2016 02:38
yeah
mrjayviper
@mrjayviper
Apr 05 2016 02:38
I've looked at UI/metadata element properties and no property stands out.
CollectiveAccess
@collectiveaccess
Apr 05 2016 02:38
just set the minimum and maximum # of repeats both to one
mrjayviper
@mrjayviper
Apr 05 2016 02:39
-thumbs up- thanks! :)
CollectiveAccess
@collectiveaccess
Apr 05 2016 02:39
That is done at the metadata element level, in the type restrictions. You can vary the max/min values for each binding
which is either confusing or nice
I'm in the "nice" camp
mrjayviper
@mrjayviper
Apr 05 2016 02:40
I can see it now. just didn't stand out at first when going through the properties. perhaps a label change? :)
CollectiveAccess
@collectiveaccess
Apr 05 2016 02:40
It hasn't changed since 2009 I think
Gosh that was a long time ago
mrjayviper
@mrjayviper
Apr 05 2016 02:42
indeed
tony-rc
@tony-rc
Apr 05 2016 05:42
Thanks for the last bit of advice I'm now testing the import process if it can take more. I'm currently experiencing issues with fields in the UI not functioning correctly with a DataType that is 'DateRange'. Only on a few fields it will do the pop-up calendar. I've compared the elements with a working calendar and with those were it does not pop-up. Is there option I'm missing to do? so I can correct the other elements.
CollectiveAccess
@collectiveaccess
Apr 05 2016 11:00
Stupid question I have to ask to start with: are you sure the calendar is enabled for all of those fields?
Stefan
@stefankeidel
Apr 05 2016 11:21
@mrjayviper The alternate UI labels are always going to be saved in the cataloguing locale. Looks like you only have one enabled. If you had more, it would display repeats of the "Alternate label to place on bundle", the "add button" and the "descriptive text for bundle" fields for each cataloguing locale.
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 12:45
Just a quick question: When I edit and save an Access Role it gets all wiped out, leaving the Role with no permissions at all. If I just tick a few of the boxes it can be saved. That made me think it was a problem with my post size in php.ini, but it is set to 512M which should be enough?
CollectiveAccess
@collectiveaccess
Apr 05 2016 12:46
I'd guess you need to up max_input_vars in php.ini
Do you know what it's set to now?
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 12:50
I changed that to 10000 when I set the server up. Should it be even more?
CollectiveAccess
@collectiveaccess
Apr 05 2016 12:50
That should be fine, but up it to 25000 and see if that makes a difference
It's just a limit; making it larger does not consume resources on the server
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 12:52
Ok, I will test that
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 12:59
Nope, didn´t work. Changed max_input_vars and restarted the webserver, but I can´t still change a role without getting all values wiped out.
CollectiveAccess
@collectiveaccess
Apr 05 2016 13:26
Which version are you running?
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 13:28
1.5
CollectiveAccess
@collectiveaccess
Apr 05 2016 13:29
Hmm, how many fields do you have configured? Are there many?
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 13:31
We use the SPECTRUM Meta data set, with some fields of our own
CollectiveAccess
@collectiveaccess
Apr 05 2016 13:32
Can you send me the profile you're using? Or a dump of your database? I don't see this issue on my test system, so I'll have to guess it's something with your specific configuration
gotlandsmuseum
@gotlandsmuseum
Apr 05 2016 13:33
Ok, where do I send it. Is it best to do an export of the Profile?
CollectiveAccess
@collectiveaccess
Apr 05 2016 14:39