These are chat archives for collectiveaccess/support

7th
Apr 2016
mrjayviper
@mrjayviper
Apr 07 2016 00:57
@stefankeidel thank you very much!
  1. I'll look into my configuration now.
  2. any chance of bringing back collapse all feature?
  3. bundle = UI screen?
Stefan
@stefankeidel
Apr 07 2016 01:10
File a JIRA and we'll see what we can do. Probably not any time soon though.
And yeah, try saving that whole screen again, after opening up (and then closing) the settings form for the Related Entities bundle that's missing the sort controls
mrjayviper
@mrjayviper
Apr 07 2016 01:12
another question please. Is it possible to change the date format given by the date picker? it's currently YYYY-MM-DD. Our staff might get confused with the MM-DD part. MON would be better to avoid confusion. I looked at the element properties and the only thing that might affect is a setting called "Does not use locale setting". I do not want to disable this since our locale is defaulted to en_US (for reasons stefan mentioned above) and using US date format will be more confusing. Thanks
@stefankeidel I will try that saving tip for UI screen. thanks
Stefan
@stefankeidel
Apr 07 2016 01:13
No idea if the date picker can be changed. I hate that thing. Typing is so much faster :-) Anyway, @collectiveaccess worked on that recently as far as I know. He'll know more. I remember hacking the old picker to do DD.MM.YYYY for a client back in Germany but that was a while ago
I gotta run -- talk to you tomorrow (I'm sure I'll have 5 new messages when I get up ;-))
mrjayviper
@mrjayviper
Apr 07 2016 05:18
@stefankeidel in regards to image processing, how does CA know which image utility to use if all 4 are available. On my setup, it's currently using ImageMagick. but it seems GMagick, GraphicsMagick and IMagick are possible to use too. thanks
mrjayviper
@mrjayviper
Apr 07 2016 05:49
sorry. I meant only ImageMagick is installed. The other 3 are missing.
mrjayviper
@mrjayviper
Apr 07 2016 05:59
I had a look at setup.php and app/conf/app.conf and I cannot see any setting that lets me choose which utility to use. thanks again
jessica-s
@jessica-s
Apr 07 2016 06:00
Hi there. I'm still trying to assign alternate labels to several bundles via UI, some with type restrictions . It seems my system has decided to not update it on the object screen side, since about last week. @mrjayviper has tired multiple PCs/macs and he can see the label change since he changed the locale settings as you advised @stefankeidel. But the changes aren't happening on my side, even though you can see it in the UI equivalent: http://imgur.com/a/IXLtu . I've tried on multiple computers in my office, on chrome, safari and firefox.. and at work and home. I am working on a mac. @mrjayviper tried on a mini mac and that was fine. I've cleared the caches etc, nothing to show. Any suggestions? Thanks again for all your help, hopefully we'll slow down on the questions in the next week or so.. but then the pawtucket questions might start... Cheers, Jess :)
mrjayviper
@mrjayviper
Apr 07 2016 06:10
in addition to what jess has said, this is what I see on my macbook. I've also tried on a macmini and my colleague's Dell laptop and it works fine for us. ps. I've changed the alternate label from "Title jl" to "Title" AFTER jessica made her screenshot.
http://i.imgur.com/w21ofeN.jpg
jessica-s
@jessica-s
Apr 07 2016 06:19
there you go there's 5 new messages as you predicted @stefankeidel
Stefan
@stefankeidel
Apr 07 2016 11:13
@jessica-s my guess is you have the UI locale set to en_AU for your account. Try setting it to en_US (which I believe is supposed to be you default now) under Manage > My preferences > General. Also nuking the cache under app/tmp can't hurt. It'll kill all sessions, so everyone is going to have to log back in again, but maybe there's something odd stuck in there.
@mrjayviper if all are installed they're used in this order: GMagick > GraphicsMagick > Imagick > ImageMagick > GD
there's a switch in app.conf that lets you disable imagick because that has caused problems (PHP crashing) in the past. Other than that you can control which one is used by pointing the path in external_applications.conf to something non-existent. If you have gmagick installed, it'll always be used. No way around i. I don't think we've ever seen gmagick cause problems but I could be wrong.
mrjayviper
@mrjayviper
Apr 07 2016 23:58
@stefankeidel thank you :)