These are chat archives for collectiveaccess/support

29th
Apr 2016
ericwm
@eriwm
Apr 29 2016 10:43
Hello I am using providence-develop and my data import templates that i used in 1.6.1 won't upload anymore
Stefan
@stefankeidel
Apr 29 2016 10:47
Something must be off in those mappings then. Is there anything in the logs in app/log?
ericwm
@eriwm
Apr 29 2016 11:20
There is nothing in the app/log these are exactly the same mappings I used in 1.6.1 report just says 0 uploaded file skipped
Stefan
@stefankeidel
Apr 29 2016 11:21
Can you make sure app/log is writable by the web server and try again? It should log something.
Your mappings might have had errors or problems that went unnoticed in the older version. Or something in the importer could have changed -- I don't know
ericwm
@eriwm
Apr 29 2016 11:22
Ok will look at app/log and get back to you tks.
Stefan
@stefankeidel
Apr 29 2016 11:23
Loading the mappings by command line will also show you any warnings/messages right there
ericwm
@eriwm
Apr 29 2016 11:33
app/log permission not set properly fixed and can now see import error log shows media permissions set incorrectly. I will fix this and it should then work. Thank You
ericwm
@eriwm
Apr 29 2016 11:59
This is the error shown in log Error creating mapping: Could not create subdirectory for uploaded file in /var/www/providence-develop/media/collectiveaccess/workspace. Please ask your administrator to check the permissions of your media directory. There is no /workspace, do I need to create this myself?
CollectiveAccess
@collectiveaccess
Apr 29 2016 11:59
Yes, it should be in your media folder
Eg /var/www/providence-develop/media/collectiveaccess/workspace should exist and be writable by the web server
The recent change causing this is a new feature that stores the uploaded mapping file, enabling you (or any other user) to download it later
This ends up being very useful for modifying mappings after the original author has quit :-)
ericwm
@eriwm
Apr 29 2016 12:00
Ok the workspace does not exist I will create one Thanks again
CollectiveAccess
@collectiveaccess
Apr 29 2016 12:01
The workspace dir should have been created by default
I'll check to make sure that's still happening on newly installed systems
ericwm
@eriwm
Apr 29 2016 12:08
Created /workspace and importer now working ok Tks
CollectiveAccess
@collectiveaccess
Apr 29 2016 12:22
great