These are chat archives for collectiveaccess/support

8th
Jun 2016
ericwm
@eriwm
Jun 08 2016 11:39

Hi, I am really struggling with this one just cannot seem to find what's wrong with my importer This is the error log after attempting an import it always hangs at line 129. I have checked my mapping using Jasonlint and it passes. I have also checked my data for hidden spaces characters etc., but could not find any.. 2016-06-08 13:04:32 - DEBUG --> Started reading row 128 at 0.0000 seconds
2016-06-08 13:04:34 - INFO --> Created new list item Fadeometer/Fadeometer/Fadeometer in list Textile_types
2016-06-08 13:04:34 - DEBUG --> Finished building content tree for % at 2.2165 seconds [128]
2016-06-08 13:04:34 - DEBUG --> Content tree is
Array
(
)

2016-06-08 13:04:34 - DEBUG --> Started reading row 129 at 0.0000 seconds Sorry dragged the Textile types.xlsx on by mistake . I am using the .ods version. I would appreciate any help with this. Eric

kaiall
@kaiall
Jun 08 2016 17:34
Suddenly, today, we cannot attach images in the media tab. They're jpgs. (small ones - 86 kb). They were working fine yesterday, but not today. We cannot import these images either. The error we get is this: [/83.1.9.jpg]: Error importing 83.1.9.jpg from : Unknown file type not accepted by media -- what could be the issue? They were taken on a DSLR, batch resized in Irfanview, and the first 8 images in the batch uploaded fine (yesterday).
(We have not changed anything in our CollectiveAccess installation since yesterday.)
CollectiveAccess
@collectiveaccess
Jun 08 2016 17:37
Try uploading one that worked yesterday. Does it work today?
kaiall
@kaiall
Jun 08 2016 17:37
One sec
No, that does not work. Same error.
kaiall
@kaiall
Jun 08 2016 17:52
(Our host did upgrade our MySQL to 5.6 (I think), but that was a week ago and things have otherwise been fine.)
Julia
@juliaweist
Jun 08 2016 20:32
@eriwm It doesn't look like it's an issue with your mapping. We'll look into DRY RUN to make sure that's functioning correctly. In the meantime, if you need to get this data migrated immediately you could always use caTools. http://docs.collectiveaccess.org/wiki/CaTools
make-list-from-excel will create the list in proper profile syntax. You can add that to an in-progress profile, or load it into an existing system via update-installation-profile (http://docs.collectiveaccess.org/wiki/Update_installation_profile)
ericwm
@eriwm
Jun 08 2016 21:03
Thanks for the feedback Julia. I am not in a hurry at the moment. I might mention that if I import one of my lists that work ok and use Dry Run then the error log shows Rollback successful but the imported data is still in the database.
kaiall
@kaiall
Jun 08 2016 22:53
So I just tried uploading a pdf - it uploaded fine, but did not generate the previews. Does this point to being an issue with ImageMagick, you think? (That's the only image-specific media processing plugin we have enabled.) And perhaps that something changed with how our host has that configured? It still shows up as available in the configuration page.