These are chat archives for collectiveaccess/support

7th
Mar 2017
naeemmuhammad
@naeemmuhammad
Mar 07 2017 14:07

We have some trouble in displaying interstitial data by using display templates in pawtucket2.
We have a field ‘Author’ with element code ‘marc700’, which consists of a container with element code ‘marc700_line1’, this container subsequently consists of an element with code ‘marc7009’ of type ‘Text’. This field is bounded to ‘object<=>entity’ relationship. We use ‘Author’ to fill in relationship data on a relationship screen (interstitial). When we access this field on object detail page in Pawtucket2 nothing appears, although data is shown correctly in Collective Access (version 1.6.1).
In Pawtucket2 object detail page (\views\Details\ca_objects_default_html.php) we use the following display :
{{{
<unit relativeTo="ca_entities" restrictToRelationshipTypes="aut" delimiter="<br>">
^ca_entities.preferred_labels
<unit relativeTo="ca_objects.related" delimiter=", ">
^ca_objects.marc700.marc7009
</unit>
</unit>
}}}

Type restriction “aut” (restricting results to a particular author type) is working and preferred labels of entities are displayed correctly. However, the second ‘<unit>’ tag gives no results. With this tag we want to show the ‘Author’ interstitial information. We tried various combinations in ‘relativeTo’ attribute but no success. We used examples given in the documentation, but nothing worked. Any help to solve this problem?

Julia
@juliaweist
Mar 07 2017 14:48
@artvrc only if you're using the overwrite or replace settings. Try none or merge
brunocalado
@brunocalado
Mar 07 2017 17:47
Demo is no long working. http://demo.collectiveaccess.org/index.php/system/auth/login error: Could not load language 'pt_BR'
Julia
@juliaweist
Mar 07 2017 18:14
@brunocalado sorry about that! Should be back up now.
brunocalado
@brunocalado
Mar 07 2017 19:38
The same happen to my instalation. How do I fix?
Thank you
Julia
@juliaweist
Mar 07 2017 21:04
Are you trying to use the Portuguese (Brazil) translation? Please provide some info about your set up
artvrc
@artvrc
Mar 07 2017 21:48
I am trying to make the object <--> occurrence relationships work. I have included Related Objects in the occurrence UI, but it's not pulling up the occurrence record that is chosen in the object record. I have tried restricting the relationship type on the occurrence UI too, but no luck. What am I missing??
Julia
@juliaweist
Mar 07 2017 22:10
Have you tried removing all restrictions? Type and relationship type?
artvrc
@artvrc
Mar 07 2017 22:15
Screen Shot 2017-03-07 at 12.14.23 PM.png
Screen Shot 2017-03-07 at 12.14.08 PM.png
Yes, no restrictions are selected.