These are chat archives for collectiveaccess/support

4th
May 2017
Kehan Harman
@kehh
May 04 2017 01:55
@TBthegr81 There is a permission in the roles actions screen, so I'd suggest you create a role for 'Web Service Users' that has the action 'Use JSON * service' along with the action things you want that role to do (eg 'Edit occurrence', 'Search occurrences').
sathishlmt
@sathishlmt
May 04 2017 06:40

I installed providence CollectiveAccess 1.7 .After i goto login page and login with above login credential. But its show the following error

   Not Found

The requested URL /system/Auth/DoLogin was not found on this server.

I TRIED LOT OF TIMES . BUT SHOW SAME ABOVE ERROR.

Please help me .

Kehan Harman
@kehh
May 04 2017 08:07
@sathishlmt have you got the apache rewite module enabled? You can enable it using sudo a2enmod rewrite on debian/ubuntu systems.
sathishlmt
@sathishlmt
May 04 2017 08:09
i got . anyway tnks fa yur replay ... solution is define("CA_USE_CLEAN_URLS", 0);
TBthegr81
@TBthegr81
May 04 2017 09:13
If ya wanna use CA_USE_CLEAN_URLS ya need to set "AllowOverride All" in the <Directory> settings in your Apache-site config. (Or set it via .htaccess) And also enable rewrite module.
Keskora
@Hyperchema
May 04 2017 16:54
Hello! I've just got providence and pawtucket both installed but it seems that they were installed without the Dublin Core profile. I've seen that the best option to get that enabled is to simply reinstall providence. I was wondering if there was any trick to doing this? Will I need to reinstall pawtucket too?
ThunderTurtles
@ThunderTurtles
May 04 2017 18:15
@Hyperchema the path to the profile configuration installer is your_system_url/install. That should open up a screen with all of the available profiles from Git. Once you have loaded a profile you want, be sure to disable the profile installer in setup.php so it can't be overwritten.
Keskora
@Hyperchema
May 04 2017 18:28
@ThunderTurtles I tried that but it's saying that the tables and such already exist. Does this mean i need to build a new database or completely wipe the current one?
ThunderTurtles
@ThunderTurtles
May 04 2017 18:44
@Hyperchema What does it say exactly? If it says "There were errors loading the database schema: Table ca_acl already exists; have you already installed CollectiveAccess?" that means your setup.php already has the installer overwrite setting disabled. Set the following to true: if (!defined('CA_ALLOW_INSTALLER_TO_OVERWRITE_EXISTING_INSTALLS')) {
define('CA_ALLOW_INSTALLER_TO_OVERWRITE_EXISTING_INSTALLS', true);
}
Keskora
@Hyperchema
May 04 2017 18:44
where would i put that code?
ThunderTurtles
@ThunderTurtles
May 04 2017 18:45
It should already be around line 369 in setup.pho
setup.php that is
just switch 'false' to 'true' (you dont need to copy the whole string, it's already there)
Keskora
@Hyperchema
May 04 2017 18:50
Okay cool and with that I then just run the installer again?
ThunderTurtles
@ThunderTurtles
May 04 2017 18:54
Yes, choosing whichever profile you like. You can re-run this as many times as you want to check out different configurations. Once you land on one or go "live", be sure to disable the installer override again.
juanulload
@juanulload
May 04 2017 20:13
Hi, i'm trying to install providence 1.6.3 in a system with php 5.4.35. According to the providence documentation, thats the correct version of php, but i keep getting an error message that put "Your PHP installation lacks MySQL support. Please add it and retry...". Some advice?