These are chat archives for collectiveaccess/support

20th
Apr 2018
murchmurch
@murchmurch
Apr 20 2018 06:29

Hi! Im trying to import images into CA and extracting metadata using the EXIF tool. When i run the import i get this log: 2018-04-20 8:17:12 - INFO --> Found 2 files in directory 'H:/xampp/htdocs/providance17/import/mia'
2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_exactly
2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
2018-04-20 8:17:12 - DEBUG --> Names to match: Array
(
[0] => mia
)

2018-04-20 8:17:12 - DEBUG --> Matched name mia on regex ^(.*)$
2018-04-20 8:17:12 - DEBUG --> Trying to find records using boolean OR and values Array
(
[idno] => mia
)

2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_without_extension
2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
2018-04-20 8:17:12 - DEBUG --> Names to match: Array
(
[0] => mia
)

2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9]+$
2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_with_page_number_included
2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
2018-04-20 8:17:12 - DEBUG --> Names to match: Array
(
[0] => mia
)

2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?.[A-Za-z0-9-]+).[A-Za-z]+$
2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
2018-04-20 8:17:12 - DEBUG --> Names to match: Array
(
[0] => mia
)

2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9]+$
2018-04-20 8:17:12 - DEBUG --> Processing mediaFilenameToObjectIdnoRegexes entry filename_with_page_number
2018-04-20 8:17:12 - DEBUG --> Trying to match on directory 'mia'
2018-04-20 8:17:12 - DEBUG --> Names to match: Array
(
[0] => mia
)

2018-04-20 8:17:12 - DEBUG --> Couldn't match name mia on regex (.*?).[A-Za-z0-9-]+.[A-Za-z]+$
2018-04-20 8:18:41 - INFO --> Started import of H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg using mapping 1234
2018-04-20 8:18:41 - ERROR --> Could not read source H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg (format=exif)
2018-04-20 8:18:41 - INFO --> Importerade UlfWickbom_text.jpg som UlfWickbom_text.jpg

As you can see the Files are found in the folder but when the EXIF part of the opoeration is run it can no longer find the file:
2018-04-20 8:17:12 - INFO --> Found 2 files in directory 'H:/xampp/htdocs/providance17/import/mia'
2018-04-20 8:18:41 - INFO --> Started import of H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg using mapping 1234
2018-04-20 8:18:41 - ERROR --> Could not read source H:/xampp/htdocs/providance17/import/mia/UlfWickbom_text.jpg (format=exif)
2018-04-20 8:18:41 - INFO --> Importerade UlfWickbom_text.jpg som UlfWickbom_text.jpg

Do i have to speciy something special in the maping file for the file location to make it work? I get the same behavior on a Ubuntu system...

murchmurch
@murchmurch
Apr 20 2018 07:01
An uppdate: If i configure the media_metadata.conf file to import the metadata it works as a charm.. But this does not give me the specific specific control that the import file gives. Any ie whats going on?
CollectiveAccess
@collectiveaccess
Apr 20 2018 10:25
@murchmurch How are you enabling EXIF processing in the importer?
murchmurch
@murchmurch
Apr 20 2018 14:14
@collectiveaccess : I have created a Data mapping excell that has EXIF as Imput Format and im using the media import setting "Extract embedded metadat object using mapping"
Extract embedded metadata into objekt using mapping.jpg
Data import Maping.jpg