These are chat archives for collectiveaccess/support

31st
Oct 2018
Dirar Abu Kteish
@dirar
Oct 31 2018 11:13
Hello, I am trying to write a script based on collective access. Is there a was to see if the current user is authenticated?
Julia
@juliaweist
Oct 31 2018 14:31
@murchmurch this is not a known bug, can you provide more info about your config?
murchmurch
@murchmurch
Oct 31 2018 15:39
@juliaweist What info do you need? im running 1.7.3 and i have set the preform_source_access to 1 in app config. Majorety of the objects have one of the predefined system source : "Our Collection". I have now created a second source "company 2" and i have created 2 access roles, one that has acces to the "Our Collection" and the second to have acces to the "conmpany2" objects (acces roles/sources tab). The issue is that the user taht has the "Our Collection" Acces role does not see any objects, but the user that has "company2" sees the "company2" objects (as expected). The same applys to all the other typs such as places,enteties etc. It seems that the "default" souces are not behaving in the same way as the newly created. The only user who now can see the "Our Collection" objects is the admin user, but that user bypases the source control as i understand.
Julia
@juliaweist
Oct 31 2018 19:26
Are the default list items and those newly created the same in all ways, for example, all have an item value, etc.?
murchmurch
@murchmurch
Oct 31 2018 19:34
Yes, all have all values filled in. both the newly created and the old ones.