Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Jesse
    @blackadder78
    I'm currently trying to upload a batch of PDF's into CollectiveAccess, some of which are quite large. When I try to upload a PDF that has more than 500 pages, the derivatives of the PDF cut off at the 500 page mark. I'm guessing by the roundness of the number that the system is set to do this. Is this a setting that can be adjusted in CollectiveAccess?
    CollectiveAccess
    @collectiveaccess
    in app.conf set the document_preview_max_number_of_pages
    by default it's set to 500
    Jesse
    @blackadder78
    Thanks! That should solve it.
    Kehan Harman
    @kehh
    In case anybody's had queries about the performance of image manipulation, I just did an import of 25000 images, and using the graphicsmagick adaptor this was estimated to take about 12 days to complete. When I installed the gmagick adaptor this came down to 6 hours, so (I know it says so in the documentation), definately try to use the gmagickadaptor.
    And on a similar note, large printed reports using dompdf were not rendering over 24 hours, but upon installing wkhtmltopdf this came down to under a minute.
    Barbara Krautgartner
    @babslgam
    regarding "item-level data" documentation says: "Note that instead of using the primary key identifier you can use a record's idno for the "id" parameter"
    do i have to change any settings to make this work?
    Kehan Harman
    @kehh
    you can certainly get to an object via it's idno directly out of the box, but your idno has to be non-numeric.
    Also the default config allows for duplicate idno's with a warning.
    I'm unsure if it's possible to configure CA to always use idno instead of id for all internal links.
    Barbara Krautgartner
    @babslgam
    @kehh you already helped me a lot. thanks :-)
    Kehan Harman
    @kehh
    :+1:
    Mike Jones
    @mikejonesmelb_twitter
    Hi there. We are trying to import largish (10-30MB) tifs into CA and after successfully processing a few (usually somewhere between 5 and 20 files) it then throws out the rest of the processing queue with the following DEBG error message for each photo remaining: Record ca_object_representations.field = file '/var/www/html/providence/media/bsv_collectiveaccess/images/7/51016_ca_object_representations_media_773_original.tiff' did not exist; queued file was discarded
    FYI, it does upload the original files (the tifs), it's the tilepic, large, medium, small, thumbnail etc. versions that don't get created.
    Sophie
    @pinkfishies
    @mikejonesmelb_twitter If the original tiffs are making it through you can use the reprocess-media tool to create the versions you need
    JD
    @OldKingHenry_twitter
    Hello. Does collectiveaccess support onsite storage? Some of my clients don't like their "stuff" in the cloud. Is this an option?
    Sophie
    @pinkfishies
    @OldKingHenry_twitter You can host collectiveaccess on any webserver, or a local network
    Full system requirements are detailed here: http://docs.collectiveaccess.org/wiki/Requirements
    JD
    @OldKingHenry_twitter
    thank you Sophie
    Mike Jones
    @mikejonesmelb_twitter
    @pinkfishies thanks Sophie!
    Kehan Harman
    @kehh
    Just letting everyone know that the Royal Western Australian Historical Society collection has just gone live in CollectiveAccess. View the research frontend here: https://research.histwest.org.au.
    Kehan Harman
    @kehh
    Hey all. Is there any way to search for blank dates in attributes? I've just seen that there is [BLANK] which appears to work for text fields like this: ca_objects.idno:"[BLANK]"(http://docs.collectiveaccess.org/wiki/Search_Syntax#Searching_for_blank_values)
    And reading a paragraph below that, this is probably covered by the count modifier (http://docs.collectiveaccess.org/wiki/Search_Syntax#Searching_for_counts), available from 1.7.
    Sophie
    @pinkfishies
    @kehh Great, would you like the project to be added to our official list of CA users?
    [BLANK] is a value assigned to certain intrinsic fields when they are not set, such as preferred labels and identifiers (this wouldn't affect dates) - and unfortunately the count modifier is only tracked for relationships
    have you tried ca_objects.mydate:null ?
    Julia
    @juliaweist
    @kehh congrats on the launch!
    Kehan Harman
    @kehh
    Thanks @pinkfishies please go ahead and add it to the official list. ca_objects.mydate:null doesn't appear to work. Searching for ca_table.attribute:[BLANK] works for text, georeference, currency, weight, length and URL attributes as per the test here: https://github.com/collectiveaccess/providence/blob/bfb71ef8c06adb0e1b7dcdbc0c772d6aa790bfe2/tests/testsWithData/queries/AttributeValueSearchQueryTest.php#L185-L208. Anyway it doesn't appear to be supported by date attributes.
    Sophie
    @pinkfishies
    @kehh Ok the project is added to the users list! Unfortunately I couldn't find a way to run a successful "no date" search, but I'll follow up with Seth to see if we can devise a solution
    Kehan Harman
    @kehh
    Thanks @pinkfishies. I've created a feature request in jira http://clangers.collectiveaccess.org/jira/browse/PROV-1803
    naeemmuhammad
    @naeemmuhammad
    Hi, How can i customize advanced search form in Pawtucket2? I need additional controls like checkbox, drop down and tabs.
    Mike Benowitz
    @mwbenowitz
    This message was deleted
    Mike Benowitz
    @mwbenowitz

    Hi @naeemmuhammad you can create a custom advanced search in the search.conf file (see http://docs.collectiveaccess.org/wiki/Pawtucket2:Advanced_Search for a description)

    You can then create the new form named in the view = field of your newly defined search using display bundles. To define a checkbox add render=is_set to the end of the bundle specifier (e.g. ca_objects.public_access%render=is_set). Adding a search field for a field controlled by a list or set vocabulary will automatically populate as a dropdown.

    naeemmuhammad
    @naeemmuhammad
    @mwbenowitz thanks. What should be the value of the render element for rendering a radio button and tabs?
    Mike Benowitz
    @mwbenowitz
    @naeemmuhammad the render value for radio buttons is radio_buttons
    and sorry, but not sure what you mean by tabs
    naeemmuhammad
    @naeemmuhammad
    Sorry perhaps i should have been more specific. Tab control, where we can display multiple sheets(panels) on top of each other. Each panel contains a set of html elements. Such as: https://api.jqueryui.com/tabs/#entry-examples
    Sophie
    @pinkfishies
    @naeemmuhammad You can simply format the advanced search view to work with the jquery ui tabs
    You can use any php/html throughout the view as you would on any other page. Just the advanced search form adheres to the specialized markup
    Perry Roth-Johnson
    @perryrothjohnson
    Hi, today my CA install started spitting out a proxy error, saying the proxy server received an invalid response from an upstream server, could not handle the request GET, and the reason was an error reading from remote server ... any ideas? I'm running CA 1.6.1 on a Red Hat OpenShift server. I tried restarting the server and tidying up logs and temp files, but no dice.
    weird, it just started working again
    but this has been an intermittent problem that pops up every few days ... anyone else having the same issue?
    Perry Roth-Johnson
    @perryrothjohnson
    Sophie
    @pinkfishies
    @perryrothjohnson Glad you resolved the issue!
    mrjayviper
    @mrjayviper
    please refer to these 2 pictures:

    http://imgur.com/DJTJbZN
    http://imgur.com/ELKRgN0

    as you can see from the 1st pic, the location info below "Edit Art" (top left) is stuck to the previous location and not the current location. How do I fix this? We're using movement location tracking if that makes a difference. Thanks

    Barbara Krautgartner
    @babslgam
    when using web service api how can i enable sorting by values from datatype list?
    naeemmuhammad
    @naeemmuhammad

    I am using ajax requests on some html components in one of my search views in Pawtucket2. Ajax calls another view in the same directory (views/Search), however requests are returned with a view containing header and footer. How can I integrate ajax calls in views and receive response without header and footer?
    Example:
    I have a drop down box in advanced search view (/views/Search/ ca_objects_advanced_search_objects_html.php). When an item in the drop down box is selected an ajax request to selection.php is made. Code in selection.php does some processing on the ajax request and returns some data that will be used to populate some additional html components in advanced search view. Ajax call is successfully made to selection.php, however response of the request contains a full view with header and footer.

    Thanks.

    CollectiveAccess
    @collectiveaccess
    The header and footer should be automatically omitted for ajax request. Do your ajax requests include a HTTP_X_REQUESTED_WITH header set to XMLHttpRequest?